summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKenjiTakahashi2020-12-03 16:23:37 +0100
committerKenjiTakahashi2020-12-03 16:23:37 +0100
commit6a28b36593b4f43236da1aeb7f9bd1d0d4d94940 (patch)
tree86ab64ef7ff1781604331c04d36cad34b71afc5a
parent1d7fc35fbbc91c0f031388f5c458a575d7006ee8 (diff)
downloadaur-6a28b36593b4f43236da1aeb7f9bd1d0d4d94940.tar.gz
6.1.16-1: Bumped version
-rw-r--r--.SRCINFO16
-rw-r--r--019-python3.9.patch101
-rw-r--r--020-gsoap.patch13
-rw-r--r--021-kernel-5.9.patch189
-rw-r--r--PKGBUILD14
5 files changed, 114 insertions, 219 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4ff19407a5a..ca2c5face639 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = virtualbox-headless
pkgdesc = Powerful x86 virtualization for enterprise as well as home use. Headless build (no GUI, no Java).
- pkgver = 6.1.14
- pkgrel = 2
+ pkgver = 6.1.16
+ pkgrel = 1
url = https://virtualbox.org
install = virtualbox.install
arch = i686
@@ -28,13 +28,13 @@ pkgbase = virtualbox-headless
optdepends = virtualbox-guest-iso: Guest Additions CD image
optdepends = virtualbox-ext-vnc: VNC server support
optdepends = virtualbox-sdk: Developer kit
- provides = virtualbox=6.1.14
+ provides = virtualbox=6.1.16
conflicts = virtualbox-ose
conflicts = virtualbox
replaces = virtualbox-ose
replaces = virtualbox
backup = etc/vbox/vbox.cfg
- source = https://download.virtualbox.org/virtualbox/6.1.14/VirtualBox-6.1.14a.tar.bz2
+ source = https://download.virtualbox.org/virtualbox/6.1.16/VirtualBox-6.1.16.tar.bz2
source = virtualbox.sysusers
source = 60-vboxdrv.rules
source = 60-vboxguest.rules
@@ -49,9 +49,8 @@ pkgbase = virtualbox-headless
source = 013-Makefile.patch
source = 017-fix-narrowing-conversion.patch
source = 018-xclient.patch
- source = 020-gsoap.patch
- source = 021-kernel-5.9.patch
- sha256sums = 16f3cb83ab3c4dacf2a9d3cc638cbd18db23767828bba6b8ba1c1b57abeb6aef
+ source = 019-python3.9.patch
+ sha256sums = 49c1990da16d8a3d5bda8cdb961ec8195a901e67e4c79aea44c1521a5fc2f9f1
sha256sums = 2101ebb58233bbfadf3aa74381f22f7e7e508559d2b46387114bc2d8e308554c
sha256sums = 9c5238183019f9ebc7d92a8582cad232f471eab9d3278786225abc1a1c7bf66e
sha256sums = 033c597e0f5285d2ddb0490868e5b6f945f45c7b1b1152a02a9e6fea438b2c95
@@ -66,8 +65,7 @@ pkgbase = virtualbox-headless
sha256sums = da7e58ed37dc23c6202aab3017864579a99e78417f3421ddcc98a198198fe2c9
sha256sums = 5aac692909a0a0ec56b08bdece9e42cf7463abdca9da2f990d441ff463be6a99
sha256sums = cac5a573e9ed5aafb2f469c2e6fffb8cd4f389bbadba5a968c9f65be7a72fee3
- sha256sums = c6892a3561a72a9b308cb33fa6647cc53e54a3bd40cb41780cad7f8e9d7df9f6
- sha256sums = 05bfc8306bbd856087c393dcb47d16de4213a4cc69124857f705f3784d88581a
+ sha256sums = 039c7b520ae589bc52dc6c0e658f7ec28ca8defb12ccbc32ad9834361d23162c
pkgname = virtualbox-headless
diff --git a/019-python3.9.patch b/019-python3.9.patch
new file mode 100644
index 000000000000..c8006d30510c
--- /dev/null
+++ b/019-python3.9.patch
@@ -0,0 +1,101 @@
+--- ./src/libs/xpcom18a4/python/gen_python_deps.py.orig 2020-06-01 05:15:00.905907651 +0100
++++ ./src/libs/xpcom18a4/python/gen_python_deps.py 2020-06-01 05:15:48.161226499 +0100
+@@ -16,7 +16,7 @@ from __future__ import print_function
+ import os,sys
+ from distutils.version import StrictVersion
+
+-versions = ["2.6", "2.7", "3.1", "3.2", "3.2m", "3.3", "3.3m", "3.4", "3.4m", "3.5", "3.5m", "3.6", "3.6m", "3.7", "3.7m", "3.8", "3.8m" ]
++versions = ["2.6", "2.7", "3.1", "3.2", "3.2m", "3.3", "3.3m", "3.4", "3.4m", "3.5", "3.5m", "3.6", "3.6m", "3.7", "3.7m", "3.8", "3.8m", "3.9", "3.9m" ]
+ prefixes = ["/usr", "/usr/local", "/opt", "/opt/local"]
+ known = {}
+
+--- ./configure.orig 2020-06-01 01:15:53.880747364 +0100
++++ ./configure 2020-06-01 01:17:42.231478707 +0100
+@@ -1992,7 +1992,7 @@ extern "C" int main(void)
+ }
+ EOF
+ found=
+- SUPPYTHONLIBS="python2.7 python2.6 python3.1 python3.2 python3.3 python3.4 python3.4m python3.5 python3.5m python3.6 python3.6m python3.7 python3.7m python3.8 python3.8m"
++ SUPPYTHONLIBS="python2.7 python2.6 python3.1 python3.2 python3.3 python3.4 python3.4m python3.5 python3.5m python3.6 python3.6m python3.7 python3.7m python3.8 python3.8m python3.9 python3.9m"
+ for p in $PYTHONDIR; do
+ for d in $SUPPYTHONLIBS; do
+ for b in lib/x86_64-linux-gnu lib/i386-linux-gnu lib64 lib/64 lib; do
+--- ./src/libs/xpcom18a4/python/Makefile.kmk.orig 2020-06-01 05:16:07.610357728 +0100
++++ ./src/libs/xpcom18a4/python/Makefile.kmk 2020-06-01 05:22:44.735037239 +0100
+@@ -26,7 +26,7 @@ endif
+
+ #
+ # List of supported Python versions, defining a number of
+-# VBOX_PYTHON[26|27|31|32|32M|33|33M|34|34M|35|35M|36|36M|37|37M|38|38M|DEF]_[INC|LIB] variables
++# VBOX_PYTHON[26|27|31|32|32M|33|33M|34|34M|35|35M|36|36M|37|37M|38|38M|39|39M|DEF]_[INC|LIB] variables
+ # which get picked up below.
+ #
+ ifeq ($(KBUILD_TARGET),darwin) # Relatively predictable, don't script.
+@@ -532,6 +532,52 @@ VBoxPython3_8m_x86_LIBS = $(VBOX_P
+ endif
+ endif
+ endif
++
++ifdef VBOX_PYTHON39_INC
++#
++# Python 3.9 version
++#
++DLLS += VBoxPython3_9
++VBoxPython3_9_EXTENDS = VBoxPythonBase
++VBoxPython3_9_EXTENDS_BY = appending
++VBoxPython3_9_TEMPLATE = XPCOM
++VBoxPython3_9_INCS = $(VBOX_PYTHON39_INC)
++VBoxPython3_9_LIBS = $(VBOX_PYTHON39_LIB)
++
++ ifdef VBOX_WITH_32_ON_64_MAIN_API
++ ifdef VBOX_PYTHON39_LIB_X86
++DLLS += VBoxPython3_9_x86
++VBoxPython3_9_x86_EXTENDS = VBoxPythonBase_x86
++VBoxPython3_9_x86_EXTENDS_BY = appending
++VBoxPython3_9_x86_TEMPLATE = XPCOM
++VBoxPython3_9_x86_INCS = $(VBOX_PYTHON39_INC)
++VBoxPython3_9_x86_LIBS = $(VBOX_PYTHON39_LIB_X86)
++ endif
++ endif
++endif
++
++ifdef VBOX_PYTHON39M_INC
++#
++# Python 3.9 version with pymalloc
++#
++DLLS += VBoxPython3_9m
++VBoxPython3_9m_EXTENDS = VBoxPythonBase_m
++VBoxPython3_9m_EXTENDS_BY = appending
++VBoxPython3_9m_TEMPLATE = XPCOM
++VBoxPython3_9m_INCS = $(VBOX_PYTHON39M_INC)
++VBoxPython3_9m_LIBS = $(VBOX_PYTHON39M_LIB)
++
++ ifdef VBOX_WITH_32_ON_64_MAIN_API
++ ifdef VBOX_PYTHON39M_LIB_X86
++DLLS += VBoxPython3_9m_x86
++VBoxPython3_9m_x86_EXTENDS = VBoxPythonBase_x86_m
++VBoxPython3_9m_x86_EXTENDS_BY = appending
++VBoxPython3_9m_x86_TEMPLATE_ = XPCOM
++VBoxPython3_9m_x86_INCS = $(VBOX_PYTHON39M_INC)
++VBoxPython3_9m_x86_LIBS = $(VBOX_PYTHON39M_LIB_X86)
++ endif
++ endif
++endif
+
+ ifdef VBOX_PYTHONDEF_INC
+ #
+--- ./src/libs/xpcom18a4/python/src/module/_xpcom.cpp.orig 2020-06-01 06:01:12.923522302 +0100
++++ ./src/libs/xpcom18a4/python/src/module/_xpcom.cpp 2020-06-01 06:02:25.704013030 +0100
+@@ -84,7 +84,11 @@ extern PYXPCOM_EXPORT void PyXPCOM_Inter
+ # define MANGLE_MODULE_INIT(a_Name) RT_CONCAT(a_Name, MODULE_NAME_SUFFIX)
+ # endif
+ # ifdef VBOX_PYXPCOM_VERSIONED
+-# if PY_VERSION_HEX >= 0x03080000 && PY_VERSION_HEX < 0x03090000
++# if PY_VERSION_HEX >= 0x03090000 && PY_VERSION_HEX < 0x03100000
++# define MODULE_NAME MANGLE_MODULE_NAME("VBoxPython3_9")
++# define initVBoxPython MANGLE_MODULE_INIT(PyInit_VBoxPython3_9)
++
++# elif PY_VERSION_HEX >= 0x03080000 && PY_VERSION_HEX < 0x03090000
+ # define MODULE_NAME MANGLE_MODULE_NAME("VBoxPython3_8")
+ # define initVBoxPython MANGLE_MODULE_INIT(PyInit_VBoxPython3_8)
+
diff --git a/020-gsoap.patch b/020-gsoap.patch
deleted file mode 100644
index 9a1aa3af7cbf..000000000000
--- a/020-gsoap.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/VBox/Main/webservice/vboxweb.cpp b/src/VBox/Main/webservice/vboxweb.cpp
-index 8dd3ca1b..9d5c9138 100644
---- a/src/VBox/Main/webservice/vboxweb.cpp
-+++ b/src/VBox/Main/webservice/vboxweb.cpp
-@@ -944,7 +944,7 @@ static void doQueuesLoop()
- if (rv == 0)
- continue; // timeout, not necessary to bother gsoap
- // r < 0, errno
-- if (soap_socket_errno(soap.master) == SOAP_EINTR)
-+ if (soap_socket_errno == SOAP_EINTR)
- rv = 0; // re-check if we should terminate
- break;
- }
diff --git a/021-kernel-5.9.patch b/021-kernel-5.9.patch
deleted file mode 100644
index 351f90db796a..000000000000
--- a/021-kernel-5.9.patch
+++ /dev/null
@@ -1,189 +0,0 @@
-This patch file contains the changes needed to compile the VirtualBox
-modules for kernel 5.9.0+.
-
-The changes are as follows:
-1. The kernel headers no longer define HAVE_UNLOCKED_IOCTL; however,
- this symbol is needed for compilation of VB.
-2. The calling sequence for get_user_pages_remote() is changed.
-3. Routine sched_setscheduler() is replaced by sched_set_fifo_low().
-4. The type of vbox_master_set() is changed from int to void.
-5. Routine drm_gem_object_put_unlocked() is replaced by drm_gem_object_put().
-6. Member offset is removed from struct ttm_buffer_object.
-
-Index: VirtualBox-6.1.14/src/VBox/Runtime/r0drv/linux/the-linux-kernel.h
-===================================================================
---- VirtualBox-6.1.14.orig/src/VBox/Runtime/r0drv/linux/the-linux-kernel.h
-+++ VirtualBox-6.1.14/src/VBox/Runtime/r0drv/linux/the-linux-kernel.h
-@@ -137,7 +137,10 @@
- #include <linux/interrupt.h>
- #include <linux/completion.h>
- #include <linux/compiler.h>
--#ifndef HAVE_UNLOCKED_IOCTL /* linux/fs.h defines this */
-+#if RTLNX_VER_MIN(5, 9, 0)
-+#define HAVE_UNLOCKED_IOCTL 1 /* defined in linux/fs.h for kernels before 5.9 */
-+#endif
-+#ifndef HAVE_UNLOCKED_IOCTL
- # include <linux/smp_lock.h>
- #endif
- /* For the shared folders module */
-Index: VirtualBox-6.1.14/src/VBox/Runtime/r0drv/linux/memobj-r0drv-linux.c
-===================================================================
---- VirtualBox-6.1.14.orig/src/VBox/Runtime/r0drv/linux/memobj-r0drv-linux.c
-+++ VirtualBox-6.1.14/src/VBox/Runtime/r0drv/linux/memobj-r0drv-linux.c
-@@ -1181,7 +1181,9 @@ DECLHIDDEN(int) rtR0MemObjNativeLockUser
- */
- else
- rc = get_user_pages_remote(
-+#if RTLNX_VER_MAX(5, 9, 0)
- pTask, /* Task for fault accounting. */
-+#endif
- pTask->mm, /* Whose pages. */
- R3Ptr, /* Where from. */
- cPages, /* How many pages. */
-Index: VirtualBox-6.1.14/src/VBox/Runtime/r0drv/linux/thread2-r0drv-linux.c
-===================================================================
---- VirtualBox-6.1.14.orig/src/VBox/Runtime/r0drv/linux/thread2-r0drv-linux.c
-+++ VirtualBox-6.1.14/src/VBox/Runtime/r0drv/linux/thread2-r0drv-linux.c
-@@ -92,8 +92,12 @@ DECLHIDDEN(int) rtThreadNativeSetPriorit
- return VERR_INVALID_PARAMETER;
- }
-
-+#if RTLNX_VER_MAX(5, 9, 0)
- sched_setscheduler(current, iSchedClass, &Param);
- #else
-+ sched_set_fifo_low(current);
-+#endif
-+#else
- RT_NOREF_PV(enmType);
- #endif
- RT_NOREF_PV(pThread);
-Index: VirtualBox-6.1.14/src/VBox/Additions/linux/drm/vbox_drv.c
-===================================================================
---- VirtualBox-6.1.14.orig/src/VBox/Additions/linux/drm/vbox_drv.c
-+++ VirtualBox-6.1.14/src/VBox/Additions/linux/drm/vbox_drv.c
-@@ -262,8 +262,13 @@ static const struct file_operations vbox
- .read = drm_read,
- };
-
-+#if RTLNX_VER_MAX(5, 9, 0)
- static int vbox_master_set(struct drm_device *dev,
- struct drm_file *file_priv, bool from_open)
-+#else
-+static void vbox_master_set(struct drm_device *dev,
-+ struct drm_file *file_priv, bool from_open)
-+#endif
- {
- struct vbox_private *vbox = dev->dev_private;
-
-Index: VirtualBox-6.1.14/src/VBox/Additions/linux/drm/vbox_fb.c
-===================================================================
---- VirtualBox-6.1.14.orig/src/VBox/Additions/linux/drm/vbox_fb.c
-+++ VirtualBox-6.1.14/src/VBox/Additions/linux/drm/vbox_fb.c
-@@ -405,7 +405,11 @@ void vbox_fbdev_fini(struct drm_device *
- vbox_bo_unpin(bo);
- vbox_bo_unreserve(bo);
- }
-+#if RTLNX_VER_MIN(5, 9, 0)
-+ drm_gem_object_put(afb->obj);
-+#else
- drm_gem_object_put_unlocked(afb->obj);
-+#endif
- afb->obj = NULL;
- }
- drm_fb_helper_fini(&fbdev->helper);
-Index: VirtualBox-6.1.14/src/VBox/Additions/linux/drm/vbox_main.c
-===================================================================
---- VirtualBox-6.1.14.orig/src/VBox/Additions/linux/drm/vbox_main.c
-+++ VirtualBox-6.1.14/src/VBox/Additions/linux/drm/vbox_main.c
-@@ -40,14 +40,19 @@
- #include <VBoxVideoVBE.h>
-
- #include "hgsmi_channels.h"
-+#include <linux/version.h>
-+
-
- static void vbox_user_framebuffer_destroy(struct drm_framebuffer *fb)
- {
- struct vbox_framebuffer *vbox_fb = to_vbox_framebuffer(fb);
-
- if (vbox_fb->obj)
-+#if RTLNX_VER_MAX(5, 9, 0)
- drm_gem_object_put_unlocked(vbox_fb->obj);
--
-+#else
-+ drm_gem_object_put(vbox_fb->obj);
-+#endif
- drm_framebuffer_cleanup(fb);
- kfree(fb);
- }
-@@ -221,7 +226,11 @@ static struct drm_framebuffer *vbox_user
- err_free_vbox_fb:
- kfree(vbox_fb);
- err_unref_obj:
-+#if RTLNX_VER_MAX(5, 9, 0)
- drm_gem_object_put_unlocked(obj);
-+#else
-+ drm_gem_object_put(obj);
-+#endif
- return ERR_PTR(ret);
- }
-
-@@ -588,7 +597,11 @@ int vbox_dumb_create(struct drm_file *fi
- return ret;
-
- ret = drm_gem_handle_create(file, gobj, &handle);
-+#if RTLNX_VER_MAX(5, 9, 0)
- drm_gem_object_put_unlocked(gobj);
-+#else
-+ drm_gem_object_put(gobj);
-+#endif
- if (ret)
- return ret;
-
-Index: VirtualBox-6.1.14/src/VBox/Additions/linux/drm/vbox_drv.h
-===================================================================
---- VirtualBox-6.1.14.orig/src/VBox/Additions/linux/drm/vbox_drv.h
-+++ VirtualBox-6.1.14/src/VBox/Additions/linux/drm/vbox_drv.h
-@@ -417,6 +417,9 @@ struct vbox_bo {
- #else
- struct ttm_place placements[3];
- #endif
-+#if RTLNX_VER_MIN(5, 9, 0)
-+ uint64_t offset;
-+#endif
- int pin_count;
- };
-
-Index: VirtualBox-6.1.14/src/VBox/Additions/linux/drm/vbox_mode.c
-===================================================================
---- VirtualBox-6.1.14.orig/src/VBox/Additions/linux/drm/vbox_mode.c
-+++ VirtualBox-6.1.14/src/VBox/Additions/linux/drm/vbox_mode.c
-@@ -885,8 +885,11 @@ out_unmap_bo:
- out_unreserve_bo:
- vbox_bo_unreserve(bo);
- out_unref_obj:
-+#if RTLNX_VER_MAX(5, 9, 0)
- drm_gem_object_put_unlocked(obj);
--
-+#else
-+ drm_gem_object_put(obj);
-+#endif
- return ret;
- }
-
-Index: VirtualBox-6.1.14/src/VBox/Additions/linux/drm/vbox_ttm.c
-===================================================================
---- VirtualBox-6.1.14.orig/src/VBox/Additions/linux/drm/vbox_ttm.c
-+++ VirtualBox-6.1.14/src/VBox/Additions/linux/drm/vbox_ttm.c
-@@ -445,7 +445,11 @@ err_free_vboxbo:
-
- static inline u64 vbox_bo_gpu_offset(struct vbox_bo *bo)
- {
-+#if RTLNX_VER_MAX(5, 9, 0)
- return bo->bo.offset;
-+#else
-+ return bo->offset;
-+#endif
- }
-
- int vbox_bo_pin(struct vbox_bo *bo, u32 pl_flag, u64 *gpu_addr)
diff --git a/PKGBUILD b/PKGBUILD
index fa7f8cbfcf6a..c78df6f83839 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: Ionut Biru <ibiru@archlinux.org>
pkgname=virtualbox-headless
-pkgver=6.1.14
-_tarver=${pkgver}a
-pkgrel=2
+pkgver=6.1.16
+_tarver=${pkgver}
+pkgrel=1
pkgdesc='Powerful x86 virtualization for enterprise as well as home use. Headless build (no GUI, no Java).'
arch=('i686' 'x86_64')
url='https://virtualbox.org'
@@ -38,11 +38,10 @@ source=("https://download.virtualbox.org/virtualbox/${pkgver}/VirtualBox-${_tarv
'013-Makefile.patch'
'017-fix-narrowing-conversion.patch'
'018-xclient.patch'
- '020-gsoap.patch'
- '021-kernel-5.9.patch'
+ '019-python3.9.patch'
)
sha256sums=(
- '16f3cb83ab3c4dacf2a9d3cc638cbd18db23767828bba6b8ba1c1b57abeb6aef'
+ '49c1990da16d8a3d5bda8cdb961ec8195a901e67e4c79aea44c1521a5fc2f9f1'
'2101ebb58233bbfadf3aa74381f22f7e7e508559d2b46387114bc2d8e308554c'
'9c5238183019f9ebc7d92a8582cad232f471eab9d3278786225abc1a1c7bf66e'
'033c597e0f5285d2ddb0490868e5b6f945f45c7b1b1152a02a9e6fea438b2c95'
@@ -57,8 +56,7 @@ sha256sums=(
'da7e58ed37dc23c6202aab3017864579a99e78417f3421ddcc98a198198fe2c9'
'5aac692909a0a0ec56b08bdece9e42cf7463abdca9da2f990d441ff463be6a99'
'cac5a573e9ed5aafb2f469c2e6fffb8cd4f389bbadba5a968c9f65be7a72fee3'
- 'c6892a3561a72a9b308cb33fa6647cc53e54a3bd40cb41780cad7f8e9d7df9f6'
- '05bfc8306bbd856087c393dcb47d16de4213a4cc69124857f705f3784d88581a'
+ '039c7b520ae589bc52dc6c0e658f7ec28ca8defb12ccbc32ad9834361d23162c'
)
prepare() {