summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2018-06-27 13:22:24 +0200
committerPiotr Gorski2018-06-27 13:22:24 +0200
commit14e80c7fa780bc049213f89037ca11584a1eb8ec (patch)
tree51b0b6c1465228e1177510982fddfb915bb43504
parent458b109b2b5a6dc1cd772d1fb786116ec5f8dd46 (diff)
downloadaur-14e80c7fa780bc049213f89037ca11584a1eb8ec.tar.gz
Bump to 5.2.12-1
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD9
2 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9cca988d4c28..0f995c9c55ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,25 @@
pkgbase = virtualbox-modules-lqx
- pkgver = 5.2.10
+ pkgver = 5.2.12
pkgrel = 1
url = http://virtualbox.org
arch = x86_64
license = GPL
makedepends = linux-lqx-headers
- makedepends = virtualbox-host-dkms>=5.2.10
- makedepends = virtualbox-guest-dkms>=5.2.10
+ makedepends = virtualbox-host-dkms>=5.2.12
+ makedepends = virtualbox-guest-dkms>=5.2.12
makedepends = dkms
pkgname = virtualbox-host-modules-lqx
pkgdesc = Host kernel modules for VirtualBox running under Linux-lqx.
license = GPL
- depends = linux-lqx>=4.15
- depends = linux-lqx<4.15
+ depends = linux-lqx>=4.16
+ depends = linux-lqx<4.17
provides = VIRTUALBOX-HOST-MODULES
pkgname = virtualbox-guest-modules-lqx
pkgdesc = Guest kernel modules for VirtualBox running under Linux-lqx.
license = GPL
- depends = linux-lqx>=4.15
- depends = linux-lqx<4.16
+ depends = linux-lqx>=4.16
+ depends = linux-lqx<4.17
provides = VIRTUALBOX-GUEST-MODULES
diff --git a/PKGBUILD b/PKGBUILD
index e65570603a5a..367550080218 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
pkgbase=virtualbox-modules-lqx
pkgname=('virtualbox-host-modules-lqx' 'virtualbox-guest-modules-lqx')
-pkgver=5.2.10
+pkgver=5.2.12
pkgrel=1
arch=('x86_64')
url='http://virtualbox.org'
license=('GPL')
makedepends=('linux-lqx-headers' "virtualbox-host-dkms>=$pkgver" "virtualbox-guest-dkms>=$pkgver" 'dkms')
-_extramodules=extramodules-4.15-lqx
+_extramodules=extramodules-4.16-lqx
_kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
build() {
@@ -31,7 +31,7 @@ package_virtualbox-host-modules-lqx() {
pkgdesc='Host kernel modules for VirtualBox running under Linux-lqx.'
license=('GPL')
provides=("VIRTUALBOX-HOST-MODULES")
- depends=('linux-lqx>=4.15' 'linux-lqx<4.15')
+ depends=('linux-lqx>=4.16' 'linux-lqx<4.17')
cd "dkms/vboxhost/${pkgver}_OSE/$_kernver/$CARCH/module"
install -Dt "$pkgdir/usr/lib/modules/$_extramodules" -m644 *
@@ -48,7 +48,7 @@ package_virtualbox-guest-modules-lqx() {
pkgdesc='Guest kernel modules for VirtualBox running under Linux-lqx.'
license=('GPL')
provides=("VIRTUALBOX-GUEST-MODULES")
- depends=('linux-lqx>=4.15' 'linux-lqx<4.16')
+ depends=('linux-lqx>=4.16' 'linux-lqx<4.17')
cd "dkms/vboxguest/${pkgver}_OSE/$_kernver/$CARCH/module"
install -Dt "$pkgdir/usr/lib/modules/$_extramodules" -m644 *
@@ -61,3 +61,4 @@ package_virtualbox-guest-modules-lqx() {
install -Dm644 /dev/stdin "$pkgdir/usr/lib/modules-load.d/virtualbox-guest-modules-lqx.conf"
}
+