summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Gorski2018-07-13 18:40:17 +0200
committerPiotr Gorski2018-07-13 18:40:17 +0200
commit156430b8447b649b5168e016585609231ab813f6 (patch)
tree154deadce072cc94b41b00e491d4d59c683adcff
parent14e80c7fa780bc049213f89037ca11584a1eb8ec (diff)
downloadaur-156430b8447b649b5168e016585609231ab813f6.tar.gz
Bump to 5.2.14
Signed-off-by: Piotr Gorski <lucjan.lucjanov@gmail.com>
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 12 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f995c9c55ed..fe93877836e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,16 @@
pkgbase = virtualbox-modules-lqx
- pkgver = 5.2.12
+ pkgver = 5.2.14
pkgrel = 1
url = http://virtualbox.org
arch = x86_64
license = GPL
makedepends = linux-lqx-headers
- makedepends = virtualbox-host-dkms>=5.2.12
- makedepends = virtualbox-guest-dkms>=5.2.12
+ makedepends = virtualbox-host-dkms>=5.2.14
makedepends = dkms
pkgname = virtualbox-host-modules-lqx
- pkgdesc = Host kernel modules for VirtualBox running under Linux-lqx.
- license = GPL
- depends = linux-lqx>=4.16
- depends = linux-lqx<4.17
+ pkgdesc = Host kernel modules for VirtualBox running under linux-lqx.
+ depends = linux-lqx>=4.17
+ depends = linux-lqx<4.18
provides = VIRTUALBOX-HOST-MODULES
-pkgname = virtualbox-guest-modules-lqx
- pkgdesc = Guest kernel modules for VirtualBox running under Linux-lqx.
- license = GPL
- depends = linux-lqx>=4.16
- depends = linux-lqx<4.17
- provides = VIRTUALBOX-GUEST-MODULES
-
diff --git a/PKGBUILD b/PKGBUILD
index 367550080218..89c075d62ac6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,15 @@
# Contributor : Trevor Turner <turn3r.tr3v0r at gmail dot com>
pkgbase=virtualbox-modules-lqx
-pkgname=('virtualbox-host-modules-lqx' 'virtualbox-guest-modules-lqx')
-pkgver=5.2.12
+pkgname=('virtualbox-host-modules-lqx')
+pkgver=5.2.14
pkgrel=1
arch=('x86_64')
url='http://virtualbox.org'
license=('GPL')
-makedepends=('linux-lqx-headers' "virtualbox-host-dkms>=$pkgver" "virtualbox-guest-dkms>=$pkgver" 'dkms')
+makedepends=('linux-lqx-headers' "virtualbox-host-dkms>=$pkgver" 'dkms')
-_extramodules=extramodules-4.16-lqx
+_extramodules=extramodules-4.17-lqx
_kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
build() {
@@ -22,18 +22,14 @@ build() {
# build host modules
msg2 'Host modules'
dkms --dkmsframework dkms.conf build "vboxhost/${pkgver}_OSE" -k "$_kernver"
- # build guest modules
- msg2 'Guest modules'
- dkms --dkmsframework dkms.conf build "vboxguest/${pkgver}_OSE" -k "$_kernver"
}
package_virtualbox-host-modules-lqx() {
- pkgdesc='Host kernel modules for VirtualBox running under Linux-lqx.'
- license=('GPL')
+ pkgdesc='Host kernel modules for VirtualBox running under linux-lqx.'
provides=("VIRTUALBOX-HOST-MODULES")
- depends=('linux-lqx>=4.16' 'linux-lqx<4.17')
+ depends=('linux-lqx>=4.17' 'linux-lqx<4.18')
- cd "dkms/vboxhost/${pkgver}_OSE/$_kernver/$CARCH/module"
+ cd "dkms/vboxhost/${pkgver}_OSE/$_kernver/$CARCH/module"
install -Dt "$pkgdir/usr/lib/modules/$_extramodules" -m644 *
# compress each module individually
@@ -43,22 +39,3 @@ package_virtualbox-host-modules-lqx() {
printf "vboxdrv\nvboxpci\nvboxnetadp\nvboxnetflt\n" |
install -Dm644 /dev/stdin "$pkgdir/usr/lib/modules-load.d/virtualbox-host-modules-lqx.conf"
}
-
-package_virtualbox-guest-modules-lqx() {
- pkgdesc='Guest kernel modules for VirtualBox running under Linux-lqx.'
- license=('GPL')
- provides=("VIRTUALBOX-GUEST-MODULES")
- depends=('linux-lqx>=4.16' 'linux-lqx<4.17')
-
- cd "dkms/vboxguest/${pkgver}_OSE/$_kernver/$CARCH/module"
- install -Dt "$pkgdir/usr/lib/modules/$_extramodules" -m644 *
-
- # compress each module individually
- find "$pkgdir" -name '*.ko' -exec gzip -n {} +
-
- # systemd module loading
- printf "vboxguest\nvboxsf\nvboxvideo\n" |
- install -Dm644 /dev/stdin "$pkgdir/usr/lib/modules-load.d/virtualbox-guest-modules-lqx.conf"
-}
-
-