summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Molin2016-01-27 00:08:14 +0100
committerOscar Molin2016-01-27 00:08:14 +0100
commit478aaae65624829bde9fbe6434df4f3925c99b92 (patch)
tree1faf81f2ee6797561d04309ba1d78e44d3ebd4a5
parent38d82a4cbccce8570e7f7d94172badfee2ea54a0 (diff)
downloadaur-478aaae65624829bde9fbe6434df4f3925c99b92.tar.gz
5.0.14-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rw-r--r--lnkops.c105
3 files changed, 6 insertions, 111 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60a4600a4164..785db681fe31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = virtualbox-modules-mainline
- pkgver = 5.0.12
- pkgrel = 4
+ pkgver = 5.0.14
+ pkgrel = 1
url = http://virtualbox.org
arch = i686
arch = x86_64
@@ -8,8 +8,8 @@ pkgbase = virtualbox-modules-mainline
makedepends = dkms
makedepends = linux-mainline-headers>=4.5rc1
makedepends = linux-mainline-headers<4.6rc1
- makedepends = virtualbox-host-dkms>=5.0.12
- makedepends = virtualbox-guest-dkms>=5.0.12
+ makedepends = virtualbox-host-dkms>=5.0.14
+ makedepends = virtualbox-guest-dkms>=5.0.14
depends = linux-mainline>=4.5rc1
depends = linux-mainline<4.6rc1
diff --git a/PKGBUILD b/PKGBUILD
index 6e51b6628eb5..84a656d696fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,8 @@
pkgbase=virtualbox-modules-mainline
pkgname=('virtualbox-host-modules-mainline' 'virtualbox-guest-modules-mainline')
-pkgver=5.0.12
-pkgrel=4
+pkgver=5.0.14
+pkgrel=1
arch=('i686' 'x86_64')
url='http://virtualbox.org'
license=('GPL')
diff --git a/lnkops.c b/lnkops.c
deleted file mode 100644
index 6d1e2820fc9e..000000000000
--- a/lnkops.c
+++ /dev/null
@@ -1,105 +0,0 @@
-/** @file
- *
- * vboxsf -- VirtualBox Guest Additions for Linux:
- * Operations for symbolic links.
- */
-
-/*
- * Copyright (C) 2010-2011 Oracle Corporation
- *
- * This file is part of VirtualBox Open Source Edition (OSE), as
- * available from http://www.virtualbox.org. This file is free software;
- * you can redistribute it and/or modify it under the terms of the GNU
- * General Public License (GPL) as published by the Free Software
- * Foundation, in version 2 as it comes in the "COPYING" file of the
- * VirtualBox OSE distribution. VirtualBox OSE is distributed in the
- * hope that it will be useful, but WITHOUT ANY WARRANTY of any kind.
- */
-
-#include "vfsmod.h"
-
-#if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 0)
-
-# if LINUX_VERSION_CODE < KERNEL_VERSION(4, 5, 0)
-# if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 2, 0)
-static const char *sf_follow_link(struct dentry *dentry, void **cookie)
-# else
-static void *sf_follow_link(struct dentry *dentry, struct nameidata *nd)
-# endif
-{
- struct inode *inode = dentry->d_inode;
- struct sf_glob_info *sf_g = GET_GLOB_INFO(inode->i_sb);
- struct sf_inode_info *sf_i = GET_INODE_INFO(inode);
- int error = -ENOMEM;
- char *path = (char*)get_zeroed_page(GFP_KERNEL);
- int rc;
-
- if (path)
- {
- error = 0;
- rc = VbglR0SfReadLink(&client_handle, &sf_g->map, sf_i->path, PATH_MAX, path);
- if (RT_FAILURE(rc))
- {
- LogFunc(("VbglR0SfReadLink failed, caller=%s, rc=%Rrc\n", __func__, rc));
- free_page((unsigned long)path);
- error = -EPROTO;
- }
- }
-# if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 2, 0)
- return error ? ERR_PTR(error) : (*cookie = path);
-# else
- nd_set_link(nd, error ? ERR_PTR(error) : path);
- return NULL;
-# endif
-}
-
-# if LINUX_VERSION_CODE < KERNEL_VERSION(4, 2, 0)
-static void sf_put_link(struct dentry *dentry, struct nameidata *nd, void *cookie)
-{
- char *page = nd_get_link(nd);
- if (!IS_ERR(page))
- free_page((unsigned long)page);
-}
-# endif
-
-# else /* LINUX_VERSION_CODE >= KERNEL_VERSION(4, 5, 0) */
-static const char *sf_get_link(struct dentry *dentry, struct inode *inode,
- struct delayed_call *done)
-{
- struct sf_glob_info *sf_g = GET_GLOB_INFO(inode->i_sb);
- struct sf_inode_info *sf_i = GET_INODE_INFO(inode);
- char *path;
- int rc;
-
- if (!dentry)
- return ERR_PTR(-ECHILD);
- path = kzalloc(PAGE_SIZE, GFP_KERNEL);
- if (!path)
- return ERR_PTR(-ENOMEM);
- rc = VbglR0SfReadLink(&client_handle, &sf_g->map, sf_i->path, PATH_MAX, path);
- if (RT_FAILURE(rc))
- {
- LogFunc(("VbglR0SfReadLink failed, caller=%s, rc=%Rrc\n", __func__, rc));
- kfree(path);
- return ERR_PTR(-EPROTO);
- }
- set_delayed_call(done, kfree_link, path);
- return path;
-}
-# endif /* LINUX_VERSION_CODE < KERNEL_VERSION(4, 5, 0) */
-
-struct inode_operations sf_lnk_iops =
-{
- .readlink = generic_readlink,
-# if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 5, 0)
- .get_link = sf_get_link
-# elif LINUX_VERSION_CODE >= KERNEL_VERSION(4, 2, 0)
- .follow_link = sf_follow_link,
- .put_link = free_page_put_link,
-# else
- .follow_link = sf_follow_link,
- .put_link = sf_put_link
-# endif
-};
-
-#endif /* LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 0) */