summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOscar Molin2015-11-22 23:28:55 +0100
committerOscar Molin2015-11-22 23:28:55 +0100
commit5fc601a65041c8f82d07373927ddf8c7ddd32f3b (patch)
tree8a691dfc87239877ee75c07c7ea49405069a7b5b
parentfb42f69cad294e8ad35a7be9d21ed0b41819b0bb (diff)
downloadaur-5fc601a65041c8f82d07373927ddf8c7ddd32f3b.tar.gz
Works with 4.4rc1-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--kernel-4.2.patch47
-rw-r--r--virtualbox-guest-modules-mainline.install2
-rw-r--r--virtualbox-host-modules-mainline.install2
5 files changed, 9 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 976078e3de82..d69ffdee0d8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = virtualbox-modules-mainline
- pkgver = 5.0.8
- pkgrel = 2
+ pkgver = 5.0.10
+ pkgrel = 1
url = http://virtualbox.org
arch = i686
arch = x86_64
@@ -8,8 +8,8 @@ pkgbase = virtualbox-modules-mainline
makedepends = dkms
makedepends = linux-mainline-headers>=4.4rc1
makedepends = linux-mainline-headers<4.5rc1
- makedepends = virtualbox-host-dkms>=5.0.8
- makedepends = virtualbox-guest-dkms>=5.0.8
+ makedepends = virtualbox-host-dkms>=5.0.10
+ makedepends = virtualbox-guest-dkms>=5.0.10
depends = linux-mainline>=4.4rc1
depends = linux-mainline<4.5rc1
diff --git a/PKGBUILD b/PKGBUILD
index 26b1485ca39c..3e28e35aed29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,15 @@
pkgbase=virtualbox-modules-mainline
pkgname=('virtualbox-host-modules-mainline' 'virtualbox-guest-modules-mainline')
-pkgver=5.0.8
-pkgrel=2
+pkgver=5.0.10
+pkgrel=1
arch=('i686' 'x86_64')
url='http://virtualbox.org'
license=('GPL')
depends=('linux-mainline>=4.4rc1' 'linux-mainline<4.5rc1')
makedepends=('dkms' 'linux-mainline-headers>=4.4rc1' 'linux-mainline-headers<4.5rc1' "virtualbox-host-dkms>=$pkgver" "virtualbox-guest-dkms>=$pkgver")
# remember to also adjust the .install files and the package deps below
-_extramodules=extramodules-4.3-mainline
+_extramodules=extramodules-4.4-mainline
build() {
_kernver=$(cat /usr/lib/modules/$_extramodules/version)
diff --git a/kernel-4.2.patch b/kernel-4.2.patch
deleted file mode 100644
index bedac9934b9f..000000000000
--- a/kernel-4.2.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-#Index: trunk/src/VBox/Additions/linux/sharedfolders/lnkops.c
-#===================================================================
-# https://raw.githubusercontent.com/manjaro/packages-extra/master/linux42-extramodules/virtualbox-modules/kernel-4.2.patch
-diff --git a/vboxsf/lnkops.c b/vboxsf/lnkops.c
-
---- a/vboxsf/lnkops.c
-+++ b/vboxsf/lnkops.c
-@@ -21,5 +21,9 @@
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 0)
-
-+# if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 2, 0)
-+static const char *sf_follow_link(struct dentry *dentry, void **cookie)
-+# else
- static void *sf_follow_link(struct dentry *dentry, struct nameidata *nd)
-+# endif
- {
- struct inode *inode = dentry->d_inode;
-@@ -41,8 +45,13 @@
- }
- }
-+# if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 2, 0)
-+ return error ? ERR_PTR(error) : (*cookie = path);
-+# else
- nd_set_link(nd, error ? ERR_PTR(error) : path);
- return NULL;
-+# endif
- }
-
-+# if LINUX_VERSION_CODE < KERNEL_VERSION(4, 2, 0)
- static void sf_put_link(struct dentry *dentry, struct nameidata *nd, void *cookie)
- {
-@@ -51,4 +60,5 @@
- free_page((unsigned long)page);
- }
-+#endif
-
- struct inode_operations sf_lnk_iops =
-@@ -56,5 +66,9 @@
- .readlink = generic_readlink,
- .follow_link = sf_follow_link,
-+# if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 2, 0)
-+ .put_link = free_page_put_link,
-+# else
- .put_link = sf_put_link
-+# endif
- };
-
diff --git a/virtualbox-guest-modules-mainline.install b/virtualbox-guest-modules-mainline.install
index 6196d8c2ad87..981a47f965c0 100644
--- a/virtualbox-guest-modules-mainline.install
+++ b/virtualbox-guest-modules-mainline.install
@@ -1,5 +1,5 @@
_depmod() {
- EXTRAMODULES=extramodules-4.3-mainline
+ EXTRAMODULES=extramodules-4.4-mainline
depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
}
diff --git a/virtualbox-host-modules-mainline.install b/virtualbox-host-modules-mainline.install
index 09cee70b9eec..da3eb2d79670 100644
--- a/virtualbox-host-modules-mainline.install
+++ b/virtualbox-host-modules-mainline.install
@@ -1,5 +1,5 @@
_depmod() {
- EXTRAMODULES=extramodules-4.3-mainline
+ EXTRAMODULES=extramodules-4.4-mainline
depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
}