summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2021-11-15 22:28:43 +0800
committerlilac2021-11-15 22:28:43 +0800
commit343e1af4d606933369c91189bf83f34495747eae (patch)
treedea015bcfd41392c7c3212b39b6beb268f9e3d04
parentc434967956a0e7e6157e2a36bc8655040158f911 (diff)
downloadaur-343e1af4d606933369c91189bf83f34495747eae.tar.gz
update to version 92314
-rw-r--r--.SRCINFO10
-rw-r--r--009-i3wm.patch50
-rw-r--r--013-Makefile.patch28
-rw-r--r--020-linux-5-11.patch12
-rw-r--r--LocalConfig.kmk2
-rw-r--r--PKGBUILD15
6 files changed, 69 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e44d84073adf..44c43fc4e0ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = virtualbox-svn
- pkgver = 89610
+ pkgver = 92314
pkgrel = 1
url = http://virtualbox.org
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = virtualbox-svn
makedepends = glu
makedepends = gsoap
makedepends = iasl
- makedepends = jdk7-openjdk
+ makedepends = jdk8-openjdk
makedepends = libidl2
makedepends = libpulse
makedepends = libstdc++5
@@ -61,6 +61,7 @@ pkgbase = virtualbox-svn
source = 005-gsoap-build.patch
source = 006-rdesktop-vrdp-keymap-path.patch
source = 008-no-vboxvideo.patch
+ source = 009-i3wm.patch
source = 012-vbglR3GuestCtrlDetectPeekGetCancelSupport.patch
source = 013-Makefile.patch
source = 017-fix-narrowing-conversion.patch
@@ -71,7 +72,7 @@ pkgbase = virtualbox-svn
sha256sums = da4c49f6ca94e047e196cdbcba2c321199f4760056ea66e0fbc659353e128c9e
sha256sums = 9c5238183019f9ebc7d92a8582cad232f471eab9d3278786225abc1a1c7bf66e
sha256sums = 033c597e0f5285d2ddb0490868e5b6f945f45c7b1b1152a02a9e6fea438b2c95
- sha256sums = 240ddf9c532b34380dd9bdd56c6302f323ded9ca95ccf5c50b6e44a5cb533cc9
+ sha256sums = 3cf42bc6e9e55fd2cb6be7b89c5b98d0f6a2eff6125a9ee7efafaabc35f1de22
sha256sums = c41a801fe344a4471a7b61a4764d1d857c403e4fb96e2ba6bc89c77a35f2be7a
sha256sums = 01dbb921bd57a852919cc78be5b73580a564f28ebab2fe8d6c9b8301265cbfce
sha256sums = 83d8f24bff25bb925083cf39b3195236c6136105e62417712cc3f25b92e14b47
@@ -82,8 +83,9 @@ pkgbase = virtualbox-svn
sha256sums = 7d2da8fe10a90f76bbfc80ad1f55df4414f118cd10e10abfb76070326abebd46
sha256sums = 13c6ca9be0f91582445fd2a14a8c58a0625a15d9cb98cb6e8c2736d77ea976ab
sha256sums = 053bfeee8863f3ffdf2f0e3f9f0d77dc61dd32764700a97a7635fd8611e20491
+ sha256sums = cd83f4c9f3befb344c7e143aec65550444647890b676d6ea8502d67c7c1b3d93
sha256sums = 81900e13d36630488accd8c0bfd2ceb69563fb2c4f0f171caba1cca59d438024
- sha256sums = baafc9aa33b7022f7e7f6af16f75621dc311abbea538bf953c227e040006fb3f
+ sha256sums = fb21aafdc0bc14312b9618ebd7550cb7ecf2228486a121c75a0d94bf90ba54fb
sha256sums = 5aac692909a0a0ec56b08bdece9e42cf7463abdca9da2f990d441ff463be6a99
sha256sums = cac5a573e9ed5aafb2f469c2e6fffb8cd4f389bbadba5a968c9f65be7a72fee3
diff --git a/009-i3wm.patch b/009-i3wm.patch
new file mode 100644
index 000000000000..eca4341fff74
--- /dev/null
+++ b/009-i3wm.patch
@@ -0,0 +1,50 @@
+diff -Naur VirtualBox/src/VBox/Frontends/VirtualBox/src/globals/UIDesktopWidgetWatchdog.cpp VirtualBox/src/VBox/Frontends/VirtualBox/src/globals/UIDesktopWidgetWatchdog.cpp
+--- VirtualBox/src/VBox/Frontends/VirtualBox/src/globals/UIDesktopWidgetWatchdog.cpp 2017-03-08 18:19:53.000000000 +0100
++++ VirtualBox/src/VBox/Frontends/VirtualBox/src/globals/UIDesktopWidgetWatchdog.cpp 2017-03-10 10:25:58.876132400 +0100
+@@ -282,7 +282,7 @@
+ /* Get cached available-geometry: */
+ const QRect availableGeometry = m_availableGeometryData.value(iHostScreenIndex);
+ /* Return cached available-geometry if it's valid or screen-geometry otherwise: */
+- return availableGeometry.isValid() ? availableGeometry :
++ return availableGeometry.isValid() && X11WMType() != X11WMType_i3 ? availableGeometry :
+ QApplication::desktop()->screenGeometry(iHostScreenIndex);
+ #else /* !VBOX_WS_X11 */
+ /* Redirect call to desktop-widget: */
+diff -Naur VirtualBox/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-x11.cpp VirtualBox/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-x11.cpp
+--- VirtualBox/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-x11.cpp 2017-03-08 18:19:54.000000000 +0100
++++ VirtualBox/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-x11.cpp 2017-03-10 10:23:15.729460200 +0100
+@@ -93,6 +93,9 @@
+ else
+ if (QString((const char*)pcData).contains("Xfwm4", Qt::CaseInsensitive))
+ wmType = X11WMType_Xfwm4;
++ else
++ if (QString((const char*)pcData).contains("i3", Qt::CaseInsensitive))
++ wmType = X11WMType_i3;
+ if (pcData)
+ XFree(pcData);
+ }
+diff -Naur VirtualBox/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-x11.h VirtualBox/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-x11.h
+--- VirtualBox/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-x11.h 2017-03-08 18:19:54.000000000 +0100
++++ VirtualBox/src/VBox/Frontends/VirtualBox/src/platform/x11/VBoxUtils-x11.h 2017-03-10 10:22:11.876123200 +0100
+@@ -27,6 +27,7 @@
+ X11WMType_KWin,
+ X11WMType_Mutter,
+ X11WMType_Xfwm4,
++ X11WMType_i3,
+ };
+
+ /** X11: Determines and returns whether the compositing manager is running. */
+diff -Naur VirtualBox/src/VBox/Frontends/VirtualBox/src/widgets/UIMiniToolBar.cpp VirtualBox/src/VBox/Frontends/VirtualBox/src/widgets/UIMiniToolBar.cpp
+--- VirtualBox/src/VBox/Frontends/VirtualBox/src/widgets/UIMiniToolBar.cpp 2017-03-08 18:19:58.000000000 +0100
++++ VirtualBox/src/VBox/Frontends/VirtualBox/src/widgets/UIMiniToolBar.cpp 2017-03-10 10:29:12.549409400 +0100
+@@ -727,6 +727,10 @@
+ /* Enable translucency through Qt API if supported: */
+ if (vboxGlobal().isCompositingManagerRunning())
+ setAttribute(Qt::WA_TranslucentBackground);
++
++ if (X11WMType() == X11WMType_i3)
++ setWindowFlags(Qt::FramelessWindowHint);
++
+ #endif /* VBOX_WS_X11 */
+
+ /* Make sure we have no focus: */
diff --git a/013-Makefile.patch b/013-Makefile.patch
index 95e247fd9ca8..02ae6715d7cd 100644
--- a/013-Makefile.patch
+++ b/013-Makefile.patch
@@ -9,8 +9,10 @@ index 18466b48..7c7de4e5 100644
-ifneq ($(KERNELRELEASE),)
+ifneq ($(KBUILD_EXTMOD),)
- # Building from kBuild (make -C <kernel_directory> M=`pwd`),
- # or inside a kernel source tree.
+-# Building from kBuild (make -C <kernel_directory> M=`pwd`),
+-# or inside a kernel source tree.
++# Building from kBuild (make -C <kernel_directory> M=`pwd`).
++# KBUILD_EXTMOD is set to $(M) in this case.
obj-m = vboxdrv/
- ifneq ($(wildcard $(CURDIR)/vboxnetflt/Makefile),)
@@ -34,27 +36,9 @@ index 18466b48..7c7de4e5 100644
ifndef SUDO
ifneq ($(shell id -u),0)
-@@ -123,7 +123,7 @@ install-vboxpci:
- install: install-vboxdrv install-vboxnetflt install-vboxnetadp install-vboxpci
-
- # Look for wrapper modules, sorting them so vmmr0 is first.
--VBOX_WRAPPER_DIRS := $(notdir $(wildcard $(CURDIR)/vbox_*))
-+VBOX_WRAPPER_DIRS := $(notdir $(wildcard $(KBUILD_EXTMOD)/vbox_*))
- ifneq ($(VBOX_WRAPPER_DIRS),)
- VBOX_WRAPPER_DIRS := $(filter vbox_vmmr0,$(VBOX_WRAPPER_DIRS)) $(sort $(filter-out vbox_vmmr0,$(VBOX_WRAPPER_DIRS)))
- endif
-@@ -166,7 +166,7 @@ buildid:
- buildid=`readelf -n $${module} | sed -ne 's/^.*Build ID: *\([[:xdigit:]][[:xdigit:]]\)\(.*\)$$/\1\/\2/p' `; \
- if [ -n "$${buildid}" ]; then \
- mkdir -p ~/.debug/.build-id/`dirname $${buildid}`; \
-- ln -sfn -- "$(CURDIR)/$${module}" ~/.debug/.build-id/$${buildid}; \
-+ ln -sfn -- "$(KERNEL_EXTMOD)/$${module}" ~/.debug/.build-id/$${buildid}; \
- else \
- echo "warning: No build ID for $${module}"; \
- fi \
-@@ -234,5 +234,5 @@ load: unload
+@@ -234,5 +234,5 @@
fi; \
done
-endif # ! KERNELRELEASE
-+endif # ! KERNEL_EXTMOD
++endif # ! KBUILD_EXTMOD
diff --git a/020-linux-5-11.patch b/020-linux-5-11.patch
deleted file mode 100644
index 66b70bf0d97e..000000000000
--- a/020-linux-5-11.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/VBox/HostDrivers/VBoxNetFlt/linux/VBoxNetFlt-linux.c b/src/VBox/HostDrivers/VBoxNetFlt/linux/VBoxNetFlt-linux.c
-index 7033b45..c8178a6 100644
---- a/src/VBox/HostDrivers/VBoxNetFlt/linux/VBoxNetFlt-linux.c
-+++ b/src/VBox/HostDrivers/VBoxNetFlt/linux/VBoxNetFlt-linux.c
-@@ -39,6 +39,7 @@
- #endif
- #include <linux/netdevice.h>
- #include <linux/etherdevice.h>
-+#include <linux/ethtool.h>
- #include <linux/rtnetlink.h>
- #include <linux/miscdevice.h>
- #include <linux/inetdevice.h>
diff --git a/LocalConfig.kmk b/LocalConfig.kmk
index fb550a4ff686..a6078ca84514 100644
--- a/LocalConfig.kmk
+++ b/LocalConfig.kmk
@@ -16,7 +16,7 @@ VBOX_PATH_APP_PRIVATE := /usr/share/virtualbox
VBOX_PATH_APP_DOCS := /usr/share/doc/virtualbox
VBOX_PATH_PACKAGE_DOCS := $(VBOX_PATH_APP_DOCS)
VBOX_BLD_PYTHON = python
-VBOX_JAVA_HOME = /usr/lib/jvm/java-7-openjdk
+VBOX_JAVA_HOME = /usr/lib/jvm/java-8-openjdk
# do not fail on warning
VBOX_GCC_WERR =
diff --git a/PKGBUILD b/PKGBUILD
index 848d9cb8c6c1..5a8c2d904b40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=('virtualbox-svn'
'virtualbox-guest-utils-svn'
'virtualbox-guest-utils-nox-svn'
'virtualbox-ext-vnc-svn')
-pkgver=89610
+pkgver=92314
pkgrel=1
arch=('x86_64')
url='http://virtualbox.org'
@@ -25,7 +25,7 @@ makedepends=('subversion'
'glu'
'gsoap'
'iasl'
- 'jdk7-openjdk'
+ 'jdk8-openjdk'
'libidl2'
'libpulse'
'libstdc++5'
@@ -70,6 +70,7 @@ source=("VirtualBox::svn+http://www.virtualbox.org/svn/vbox/trunk"
'005-gsoap-build.patch'
'006-rdesktop-vrdp-keymap-path.patch'
'008-no-vboxvideo.patch'
+ '009-i3wm.patch'
'012-vbglR3GuestCtrlDetectPeekGetCancelSupport.patch'
'013-Makefile.patch'
'017-fix-narrowing-conversion.patch'
@@ -98,10 +99,6 @@ prepare() {
echo 'Use our CFLAGS'
echo "VBOX_GCC_OPT=$CXXFLAGS" >> LocalConfig.kmk
-
- sed -i '/#include "PyXPCOM_std.h"/a PyAPI_FUNC(void) _Py_NewReference(PyObject *op);' src/libs/xpcom18a4/python/src/PyIID.cpp
- sed -i '/#include "PyXPCOM_std.h"/a PyAPI_FUNC(void) _Py_NewReference(PyObject *op);' src/libs/xpcom18a4/python/src/PyISupports.cpp
- sed -i '/#include "PyXPCOM_std.h"/a PyAPI_FUNC(void) _Py_NewReference(PyObject *op);' src/libs/xpcom18a4/python/src/TypeObject.cpp
}
build() {
@@ -171,7 +168,6 @@ package_virtualbox-svn() {
# components
install -dm0755 "$pkgdir/usr/lib/virtualbox/components"
- #rm components/VBoxREM.so # TODO: remove when dead link is fixed
install -m0755 components/* -t "$pkgdir/usr/lib/virtualbox/components"
# extensions packs
@@ -351,7 +347,7 @@ sha256sums=('SKIP'
'da4c49f6ca94e047e196cdbcba2c321199f4760056ea66e0fbc659353e128c9e'
'9c5238183019f9ebc7d92a8582cad232f471eab9d3278786225abc1a1c7bf66e'
'033c597e0f5285d2ddb0490868e5b6f945f45c7b1b1152a02a9e6fea438b2c95'
- '240ddf9c532b34380dd9bdd56c6302f323ded9ca95ccf5c50b6e44a5cb533cc9'
+ '3cf42bc6e9e55fd2cb6be7b89c5b98d0f6a2eff6125a9ee7efafaabc35f1de22'
'c41a801fe344a4471a7b61a4764d1d857c403e4fb96e2ba6bc89c77a35f2be7a'
'01dbb921bd57a852919cc78be5b73580a564f28ebab2fe8d6c9b8301265cbfce'
'83d8f24bff25bb925083cf39b3195236c6136105e62417712cc3f25b92e14b47'
@@ -362,7 +358,8 @@ sha256sums=('SKIP'
'7d2da8fe10a90f76bbfc80ad1f55df4414f118cd10e10abfb76070326abebd46'
'13c6ca9be0f91582445fd2a14a8c58a0625a15d9cb98cb6e8c2736d77ea976ab'
'053bfeee8863f3ffdf2f0e3f9f0d77dc61dd32764700a97a7635fd8611e20491'
+ 'cd83f4c9f3befb344c7e143aec65550444647890b676d6ea8502d67c7c1b3d93'
'81900e13d36630488accd8c0bfd2ceb69563fb2c4f0f171caba1cca59d438024'
- 'baafc9aa33b7022f7e7f6af16f75621dc311abbea538bf953c227e040006fb3f'
+ 'fb21aafdc0bc14312b9618ebd7550cb7ecf2228486a121c75a0d94bf90ba54fb'
'5aac692909a0a0ec56b08bdece9e42cf7463abdca9da2f990d441ff463be6a99'
'cac5a573e9ed5aafb2f469c2e6fffb8cd4f389bbadba5a968c9f65be7a72fee3')