summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2019-05-20 19:44:59 +0800
committerlilac2019-05-20 19:44:59 +0800
commitbfda6b4d22384b78b891ce5ce45b5f899376097c (patch)
tree44b2cdddca8d7e2e79ff18a8274094b6efb40251
parent2c87cbae5a21579488e0cfc57057d77f02e1b88c (diff)
downloadaur-bfda6b4d22384b78b891ce5ce45b5f899376097c.tar.gz
update by lilac
-rw-r--r--.SRCINFO4
-rw-r--r--013-Makefile.patch44
-rw-r--r--PKGBUILD4
3 files changed, 50 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2306a4cbca66..9514278f71a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = virtualbox-svn
pkgver = 78447
- pkgrel = 1
+ pkgrel = 2
url = http://virtualbox.org
arch = x86_64
license = GPL
@@ -63,6 +63,7 @@ pkgbase = virtualbox-svn
source = 008-no-vboxvideo.patch
source = 011-python-3-7.patch
source = 012-vbglR3GuestCtrlDetectPeekGetCancelSupport.patch
+ source = 013-Makefile.patch
source = 101-vboxsf-automount.patch
source = mount.vboxsf
sha256sums = SKIP
@@ -85,6 +86,7 @@ pkgbase = virtualbox-svn
sha256sums = 8b7f241107863f82a5b0ae336aead0b3366a40103ff72dbebf33f54b512a0cbc
sha256sums = 55224cb74b54b331d691f171efc0d4c058a14f738551f1d8f559146c2908635d
sha256sums = 06485dce54a5f21b85f4360db884d98c1ab091d3f2535881ec9fcd82feb06b7e
+ sha256sums = da7e58ed37dc23c6202aab3017864579a99e78417f3421ddcc98a198198fe2c9
sha256sums = a784f3cc24652a16385cc63abac6c5178932ca5f3861be7650631b7dafa753a4
sha256sums = f3ed6741f8977f40900c8aa372fa082df1f8723d497d4fff445153c543bc8947
makedepends_x86_64 = gcc-multilib
diff --git a/013-Makefile.patch b/013-Makefile.patch
new file mode 100644
index 000000000000..30b44c7259fd
--- /dev/null
+++ b/013-Makefile.patch
@@ -0,0 +1,44 @@
+diff --git a/src/VBox/HostDrivers/linux/Makefile b/src/VBox/HostDrivers/linux/Makefile
+index 18466b48..7c7de4e5 100644
+--- a/src/VBox/HostDrivers/linux/Makefile
++++ b/src/VBox/HostDrivers/linux/Makefile
+@@ -23,25 +23,25 @@
+ # terms and conditions of either the GPL or the CDDL or both.
+ #
+
+-ifneq ($(KERNELRELEASE),)
++ifneq ($(KBUILD_EXTMOD),)
+
+-# Building from kBuild (make -C <kernel_directory> M=`pwd`),
+-# or inside a kernel source tree.
++# Building from kBuild (make -C <kernel_directory> M=`pwd`).
++# KBUILD_EXTMOD is set to $(M) in this case.
+
+ obj-m = vboxdrv/
+-ifneq ($(wildcard $(CURDIR)/vboxnetflt/Makefile),)
++ifneq ($(wildcard $(KBUILD_EXTMOD)/vboxnetflt/Makefile),)
+ obj-m += vboxnetflt/
+ endif
+-ifneq ($(wildcard $(CURDIR)/vboxnetadp/Makefile),)
++ifneq ($(wildcard $(KBUILD_EXTMOD)/vboxnetadp/Makefile),)
+ obj-m += vboxnetadp/
+ endif
+-ifneq ($(wildcard $(CURDIR)/vboxpci/Makefile),)
++ifneq ($(wildcard $(KBUILD_EXTMOD)/vboxpci/Makefile),)
+ obj-m += vboxpci/
+ endif
+
+-else # ! KERNELRELEASE
++else # ! KBUILD_EXTMOD
+
+-# convenience Makefile without KERNELRELEASE
++# convenience Makefile without KBUILD_EXTMOD
+
+ KBUILD_VERBOSE ?=
+ KERN_VER ?= $(shell uname -r)
+@@ -146,4 +146,4 @@ load: unload
+ fi; \
+ done
+
+-endif # ! KERNELRELEASE
++endif # ! KBUILD_EXTMOD
diff --git a/PKGBUILD b/PKGBUILD
index 109714c79406..45b5217b6bfe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ pkgname=('virtualbox-svn'
'virtualbox-guest-utils-nox-svn'
'virtualbox-ext-vnc-svn')
pkgver=78447
-pkgrel=1
+pkgrel=2
_vboxsf_commit='87b9015c57dd7f226c768131bf8b4c0249de9835'
arch=('x86_64')
url='http://virtualbox.org'
@@ -77,6 +77,7 @@ source=("VirtualBox::svn+http://www.virtualbox.org/svn/vbox/trunk"
'008-no-vboxvideo.patch'
'011-python-3-7.patch'
'012-vbglR3GuestCtrlDetectPeekGetCancelSupport.patch'
+ '013-Makefile.patch'
# The following patch and mount.vboxsf wrapper should be removed
# once support for mainline-style options string gets upstreamed
'101-vboxsf-automount.patch'
@@ -101,6 +102,7 @@ sha256sums=('SKIP'
'8b7f241107863f82a5b0ae336aead0b3366a40103ff72dbebf33f54b512a0cbc'
'55224cb74b54b331d691f171efc0d4c058a14f738551f1d8f559146c2908635d'
'06485dce54a5f21b85f4360db884d98c1ab091d3f2535881ec9fcd82feb06b7e'
+ 'da7e58ed37dc23c6202aab3017864579a99e78417f3421ddcc98a198198fe2c9'
'a784f3cc24652a16385cc63abac6c5178932ca5f3861be7650631b7dafa753a4'
'f3ed6741f8977f40900c8aa372fa082df1f8723d497d4fff445153c543bc8947')