summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo (XenGi) Band2020-11-27 11:34:12 +0100
committerRicardo (XenGi) Band2020-11-27 11:34:12 +0100
commit75f860492d0be26a70f618acdd5c16406cbff096 (patch)
treedc7d053e6a2761a69b8dc42aa00f6d3d090989e8
parentf62057deca7ca0309cdca73671baef45653c5371 (diff)
downloadaur-75f860492d0be26a70f618acdd5c16406cbff096.tar.gz
changed fish to a runtime dependency
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c397f85b6fff..320554358c0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = virtualfish
pkgdesc = Fish shell tool for managing Python virtual environments
pkgver = 2.5.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/justinmayer/virtualfish
arch = any
license = MIT
@@ -9,9 +9,9 @@ pkgbase = virtualfish
depends = python-pkgconfig
depends = python-psutil
depends = python-virtualenv
- depends = fish>=3.1
source = https://files.pythonhosted.org/packages/source/v/virtualfish/virtualfish-2.5.0.tar.gz
sha256sums = 922f4990980136db3b62791f4898add90eea03e3b8f8c8ca9d21327987033468
pkgname = virtualfish
+ depends = fish>=3.1
diff --git a/PKGBUILD b/PKGBUILD
index e67570fe1f23..02be66b42928 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Ricardo Band <email@ricardo.band>
pkgname=virtualfish
pkgver=2.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Fish shell tool for managing Python virtual environments"
arch=("any")
url=https://github.com/justinmayer/virtualfish
license=("MIT")
-depends=("python-pkgconfig" "python-psutil" "python-virtualenv" "fish>=3.1")
+depends=("python-pkgconfig" "python-psutil" "python-virtualenv")
makedepends=("python-setuptools")
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
sha256sums=('922f4990980136db3b62791f4898add90eea03e3b8f8c8ca9d21327987033468')
@@ -17,6 +17,8 @@ build() {
}
package() {
+ depends=("fish>=3.1")
+
cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}