summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo (XenGi) Band2020-04-11 22:17:06 +0200
committerRicardo (XenGi) Band2020-04-11 22:17:06 +0200
commita6ce71c5733c01838784b461b70efadbf392b7f1 (patch)
tree2a6b0e44fec31c6cbbce65dca22b1ec475b46729
parentb3ed6cc4e93c9d2522976613bc8bf9b44533b3d7 (diff)
downloadaur-a6ce71c5733c01838784b461b70efadbf392b7f1.tar.gz
bumped to v2.2.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--xdg.patch51
3 files changed, 9 insertions, 70 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fc2db6c8df6f..2ed9ad05e214 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = virtualfish
pkgdesc = Fish shell tool for managing Python virtual environments
- pkgver = 2.1.0
- pkgrel = 4
+ pkgver = 2.2.0
+ pkgrel = 1
url = https://github.com/justinmayer/virtualfish
arch = any
license = MIT
@@ -10,10 +10,8 @@ pkgbase = virtualfish
depends = python-pkgconfig
depends = python-psutil
depends = python-virtualenv
- source = https://files.pythonhosted.org/packages/source/v/virtualfish/virtualfish-2.1.0.tar.gz
- source = xdg.patch
- sha256sums = 704b9e4ec0594f84ef6a29d3caca4c74ee9778ec57ab97c5bd79073e477982c2
- sha256sums = 5eeea55f3c7c216fbf04368936005da618f49c57f75bda66e8e3d15772d17a87
+ source = https://files.pythonhosted.org/packages/source/v/virtualfish/virtualfish-2.2.0.tar.gz
+ sha256sums = 9dae04094af00b1033ee837a2e0781ae3afd6d278ee9e3884009dcebbd8bb1a2
pkgname = virtualfish
diff --git a/PKGBUILD b/PKGBUILD
index 60d35dfb8dc1..99a17bb276e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,15 @@
# Maintainer: Ricardo Band <email@ricardo.band>
pkgname=virtualfish
-pkgver=2.1.0
-pkgrel=4
+pkgver=2.2.0
+pkgrel=1
pkgdesc="Fish shell tool for managing Python virtual environments"
arch=("any")
url=https://github.com/justinmayer/virtualfish
license=("MIT")
-depends=("python" "python-pkgconfig" "python-psutil" "python-virtualenv") # python-pyxdg
+depends=("python" "python-pkgconfig" "python-psutil" "python-virtualenv")
makedepends=("python-setuptools")
-source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz"
- "xdg.patch")
-sha256sums=('704b9e4ec0594f84ef6a29d3caca4c74ee9778ec57ab97c5bd79073e477982c2'
- '5eeea55f3c7c216fbf04368936005da618f49c57f75bda66e8e3d15772d17a87')
-
-prepare() {
- cd "$srcdir/$pkgname-$pkgver"
- # fix issue with xdg/pyxdg https://bugs.archlinux.org/task/64173
- patch --forward --strip=1 --input="${srcdir}/xdg.patch"
-}
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('9dae04094af00b1033ee837a2e0781ae3afd6d278ee9e3884009dcebbd8bb1a2')
build() {
cd "$srcdir/$pkgname-$pkgver"
diff --git a/xdg.patch b/xdg.patch
deleted file mode 100644
index f625c4b4fb3b..000000000000
--- a/xdg.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-diff --unified --recursive --text virtualfish-2.1.0/PKG-INFO virtualfish-2.1.0.patched/PKG-INFO
---- virtualfish-2.1.0/PKG-INFO 2020-04-04 10:49:48.721342800 +0200
-+++ virtualfish-2.1.0.patched/PKG-INFO 2020-04-07 15:28:38.982243164 +0200
-@@ -22,7 +22,6 @@
- Requires-Dist: pkgconfig (>=1.5,<2.0)
- Requires-Dist: psutil (>=5.7,<6.0)
- Requires-Dist: virtualenv (>=20,<21)
--Requires-Dist: xdg (>=4.0,<5.0)
- Project-URL: Documentation, https://virtualfish.readthedocs.org/
- Project-URL: Repository, https://github.com/justinmayer/virtualfish
- Project-URL: Tracker, https://github.com/justinmayer/virtualfish/issues
-diff --unified --recursive --text virtualfish-2.1.0/pyproject.toml virtualfish-2.1.0.patched/pyproject.toml
---- virtualfish-2.1.0/pyproject.toml 2020-04-04 10:49:48.220612800 +0200
-+++ virtualfish-2.1.0.patched/pyproject.toml 2020-04-07 15:28:47.880288901 +0200
-@@ -31,7 +31,6 @@
- pkgconfig = "^1.5"
- psutil = "^5.7"
- virtualenv = "^20"
--xdg = "^4.0"
-
- [tool.poetry.dev-dependencies]
- black = "^19.10b0"
-diff --unified --recursive --text virtualfish-2.1.0/setup.py virtualfish-2.1.0.patched/setup.py
---- virtualfish-2.1.0/setup.py 2020-04-04 10:49:48.720887200 +0200
-+++ virtualfish-2.1.0.patched/setup.py 2020-04-07 15:28:57.138384051 +0200
-@@ -10,8 +10,7 @@
- install_requires = \
- ['pkgconfig>=1.5,<2.0',
- 'psutil>=5.7,<6.0',
-- 'virtualenv>=20,<21',
-- 'xdg>=4.0,<5.0']
-+ 'virtualenv>=20,<21']
-
- entry_points = \
- {'console_scripts': ['vf = virtualfish.loader.cli:main']}
-diff --unified --recursive --text virtualfish-2.1.0/virtualfish/loader/installer.py virtualfish-2.1.0.patched/virtualfish/loader/installer.py
---- virtualfish-2.1.0/virtualfish/loader/installer.py 2020-04-04 10:47:54.392377100 +0200
-+++ virtualfish-2.1.0.patched/virtualfish/loader/installer.py 2020-04-07 15:29:28.782744132 +0200
-@@ -1,11 +1,10 @@
- import os
- import sys
-
--from xdg import XDG_CONFIG_HOME
-
- from virtualfish.loader import load
-
--INSTALL_DIR = os.path.join(XDG_CONFIG_HOME, "fish", "conf.d")
-+INSTALL_DIR = os.path.expanduser("~/.config/fish/conf.d")
- INSTALL_FILE = os.path.join(INSTALL_DIR, "virtualfish-loader.fish")
-
-