summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo (XenGi) Band2020-04-07 15:36:17 +0200
committerRicardo (XenGi) Band2020-04-07 15:36:17 +0200
commitb3ed6cc4e93c9d2522976613bc8bf9b44533b3d7 (patch)
tree75775ef447a677d8de1262b20d316d7db4332ec8
parent48dbe0a8bc7e2007f853a00048614b86de3d0a08 (diff)
downloadaur-b3ed6cc4e93c9d2522976613bc8bf9b44533b3d7.tar.gz
fixed it once and for all
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
-rw-r--r--xdg.patch51
3 files changed, 64 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8793f9f7dc6..fc2db6c8df6f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = virtualfish
pkgdesc = Fish shell tool for managing Python virtual environments
pkgver = 2.1.0
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/justinmayer/virtualfish
arch = any
license = MIT
@@ -11,9 +11,9 @@ pkgbase = virtualfish
depends = python-psutil
depends = python-virtualenv
source = https://files.pythonhosted.org/packages/source/v/virtualfish/virtualfish-2.1.0.tar.gz
- source = xdg.py::https://github.com/srstevenson/xdg/raw/4.0.1/src/xdg/__init__.py
+ source = xdg.patch
sha256sums = 704b9e4ec0594f84ef6a29d3caca4c74ee9778ec57ab97c5bd79073e477982c2
- sha256sums = 8be0fdce34525e68d18dc3df8297a1672551bdae4b8dfab6d0eb6ee7be1e0f0e
+ sha256sums = 5eeea55f3c7c216fbf04368936005da618f49c57f75bda66e8e3d15772d17a87
pkgname = virtualfish
diff --git a/PKGBUILD b/PKGBUILD
index aa64f7055146..60d35dfb8dc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,23 @@
# Maintainer: Ricardo Band <email@ricardo.band>
pkgname=virtualfish
pkgver=2.1.0
-pkgrel=3
+pkgrel=4
pkgdesc="Fish shell tool for managing Python virtual environments"
arch=("any")
url=https://github.com/justinmayer/virtualfish
license=("MIT")
-depends=("python" "python-pkgconfig" "python-psutil" "python-virtualenv") # python-xdg
+depends=("python" "python-pkgconfig" "python-psutil" "python-virtualenv") # python-pyxdg
makedepends=("python-setuptools")
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz"
- "xdg.py::https://github.com/srstevenson/xdg/raw/4.0.1/src/xdg/__init__.py")
+ "xdg.patch")
sha256sums=('704b9e4ec0594f84ef6a29d3caca4c74ee9778ec57ab97c5bd79073e477982c2'
- '8be0fdce34525e68d18dc3df8297a1672551bdae4b8dfab6d0eb6ee7be1e0f0e')
+ '5eeea55f3c7c216fbf04368936005da618f49c57f75bda66e8e3d15772d17a87')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ # fix issue with xdg/pyxdg https://bugs.archlinux.org/task/64173
+ patch --forward --strip=1 --input="${srcdir}/xdg.patch"
+}
build() {
cd "$srcdir/$pkgname-$pkgver"
@@ -21,8 +27,5 @@ build() {
package() {
cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
-
- # temporary fix issue with xdg/pyxdg https://bugs.archlinux.org/task/64173
- install -m 0644 "$srcdir/xdg.py" "$pkgdir/usr/lib/python3.8/site-packages/virtualfish/loader/xdg.py"
}
diff --git a/xdg.patch b/xdg.patch
new file mode 100644
index 000000000000..f625c4b4fb3b
--- /dev/null
+++ b/xdg.patch
@@ -0,0 +1,51 @@
+diff --unified --recursive --text virtualfish-2.1.0/PKG-INFO virtualfish-2.1.0.patched/PKG-INFO
+--- virtualfish-2.1.0/PKG-INFO 2020-04-04 10:49:48.721342800 +0200
++++ virtualfish-2.1.0.patched/PKG-INFO 2020-04-07 15:28:38.982243164 +0200
+@@ -22,7 +22,6 @@
+ Requires-Dist: pkgconfig (>=1.5,<2.0)
+ Requires-Dist: psutil (>=5.7,<6.0)
+ Requires-Dist: virtualenv (>=20,<21)
+-Requires-Dist: xdg (>=4.0,<5.0)
+ Project-URL: Documentation, https://virtualfish.readthedocs.org/
+ Project-URL: Repository, https://github.com/justinmayer/virtualfish
+ Project-URL: Tracker, https://github.com/justinmayer/virtualfish/issues
+diff --unified --recursive --text virtualfish-2.1.0/pyproject.toml virtualfish-2.1.0.patched/pyproject.toml
+--- virtualfish-2.1.0/pyproject.toml 2020-04-04 10:49:48.220612800 +0200
++++ virtualfish-2.1.0.patched/pyproject.toml 2020-04-07 15:28:47.880288901 +0200
+@@ -31,7 +31,6 @@
+ pkgconfig = "^1.5"
+ psutil = "^5.7"
+ virtualenv = "^20"
+-xdg = "^4.0"
+
+ [tool.poetry.dev-dependencies]
+ black = "^19.10b0"
+diff --unified --recursive --text virtualfish-2.1.0/setup.py virtualfish-2.1.0.patched/setup.py
+--- virtualfish-2.1.0/setup.py 2020-04-04 10:49:48.720887200 +0200
++++ virtualfish-2.1.0.patched/setup.py 2020-04-07 15:28:57.138384051 +0200
+@@ -10,8 +10,7 @@
+ install_requires = \
+ ['pkgconfig>=1.5,<2.0',
+ 'psutil>=5.7,<6.0',
+- 'virtualenv>=20,<21',
+- 'xdg>=4.0,<5.0']
++ 'virtualenv>=20,<21']
+
+ entry_points = \
+ {'console_scripts': ['vf = virtualfish.loader.cli:main']}
+diff --unified --recursive --text virtualfish-2.1.0/virtualfish/loader/installer.py virtualfish-2.1.0.patched/virtualfish/loader/installer.py
+--- virtualfish-2.1.0/virtualfish/loader/installer.py 2020-04-04 10:47:54.392377100 +0200
++++ virtualfish-2.1.0.patched/virtualfish/loader/installer.py 2020-04-07 15:29:28.782744132 +0200
+@@ -1,11 +1,10 @@
+ import os
+ import sys
+
+-from xdg import XDG_CONFIG_HOME
+
+ from virtualfish.loader import load
+
+-INSTALL_DIR = os.path.join(XDG_CONFIG_HOME, "fish", "conf.d")
++INSTALL_DIR = os.path.expanduser("~/.config/fish/conf.d")
+ INSTALL_FILE = os.path.join(INSTALL_DIR, "virtualfish-loader.fish")
+
+