summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXenGi2017-09-04 00:20:44 +0200
committerXenGi2017-09-04 00:20:44 +0200
commitd68fe83072f6a9e7642c7f10e483f4d0d2863beb (patch)
tree2c8ab3732bbb4806d40a3335edde2d1b8809235f
downloadaur-d68fe83072f6a9e7642c7f10e483f4d0d2863beb.tar.gz
added python2 version
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore44
-rw-r--r--PKGBUILD33
3 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..04e6f03ed29e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = virtualfish
+ pkgdesc = A virtualenv wrapper for the Fish shell
+ pkgver = 1.0.5
+ pkgrel = 4
+ url = https://github.com/adambrenecki/virtualfish
+ arch = any
+ license = MIT
+ depends = python-virtualenv
+ depends = python2-virtualenv
+ depends = python-setuptools
+ depends = python2-setuptools
+ options = !emptydirs
+ source = virtualfish::git+https://github.com/adambrenecki/virtualfish.git#tag=1.0.5
+ sha1sums = SKIP
+
+pkgname = python-virtualfish
+ depends = python-virtualenv
+ depends = python-setuptools
+
+pkgname = python2-virtualfish
+ depends = python2-virtualenv
+ depends = python2-setuptools
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bf7612cc53c9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,44 @@
+
+# Created by https://www.gitignore.io/api/linux,archlinuxpackages,vim
+
+### Linux ###
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+
+### Vim ###
+# swap
+[._]*.s[a-w][a-z]
+[._]s[a-w][a-z]
+# session
+Session.vim
+# temporary
+.netrwhist
+*~
+# auto-generated tag files
+tags
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1e2444daaf63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Ricardo (XenGi) Band <email@ricardo.band>
+pkgbase=virtualfish
+pkgname=('python-virtualfish' 'python2-virtualfish')
+pkgname=python-$pkgbase
+pkgver=1.0.5
+pkgrel=4
+pkgdesc="A virtualenv wrapper for the Fish shell"
+arch=(any)
+url="https://github.com/adambrenecki/virtualfish"
+license=('MIT')
+depends=('python-virtualenv' 'python2-virtualenv' 'python-setuptools' 'python2-setuptools')
+options=(!emptydirs)
+install=
+source=("${pkgbase}::git+https://github.com/adambrenecki/${pkgbase}.git#tag=1.0.5")
+sha1sums=('SKIP')
+
+prepare() {
+ cp -a "$srcdir/$pkgbase"{,-py2}
+}
+
+package_python-virtualfish() {
+ depends=('python-virtualenv' 'python-setuptools')
+
+ cd "${srcdir}/${pkgbase}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+package_python2-virtualfish() {
+ depends=('python2-virtualenv' 'python2-setuptools')
+
+ cd "${srcdir}/${pkgbase}-py2"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}