summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDāvis2020-02-13 02:15:48 +0200
committerDāvis2020-02-13 02:15:48 +0200
commit6be34f1bbf5f93ebcc263fe80e1956b63ee25ead (patch)
tree3f8438cd4c0f364a2828065486434802743a2ade
parent495a170ad6460ac18d9b7c700ec30f442f54b126 (diff)
downloadaur-6be34f1bbf5f93ebcc263fe80e1956b63ee25ead.tar.gz
Add patch so it builds with neset mesa
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--fix_mesa_change.patch15
3 files changed, 24 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b27b3ae4d2b9..dc14f1ebb3e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Fri Jul 7 16:36:23 UTC 2017
pkgbase = virtualgl-git
pkgdesc = Redirects 3D commands from an OpenGL application onto a server-side 3D graphics card
- pkgver = 2.4.r138.ga930d056
+ pkgver = 2.4.r399.g2a7fadbc
pkgrel = 1
url = http://www.virtualgl.org/
arch = i686
@@ -15,8 +13,10 @@ pkgbase = virtualgl-git
depends = xcb-util-keysyms
provides = virtualgl
conflicts = virtualgl
- source = virtualgl::git+https://github.com/VirtualGL/virtualgl.git
+ source = virtualgl::git+https://github.com/VirtualGL/virtualgl.git#branch=dev
+ source = fix_mesa_change.patch
sha256sums = SKIP
+ sha256sums = 38ef2efcf973f42855c7e5260d758904d06c8a04d29c6e43e9f07620977535b4
pkgname = virtualgl-git
diff --git a/PKGBUILD b/PKGBUILD
index 39183a86af08..951b299fb093 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=virtualgl
pkgname=$_pkgname-git
-pkgver=2.4.r138.ga930d056
+pkgver=2.4.r399.g2a7fadbc
pkgrel=1
pkgdesc='Redirects 3D commands from an OpenGL application onto a server-side 3D graphics card'
arch=('i686' 'x86_64')
@@ -12,8 +12,8 @@ depends=('libxv' 'glu' 'libjpeg-turbo' 'xcb-util-keysyms')
makedepends=('git')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$_pkgname::git+https://github.com/VirtualGL/virtualgl.git")
-sha256sums=('SKIP')
+source=("$_pkgname::git+https://github.com/VirtualGL/virtualgl.git#branch=dev" "fix_mesa_change.patch")
+sha256sums=('SKIP' '38ef2efcf973f42855c7e5260d758904d06c8a04d29c6e43e9f07620977535b4')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -23,6 +23,8 @@ pkgver() {
prepare() {
cd "$srcdir"
mkdir -p build
+ cd "virtualgl"
+ patch -p1 < ./../fix_mesa_change.patch
}
build() {
diff --git a/fix_mesa_change.patch b/fix_mesa_change.patch
new file mode 100644
index 000000000000..32c8b301dc1d
--- /dev/null
+++ b/fix_mesa_change.patch
@@ -0,0 +1,15 @@
+diff --git a/server/faker-glx.cpp b/server/faker-glx.cpp
+index 4a620b79..eed2b07e 100644
+--- a/server/faker-glx.cpp
++++ b/server/faker-glx.cpp
+@@ -1811,11 +1811,10 @@ void glXQueryDrawable(Display *dpy, GLXDrawable draw, int attribute,
+ CATCH();
+ }
+
+-int glXQueryGLXPbufferSGIX(Display *dpy, GLXPbuffer pbuf, int attribute,
++void glXQueryGLXPbufferSGIX(Display *dpy, GLXPbuffer pbuf, int attribute,
+ unsigned int *value)
+ {
+ glXQueryDrawable(dpy, pbuf, attribute, value);
+- return 0;
+ }