summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebRmv2016-11-05 11:02:22 +0100
committerSebRmv2016-11-05 11:04:23 +0100
commit4f4ee0626f63334fad9b4aea3fac2fa66c2fb9e6 (patch)
tree2ec31386f5d3c7e90cd5587be172ab3a6d9bca4b
parentb6ea05e262bf04b89dd5f34d208738663006d333 (diff)
downloadaur-4f4ee0626f63334fad9b4aea3fac2fa66c2fb9e6.tar.gz
Fix package.
-rw-r--r--0001-Fix-Makefile-qt-5-is-not-a-valid-option-of-recent-qm.patch25
-rw-r--r--PKGBUILD7
2 files changed, 29 insertions, 3 deletions
diff --git a/0001-Fix-Makefile-qt-5-is-not-a-valid-option-of-recent-qm.patch b/0001-Fix-Makefile-qt-5-is-not-a-valid-option-of-recent-qm.patch
new file mode 100644
index 000000000000..c25a5ae5bbb4
--- /dev/null
+++ b/0001-Fix-Makefile-qt-5-is-not-a-valid-option-of-recent-qm.patch
@@ -0,0 +1,25 @@
+From bbec2c8e4c8f306cf9fa2c5a140aabc9aa2b167a Mon Sep 17 00:00:00 2001
+From: Seb/The Removers <SebRmv@jagware.org>
+Date: Fri, 4 Nov 2016 10:35:31 +0100
+Subject: [PATCH] Fix Makefile: -qt=5 is not a valid option of recent qmake.
+
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 29f5f49..b4b8512 100644
+--- a/Makefile
++++ b/Makefile
+@@ -65,7 +65,7 @@ virtualjaguar: sources libs makefile-qt
+
+ makefile-qt: virtualjaguar.pro
+ @echo -e "\033[01;33m***\033[00;32m Creating Qt makefile...\033[00m"
+- $(Q)$(CROSS)qmake -qt=5 $(QMAKE_EXTRA) virtualjaguar.pro -o makefile-qt
++ $(Q)$(CROSS)qmake-qt5 $(QMAKE_EXTRA) virtualjaguar.pro -o makefile-qt
+
+ libs: obj/libm68k.a obj/libjaguarcore.a
+ @echo -e "\033[01;33m***\033[00;32m Libraries successfully made.\033[00m"
+--
+2.10.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 5b05f1c6982a..4b885c78f10c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: SebRmv <sbriais at-symbol free dot fr>
pkgname=virtualjaguar-git
pkgver=r503.a0fe543
-pkgrel=1
+pkgrel=3
pkgdesc="A portable Atari Jaguar emulator"
arch=('i686' 'x86_64')
url=http://icculus.org/virtualjaguar/
@@ -10,8 +10,8 @@ depends=('qt4' 'gcc' 'gdb' 'sdl' 'zlib' 'libcdio' 'freeglut')
makedepends=('git')
provides=('virtualjaguar')
conflicts=('virtualjaguar' 'virtualjaguar-svn')
-source=('virtualjaguar::git+http://shamusworld.gotdns.org/git/virtualjaguar')
-sha1sums=(SKIP)
+source=('virtualjaguar::git+http://shamusworld.gotdns.org/git/virtualjaguar' '0001-Fix-Makefile-qt-5-is-not-a-valid-option-of-recent-qm.patch')
+sha1sums=(SKIP '7bbe6bf9cb1c0cd0c09a9b717021058384e07fa2')
_gitname='virtualjaguar'
@@ -23,6 +23,7 @@ build() {
cp -r "$_gitname" "$_gitname-build"
cd "$_gitname-build"
+ git apply "$srcdir/0001-Fix-Makefile-qt-5-is-not-a-valid-option-of-recent-qm.patch"
make
}