summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2021-12-11 03:43:19 -0500
committerTony Lambiris2021-12-11 03:43:19 -0500
commit44ad68ea3875a2cacab9d7bc116a401296ade7f5 (patch)
tree73305a5f45b25266747897b10fcbf210d543e4c5
parent6d3568ed3f0d522af4c0f91ad1c15e592b0a3790 (diff)
downloadaur-44ad68ea3875a2cacab9d7bc116a401296ade7f5.tar.gz
Version bump
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD18
2 files changed, 7 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86e003b44ebb..81c4be1ade86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = virusgotal-git
pkgdesc = VirusTotal zero dependency command line client.
pkgver = 1.0.2.r5.g295d2dc
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/moldabekov/virusgotal
arch = x86_64
license = MIT
@@ -12,4 +12,3 @@ pkgbase = virusgotal-git
sha256sums = SKIP
pkgname = virusgotal-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c592fc0278c8..c0e88b3e2717 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=virusgotal-git
pkgver=1.0.2.r5.g295d2dc
-pkgrel=2
+pkgrel=3
pkgdesc='VirusTotal zero dependency command line client.'
arch=(x86_64)
url="https://github.com/moldabekov/virusgotal"
@@ -27,9 +27,7 @@ prepare() {
cd "${srcdir}/go/src/github.com/moldabekov/virusgotal"
- export GO111MODULE="auto"
- export GOPATH="${srcdir}/go"
-
+ export GOPATH="${srcdir}/go" GOFLAGS="-modcacherw"
go get -v ./...
}
@@ -38,18 +36,14 @@ build() {
mkdir -p build
- export GO111MODULE="auto"
- export GOPATH="${srcdir}/go"
-
- go build -ldflags "-s -w" \
- -gcflags="all=-trimpath=${GOPATH}/src" \
- -asmflags="all=-trimpath=${GOPATH}/src" \
+ export GOPATH="${srcdir}/go" GOFLAGS="-modcacherw"
+ go build -trimpath -ldflags "-s -w" \
-o build/virusgotal
}
package() {
cd "${srcdir}/go/src/github.com/moldabekov/virusgotal"
- install -Dm755 "./build/virusgotal" "${pkgdir}/usr/bin/virusgotal"
- install -Dm644 "./LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 "build/virusgotal" "${pkgdir}/usr/bin/virusgotal"
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}