summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShibumi2015-07-20 22:18:50 +0200
committerShibumi2015-07-20 22:18:50 +0200
commit20ec56a7498ea1a48e247e9e8b771229e7ce9bba (patch)
tree18a5fe40d84dc8abf960bace1e86488c2a316a52
downloadaur-20ec56a7498ea1a48e247e9e8b771229e7ce9bba.tar.gz
initial push to aur4
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD22
-rw-r--r--virustotal.install7
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a8efc593b391
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = virustotal
+ pkgdesc = Command-line client for virustotal.com
+ pkgver = 1.1
+ pkgrel = 3
+ url = https://github.com/botherder/virustotal
+ install = virustotal.install
+ arch = any
+ license = BSD
+ depends = python
+ backup = etc/virustotal.conf
+ source = https://github.com/shibumi/virustotal/archive/1.1.tar.gz
+ source = virustotal.install
+ sha512sums = 48254029c3adf8ea25ed070a68363b5224a86291b5bfd3f14e102ecc3d377fd79f4d1a21ad00c2991c9b3ab4d81422aad5c710782b5e5214680c02bbda240ad9
+ sha512sums = 9fc9a73398e517a0bd330712633b2884bf3ab35f10c908650390f74341f368e9cf5528eca89a75fc2ceea27191659b4eee57a3ae7899eb1d3c102dcdaf6cc5be
+
+pkgname = virustotal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01e1a354dd4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Christian Rebischke <echo Q2hyaXMuUmViaXNjaGtlQGdtYWlsLmNvbQo= | base64 -d>
+pkgname=virustotal
+pkgver=1.1
+pkgrel=3
+pkgdesc='Command-line client for virustotal.com'
+arch=('any')
+url="https://github.com/botherder/virustotal"
+license=('BSD')
+depends=('python')
+source=("https://github.com/shibumi/$pkgname/archive/$pkgver.tar.gz"
+"virustotal.install")
+sha512sums=('48254029c3adf8ea25ed070a68363b5224a86291b5bfd3f14e102ecc3d377fd79f4d1a21ad00c2991c9b3ab4d81422aad5c710782b5e5214680c02bbda240ad9'
+'9fc9a73398e517a0bd330712633b2884bf3ab35f10c908650390f74341f368e9cf5528eca89a75fc2ceea27191659b4eee57a3ae7899eb1d3c102dcdaf6cc5be')
+backup=('etc/virustotal.conf')
+install=('virustotal.install')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -D -m755 vt.py "$pkgdir/usr/bin/virustotal"
+ install -D -m644 virustotal.conf "$pkgdir/etc/virustotal.conf"
+
+}
diff --git a/virustotal.install b/virustotal.install
new file mode 100644
index 000000000000..8c35e1e047a5
--- /dev/null
+++ b/virustotal.install
@@ -0,0 +1,7 @@
+#!/bin/bash
+
+post_install(){
+ echo "[+] Please get a valid virustotal API-key and edit /etc/virustotal.conf"
+}
+
+