summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Feletto2020-11-18 14:43:23 +0100
committerAndrea Feletto2020-11-18 14:43:23 +0100
commitd50af90869b79d4df30e98f855e2ec4d598e24e3 (patch)
treef2a52f78c28d690bdcd82f564a4e31d131319a8e
downloadaur-d50af90869b79d4df30e98f855e2ec4d598e24e3.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f9ec4e0e6b4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vis-base16-git
+ pkgdesc = cscope interface for the vis editor.
+ pkgver = r6.05dae61
+ pkgrel = 1
+ url = https://github.com/pshevtsov/base16-vis
+ arch = any
+ license = MIT
+ depends = vis
+ provides = vis-base16
+ conflicts = vis-base16
+ source = git+https://github.com/pshevtsov/base16-vis.git
+ sha256sums = SKIP
+
+pkgname = vis-base16-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..247a3d8c9156
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+
+# Maintainer: Andrea Feletto <andrea@andreafeletto.com>
+
+pkgname=vis-base16-git
+_pkgname=base16-vis
+pkgver=r6.05dae61
+pkgrel=1
+pkgdesc='cscope interface for the vis editor.'
+arch=('any')
+url='https://github.com/pshevtsov/base16-vis'
+license=('MIT')
+depends=('vis')
+provides=('vis-base16')
+conflicts=('vis-base16')
+source=("git+https://github.com/pshevtsov/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ vispath="$pkgdir/usr/share/vis/themes"
+ licenses="$pkgdir/usr/share/licenses/${pkgname%-git}"
+
+ cd "$srcdir/$_pkgname"
+ install -dv "$vispath"
+ cp themes/* "$vispath"
+ install -Dm644 LICENSE "$licenses/LICENSE"
+}