summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Feletto2021-09-26 18:49:24 +0200
committerAndrea Feletto2021-09-26 18:49:24 +0200
commit4fcb145c167a50e9dcf9fdffcac8947fca29a761 (patch)
tree2c37eeaa208509a665fa57b8659d4ac765110cc5
downloadaur-4fcb145c167a50e9dcf9fdffcac8947fca29a761.tar.gz
first commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa9af939e35d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = vis-filetype-settings-git
+ pkgdesc = A plugin for the vis editor that lets the user set options depending on filetype.
+ pkgver = r8.60f8fa3
+ pkgrel = 1
+ url = https://github.com/jocap/vis-filetype-settings
+ arch = any
+ license = MIT
+ depends = vis
+ provides = vis-filetype-settings
+ conflicts = vis-filetype-settings
+ source = git+https://github.com/jocap/vis-filetype-settings
+ sha256sums = SKIP
+
+pkgname = vis-filetype-settings-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26acf226d50a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+
+# Maintainer: Andrea Feletto <andrea@andreafeletto.com>
+
+pkgname=vis-filetype-settings-git
+_pkgname=${pkgname%-git}
+pkgver=r8.60f8fa3
+pkgrel=1
+pkgdesc='A plugin for the vis editor that lets the user set options depending on filetype.'
+arch=('any')
+url='https://github.com/jocap/vis-filetype-settings'
+license=('MIT')
+depends=('vis')
+provides=('vis-filetype-settings')
+conflicts=('vis-filetype-settings')
+source=("git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm644 "$_pkgname.lua" -t "$pkgdir/usr/share/vis/plugins"
+ install -Dm644 'LICENSE' -t "$pkgdir/usr/share/licenses/$_pkgname"
+ install -Dm644 'README.md' -t "$pkgdir/usr/share/doc/$_pkgname"
+}