summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Feletto2020-12-29 18:16:33 +0100
committerAndrea Feletto2020-12-29 18:16:33 +0100
commitd04e844333910455d62c18795c5cbf99aceefee9 (patch)
tree95f0c4fec8c96401e03d08dd037ee740c74bf80e
downloadaur-d04e844333910455d62c18795c5cbf99aceefee9.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71608103c738
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vis-smart-backspace-git
+ pkgdesc = A plugin for simulating softtabstop in vis.
+ pkgver = r2.ae165c1
+ pkgrel = 1
+ url = https://github.com/ingolemo/vis-smart-backspace
+ arch = any
+ license = GPL3
+ depends = vis
+ provides = vis-smart-backspace
+ conflicts = vis-smart-backspace
+ source = git+https://github.com/ingolemo/vis-smart-backspace.git
+ sha256sums = SKIP
+
+pkgname = vis-smart-backspace-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb94130f2e2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+
+# Maintainer: Andrea Feletto <andrea@andreafeletto.com>
+
+pkgname=vis-smart-backspace-git
+_pkgname=${pkgname%-git}
+pkgver=r2.ae165c1
+pkgrel=1
+pkgdesc='A plugin for simulating softtabstop in vis.'
+arch=('any')
+url='https://github.com/ingolemo/vis-smart-backspace'
+license=('GPL3')
+depends=('vis')
+provides=('vis-smart-backspace')
+conflicts=('vis-smart-backspace')
+source=("git+https://github.com/ingolemo/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm644 'init.lua' -t "$pkgdir/usr/share/vis/plugins/$_pkgname"
+ install -Dm644 'LICENSE' -t "$pkgdir/usr/share/licenses/$_pkgname"
+ install -Dm644 'README.md' -t "$pkgdir/usr/share/doc/$_pkgname"
+}