summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Feletto2020-12-30 11:58:19 +0100
committerAndrea Feletto2020-12-30 11:58:19 +0100
commitb81ad6c9a7a4d2269e02038f4ca29597ec79fe27 (patch)
tree92521bce8adf539338ae3d672d6bed4761f9a886
downloadaur-vis-spellcheck-git.tar.gz
first commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD28
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad4dff79f133
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = vis-spellcheck-git
+ pkgdesc = Spellcheck plugin for the vis editor.
+ pkgver = r53.cc24d18
+ pkgrel = 1
+ url = https://github.com/fischerling/vis-spellcheck
+ arch = any
+ license = MIT
+ depends = vis
+ provides = vis-spellcheck
+ conflicts = vis-spellcheck
+ source = git+https://github.com/fischerling/vis-spellcheck.git
+ sha256sums = SKIP
+
+pkgname = vis-spellcheck-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7900364c3b09
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+
+# Maintainer: Andrea Feletto <andrea@andreafeletto.com>
+
+pkgname=vis-spellcheck-git
+_pkgname=${pkgname%-git}
+pkgver=r53.cc24d18
+pkgrel=1
+pkgdesc='Spellcheck plugin for the vis editor.'
+arch=('any')
+url='https://github.com/fischerling/vis-spellcheck'
+license=('MIT')
+depends=('vis')
+provides=('vis-spellcheck')
+conflicts=('vis-spellcheck')
+source=("git+https://github.com/fischerling/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm644 'spellcheck.lua' -t "$pkgdir/usr/share/vis/plugins"
+ install -Dm644 'LICENSE' -t "$pkgdir/usr/share/licenses/$_pkgname"
+ install -Dm644 'Readme.md' -t "$pkgdir/usr/share/doc/$_pkgname"
+}