summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2017-01-12 12:42:47 +0100
committerChristian Hesse2017-01-12 12:42:47 +0100
commitc1a8656221cf5782c13754eab880a5f3f50b4e3f (patch)
tree629d668ac2469a0863531a954292909e7dd43373
parentff6800648504f2455eab7ec86e19b53eb478a410 (diff)
downloadaur-c1a8656221cf5782c13754eab880a5f3f50b4e3f.tar.gz
commit vis-standalone-git 0.2.r645.ge83a9d5-2
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 24 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f57372fcd06..b504fe4189d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jan 6 06:57:59 UTC 2017
+# Thu Jan 12 11:42:47 UTC 2017
pkgbase = vis-standalone-git
pkgdesc = modern, legacy free, simple yet efficient vim-like editor - statically linked - git checkout
- pkgver = 0.2.r632.g604c866
- pkgrel = 1
+ pkgver = 0.2.r645.ge83a9d5
+ pkgrel = 2
url = http://www.brain-dump.org/projects/vis/
arch = i686
arch = x86_64
@@ -11,7 +11,6 @@ pkgbase = vis-standalone-git
makedepends = git
provides = vis
conflicts = vis
- conflicts = vis-standalone
source = git://github.com/martanne/vis.git
source = http://www.musl-libc.org/releases/musl-1.1.16.tar.gz
source = http://www.musl-libc.org/releases/musl-1.1.16.tar.gz.asc
@@ -30,4 +29,8 @@ pkgbase = vis-standalone-git
sha256sums = 10190ae758a22a16415429a9eb70344cf29cbda738a6962a9f94a732340abf8e
pkgname = vis-standalone-git
+ pkgdesc = modern, legacy free, simple yet efficient vim-like editor - statically linked - git checkout
+
+pkgname = vis-single-git
+ pkgdesc = modern, legacy free, simple yet efficient vim-like editor - statically linked, self-extracting - git checkout
diff --git a/PKGBUILD b/PKGBUILD
index a876aa48521e..556f6ba16e66 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Christian Hesse <mail@eworm.de>
-pkgname=vis-standalone-git
-pkgver=0.2.r632.g604c866
-pkgrel=1
+pkgbase=vis-standalone-git
+pkgname=(vis-standalone-git vis-single-git)
+pkgver=0.2.r645.ge83a9d5
+pkgrel=2
_pkgver_libmusl=1.1.16
_pkgver_ncurses=6.0
_pkgver_libtermkey=0.19
@@ -12,7 +13,7 @@ pkgdesc='modern, legacy free, simple yet efficient vim-like editor - statically
arch=('i686' 'x86_64')
url='http://www.brain-dump.org/projects/vis/'
makedepends=('git')
-conflicts=('vis' 'vis-standalone')
+conflicts=('vis')
provides=('vis')
license=('custom:ISC')
validpgpkeys=('836489290BB6B70F99FFDA0556BCDB593020450F' # musl libc <musl@libc.org>
@@ -63,12 +64,22 @@ build() {
unset CFLAGS LDFLAGS
- make PREFIX='/usr/' standalone
+ make PREFIX='/usr/' single
}
-package() {
+package_vis-standalone-git() {
+ pkgdesc='modern, legacy free, simple yet efficient vim-like editor - statically linked - git checkout'
+
cd vis/
make DESTDIR="${pkgdir}" PREFIX='/usr/' install
}
+package_vis-single-git() {
+ pkgdesc='modern, legacy free, simple yet efficient vim-like editor - statically linked, self-extracting - git checkout'
+
+ cd vis/
+
+ install -D -m0755 vis-single "${pkgdir}/usr/bin/vis"
+}
+