summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Bolka2022-08-23 17:49:24 +0200
committerAndreas Bolka2022-08-23 17:49:31 +0200
commita19e3dd233358984a6dc56a5123f4b26c39fdb14 (patch)
tree093b0d9c0cc237c52a511684daa5c9ff992377fd
parent82104bce5eae4e88246e6353e9239934b8d5254f (diff)
downloadaur-a19e3dd233358984a6dc56a5123f4b26c39fdb14.tar.gz
Switch to pip-based install
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 79f3f2a4d07c..bbc08f853a7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=('any')
url='http://visidata.org/'
license=('GPLv3')
depends=('python')
-makedepends=('git' 'python-setuptools')
+makedepends=('git' 'python-pip' 'python-setuptools')
optdepends=('python-dnslib: pcap support'
'python-dpkt: pcap support' # AUR
'python-fonttools: ttf/otf support'
@@ -42,7 +42,7 @@ pkgver() {
package() {
cd "$srcdir/$pkgname"
- python setup.py -q install --root="$pkgdir" --optimize=1
+ pip3 install . --user --root="$pkgdir" --no-warn-script-location
install -Dm644 LICENSE.gpl3 "$pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE"
install -Dm644 CHANGELOG.md "$pkgdir/usr/share/doc/${pkgname%-*}/CHANGELOG.md"
cp -R docs/* "$pkgdir/usr/share/doc/${pkgname%-*}/"