summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Bolka2018-12-05 17:21:13 +0100
committerAndreas Bolka2018-12-05 17:21:13 +0100
commitdadac139482451c624f9a6181ed050590d473f4c (patch)
tree50f41124a3fb1c34a4351124aac4e5f326310fe4
parentffaccd3aab2457bfaffe12fdc540f91cecd6de0d (diff)
downloadaur-dadac139482451c624f9a6181ed050590d473f4c.tar.gz
Update to VisiData 1.5
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e5711841ae5..38e6f0427d8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = visidata-git
pkgdesc = A console spreadsheet tool for discovering and arranging data
- pkgver = 1.1.gfbc1f2f
+ pkgver = 1.5.ga2e8717
pkgrel = 1
url = http://visidata.org/
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 9ae385e9fdaa..febf26106b37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andreas Bolka <a AT bolka DOT at>
pkgname=visidata-git
-pkgver=1.1.gfbc1f2f
+pkgver=1.5.ga2e8717
pkgrel=1
pkgdesc='A console spreadsheet tool for discovering and arranging data'
arch=('any')
@@ -21,12 +21,12 @@ md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
local PYVER=$(python setup.py --version)
- local GITID=$(git describe --always --long)
+ local GITID=$(git rev-parse --short HEAD)
echo "$PYVER.g$GITID"
}
package() {
cd "$srcdir/$pkgname"
python setup.py -q install --root="$pkgdir" --optimize=1
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE"
+ install -Dm644 LICENSE.gpl3 "$pkgdir/usr/share/licenses/${pkgname%-*}/LICENSE"
}