summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2017-07-25 18:16:12 +0200
committereolianoe2017-07-25 18:16:12 +0200
commit53c1ac52c1af5d04a6e338e6a5c5fa329a87ca51 (patch)
tree6be3653a2475dbd9cd7b1bf560bcd8c4cb268093
parentbca0b1d3360724d73e8b06daa7cd969991679c94 (diff)
downloadaur-53c1ac52c1af5d04a6e338e6a5c5fa329a87ca51.tar.gz
fix deps and compilation with gcc7
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--visit_fix_gcc7.patch43
3 files changed, 56 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ddeab67ce09..c00480bc2dcb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Apr 24 14:10:07 UTC 2017
+# Tue Jul 25 16:15:26 UTC 2017
pkgbase = visit
pkgdesc = Interactive parallel visualization and graphical analysis tool.
pkgver = 2.12.2
- pkgrel = 2
+ pkgrel = 3
url = https://wci.llnl.gov/simulation/computer-codes/visit
arch = i686
arch = x86_64
@@ -14,7 +14,7 @@ pkgbase = visit
makedepends = gcc-fortran
depends = qt5-webkit
depends = qt5-x11extras
- depends = qwt-qt5
+ depends = qwt
depends = python2-numpy
depends = gperftools
depends = icet
@@ -32,10 +32,12 @@ pkgbase = visit
source = visit.sh
source = visit_FindIceT.patch
source = visit_frontendlauncher.patch
+ source = visit_fix_gcc7.patch
sha256sums = 55897d656ac2ea4eb87a30118b2e3963d6c8a391dda0790268426a73e4b06943
sha256sums = d07a11e67ad646579fbc341f30e1eb63ebd38a5fbdd4f3ea36e8f460419028da
sha256sums = 2e7b0be6ad5bc6c0f0568b91f79149f081c2a9bded58223e4347fcf513aa206a
sha256sums = 75179bcdcc5881b12e417f402e52b14598ae2f85ea1f78702ce1dc95c9b5198f
+ sha256sums = d1daa5da6ec25c5a6bfcabb3cf0bf02ab97ec87a332886a2f42695072fe8568d
pkgname = visit
diff --git a/PKGBUILD b/PKGBUILD
index 79e7b9cb9153..c154a218f604 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=visit
pkgver=2.12.2
_pkgver=${pkgver//./_}
-pkgrel=2
+pkgrel=3
pkgdesc="Interactive parallel visualization and graphical analysis tool."
arch=('i686' 'x86_64')
url="https://wci.llnl.gov/simulation/computer-codes/visit"
license=('BSD' 'custom')
makedepends=('cmake' 'java-runtime' 'gcc-fortran')
-depends=('qt5-webkit' 'qt5-x11extras' 'qwt-qt5'
+depends=('qt5-webkit' 'qt5-x11extras' 'qwt'
'python2-numpy'
'gperftools' 'icet' 'java-environment'
'vtk-visit'
@@ -19,11 +19,13 @@ conflicts=('visit-bin' 'visit-build')
source=("https://portal.nersc.gov/svn/${pkgname}/trunk/releases/${pkgver}/${pkgname}${pkgver}.tar.gz"
"visit.sh"
"visit_FindIceT.patch"
- "visit_frontendlauncher.patch")
+ "visit_frontendlauncher.patch"
+ "visit_fix_gcc7.patch")
sha256sums=('55897d656ac2ea4eb87a30118b2e3963d6c8a391dda0790268426a73e4b06943'
'd07a11e67ad646579fbc341f30e1eb63ebd38a5fbdd4f3ea36e8f460419028da'
'2e7b0be6ad5bc6c0f0568b91f79149f081c2a9bded58223e4347fcf513aa206a'
- '75179bcdcc5881b12e417f402e52b14598ae2f85ea1f78702ce1dc95c9b5198f')
+ '75179bcdcc5881b12e417f402e52b14598ae2f85ea1f78702ce1dc95c9b5198f'
+ 'd1daa5da6ec25c5a6bfcabb3cf0bf02ab97ec87a332886a2f42695072fe8568d')
options=(!emptydirs)
prepare(){
@@ -67,6 +69,8 @@ prepare(){
# IceT, use the IceTConfig.cmake provided by IceT
patch CMake/FindIceT.cmake "${srcdir}/visit_FindIceT.patch"
+ patch -p0 < "${srcdir}/visit_fix_gcc7.patch"
+
# Fix Qwt include
sed -i 's:<qwt_:<qwt/qwt_:g' \
gui/QvisStripChart.h gui/QvisStripChart.C
diff --git a/visit_fix_gcc7.patch b/visit_fix_gcc7.patch
new file mode 100644
index 000000000000..f9c3a518ffe7
--- /dev/null
+++ b/visit_fix_gcc7.patch
@@ -0,0 +1,43 @@
+------------------------------------------------------------------------
+r31082 | whitlocb | 2017-06-16 00:19:15 +0200 (Fri, 16 Jun 2017) | 1 line
+
+Fix for GCC 7
+
+Index: databases/Vs/VsStaggeredField.C
+===================================================================
+--- databases/Vs/VsStaggeredField.C (revision 31081)
++++ databases/Vs/VsStaggeredField.C (revision 31082)
+@@ -26,10 +26,13 @@
+ this->indexOrder = VsSchema::compMajorCKey;
+ this->centering = VsSchema::nodalCenteringKey;
+
++#if 0
++ // There is no clear method under GCC 7. What good would it do here anyway?
+ this->oriCellDims.clear();
+ this->oriCellDimProd.clear();
+ this->newCellDims.clear();
+ this->newCellDimProd.clear();
++#endif
+ }
+
+ template<class TYPE>
+@@ -136,7 +139,7 @@
+ // iterate over subgrid
+ for (size_t subBigIndx = 0; subBigIndx < this->numNeighbors; ++subBigIndx) {
+ std::valarray<int> subCellInds = this->getSubCellIndexSet(subBigIndx);
+- std::valarray<int> newCellInds = oriCellInds*this->numNeighbors + subCellInds;
++ std::valarray<int> newCellInds = oriCellInds*static_cast<TYPE>(this->numNeighbors) + subCellInds;
+ size_t newBigIndx = this->getNewBigIndex(newCellInds);
+ std::valarray<TYPE> xi = std::valarray<TYPE>(subCellInds) / this->twoPowSubRes;
+ this->setNewFieldVals(newBigIndx, xi, sigmaVals, neighVals, dataPtr);
+@@ -147,7 +150,7 @@
+ template <class TYPE>
+ std::valarray<int>
+ VsStaggeredField<TYPE>::getOriCellIndexSet(size_t bigIndex) const {
+- return (bigIndex / this->oriCellDimProd) % this->oriCellDims;
++ return (bigIndex / static_cast<TYPE>(this->oriCellDimProd)) % this->oriCellDims;
+ }
+
+ template <class TYPE>
+
+------------------------------------------------------------------------