summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2015-09-18 10:21:59 +0200
committereolianoe2015-09-18 10:21:59 +0200
commit8d2009db23b8d7a33b1bd66a7ef4ff9fffcc7fc4 (patch)
tree71d53bb1e00432b21a811ba21a6c21b7c29589cd
parente65f5d0d15de0892c9afd6d82aefacfd344e4e67 (diff)
downloadaur-8d2009db23b8d7a33b1bd66a7ef4ff9fffcc7fc4.tar.gz
gdal 2.0.0 rebuild & improvements
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fbd7304fc007..88c31c867638 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v7
+# Fri Sep 18 08:16:47 UTC 2015
pkgbase = visit
pkgdesc = Interactive parallel visualization and graphical analysis tool.
pkgver = 2.9.2
- pkgrel = 2
+ pkgrel = 3
url = https://wci.llnl.gov/simulation/computer-codes/visit
arch = i686
arch = x86_64
@@ -21,7 +23,7 @@ pkgbase = visit
conflicts = visit-bin
conflicts = visit-build
options = !emptydirs
- source = http://portal.nersc.gov/svn/visit/trunk/releases/2.9.2/visit2.9.2.tar.gz
+ source = https://portal.nersc.gov/svn/visit/trunk/releases/2.9.2/visit2.9.2.tar.gz
source = visit.sh
source = visit_FindIceT.patch
sha256sums = 97d19e2609fbba655772feb055919b925214ab68c95ff46481572bd7e9c9ea31
diff --git a/PKGBUILD b/PKGBUILD
index ff0a7debaf74..7680cfe26048 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,17 @@
pkgname=visit
pkgver=2.9.2
_pkgver=2_9_2
-pkgrel=2
+pkgrel=3
pkgdesc="Interactive parallel visualization and graphical analysis tool."
arch=('i686' 'x86_64')
url="https://wci.llnl.gov/simulation/computer-codes/visit"
-_url="http://portal.nersc.gov"
license=('BSD' 'custom')
makedepends=('cmake' 'java-runtime' 'gcc-fortran')
depends=('qtwebkit' 'python2-numpy'
'gperftools' 'icet' 'java-environment'
'vtk' 'silo' 'cgns')
conflicts=('visit-bin' 'visit-build')
-source=("${_url}/svn/${pkgname}/trunk/releases/${pkgver}/${pkgname}${pkgver}.tar.gz"
+source=("https://portal.nersc.gov/svn/${pkgname}/trunk/releases/${pkgver}/${pkgname}${pkgver}.tar.gz"
"visit.sh"
"visit_FindIceT.patch")
@@ -76,8 +75,8 @@ prepare(){
# Out of source build
cd "${srcdir}"
- rm -rf build-${pkgver}
- mkdir -p build-${pkgver}
+ rm -rf -- build-${pkgver}
+ mkdir -p -- build-${pkgver}
}
build() {
@@ -98,7 +97,13 @@ build() {
-DVISIT_HDF5_DIR=/usr \
-DVISIT_SILO_DIR=/usr \
-DVISIT_GDAL_DIR=/usr \
- -DVISIT_CGNS_DIR=/usr
+ -DVISIT_CGNS_DIR=/usr \
+ -DVISIT_THREAD:BOOL=ON \
+ -DVISIT_JAVA:BOOL=ON
+
+ # For Qt5 (for now, it's failing with:
+ # This application failed to start because it could not find or load the Qt platform plugin "xcb")
+ #-VISIT_QT5:BOOL=ON -DVISIT_QT_DIR:PATH=/usr/lib/qt -DVISIT_VISIT_QT_SKIP_INSTALL:BOOL=ON \
# Does not compile for now
#-DVISIT_NETCDF_DIR=/usr \