summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2016-07-13 16:30:21 +0200
committereolianoe2016-07-13 16:30:21 +0200
commit305afe32f14c93abc56c17fc6209d1589f22524c (patch)
tree2e4912c2406f2ce7ce06b25f30ac6161e67fe103
parent8825f10419cdc81436bb70be2e79071522eadb80 (diff)
downloadaur-305afe32f14c93abc56c17fc6209d1589f22524c.tar.gz
updpkg: 2.10.3
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
-rw-r--r--vtk_gcc6.patch61
3 files changed, 77 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d83d1b4ee166..21601015360b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Apr 1 20:02:08 UTC 2016
+# Wed Jul 13 14:30:14 UTC 2016
pkgbase = visit-build
pkgdesc = Interactive parallel visualization and graphical analysis tool (built with build_visit).
- pkgver = 2.10.2
+ pkgver = 2.10.3
pkgrel = 1
url = https://wci.llnl.gov/simulation/computer-codes/visit
arch = i686
@@ -24,15 +24,17 @@ pkgbase = visit-build
conflicts = visit
conflicts = visit-bin
options = !emptydirs
- source = https://portal.nersc.gov/svn/visit/trunk/releases/2.10.2/build_visit2_10_2
- source = https://portal.nersc.gov/svn/visit/trunk/releases/2.10.2/visit2.10.2.tar.gz
+ source = https://portal.nersc.gov/svn/visit/trunk/releases/2.10.3/build_visit2_10_3
+ source = https://portal.nersc.gov/svn/visit/trunk/releases/2.10.3/visit2.10.3.tar.gz
source = visit.sh
source = no_extract_visit.patch
+ source = vtk_gcc6.patch
source = qt5-qpa.patch
- sha256sums = 5848da740242f7516df7eae48c804e795065f55d48f9d194477e3296477cf9c3
- sha256sums = 89ecdfaf197ef431685e31b75628774deb6cd75d3e332ef26505774403e8beff
+ sha256sums = 72694d887700d642c0d23ac02bff62cfcabb2ba7d0f567c0bbbb870b0187eff2
+ sha256sums = 05018215c4727eb42d47bb5cc4ff937b2a2ccaca90d141bc7fa426a0843a5dbc
sha256sums = d07a11e67ad646579fbc341f30e1eb63ebd38a5fbdd4f3ea36e8f460419028da
sha256sums = fe8ffacc194689bf5f3165a4cc54b0ef49371b34ef68dd952b5a828a82364108
+ sha256sums = f08e867357837dd6e2fa8b20d033ad39aa0f59fc13d2333f7153d0eb83b2cb5a
sha256sums = a523dd42c61ccd6743f23d35e63518c4dd33a465fa024e4431f002932464f26b
pkgname = visit-build
diff --git a/PKGBUILD b/PKGBUILD
index 786eb2489a69..c12ecd74f19d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=visit-build
_pkgname=visit
-pkgver=2.10.2
+pkgver=2.10.3
_pkgver=${pkgver//./_}
pkgrel=1
pkgdesc="Interactive parallel visualization and graphical analysis tool (built with build_visit)."
@@ -18,11 +18,13 @@ source=("https://portal.nersc.gov/svn/${_pkgname}/trunk/releases/${pkgver}/build
"https://portal.nersc.gov/svn/${_pkgname}/trunk/releases/${pkgver}/${_pkgname}${pkgver}.tar.gz"
"visit.sh"
'no_extract_visit.patch'
+ "vtk_gcc6.patch"
'qt5-qpa.patch')
-sha256sums=('5848da740242f7516df7eae48c804e795065f55d48f9d194477e3296477cf9c3'
- '89ecdfaf197ef431685e31b75628774deb6cd75d3e332ef26505774403e8beff'
+sha256sums=('72694d887700d642c0d23ac02bff62cfcabb2ba7d0f567c0bbbb870b0187eff2'
+ '05018215c4727eb42d47bb5cc4ff937b2a2ccaca90d141bc7fa426a0843a5dbc'
'd07a11e67ad646579fbc341f30e1eb63ebd38a5fbdd4f3ea36e8f460419028da'
'fe8ffacc194689bf5f3165a4cc54b0ef49371b34ef68dd952b5a828a82364108'
+ 'f08e867357837dd6e2fa8b20d033ad39aa0f59fc13d2333f7153d0eb83b2cb5a'
'a523dd42c61ccd6743f23d35e63518c4dd33a465fa024e4431f002932464f26b')
options=(!emptydirs)
@@ -45,6 +47,9 @@ prepare(){
# Do not re-extract the visit source code
patch "${srcdir}/build_${_pkgname}${_pkgver}" no_extract_visit.patch
+ # Patch build_visit to apply patch that permits to build vtk with gcc6
+ patch "${srcdir}/build_${_pkgname}${_pkgver}" vtk_gcc6.patch
+
# Fix to use python2 in every scripts
sed -i 's/exec\ python/exec\ python2/' \
"${srcdir}/${_pkgname}${pkgver}/src/bin/frontendlauncher"
@@ -115,7 +120,6 @@ _build_command(){
--netcdf \
--silo \
--szip \
- --xdmf \
--zlib \
${opt}
}
diff --git a/vtk_gcc6.patch b/vtk_gcc6.patch
new file mode 100644
index 000000000000..5e0dd86f43c5
--- /dev/null
+++ b/vtk_gcc6.patch
@@ -0,0 +1,61 @@
+--- build_visit2_10_3 2016-07-13 10:21:46.960665498 +0200
++++ build_visit2_10_3.new 2016-07-13 13:15:57.205848552 +0200
+@@ -18575,6 +18575,50 @@
+ return 0;
+ }
+
++function apply_vtk_gcc6_patch
++{
++ patch -p1 << \EOF
++--- a/CMake/vtkCompilerExtras.cmake 2014-01-22 16:55:41.000000000 +0100
+++++ b/CMake/vtkCompilerExtras.cmake.new 2016-07-11 21:28:48.107362104 +0200
++@@ -27,10 +27,10 @@
++ OUTPUT_VARIABLE _gcc_version_info
++ ERROR_VARIABLE _gcc_version_info)
++
++- string (REGEX MATCH "[345]\\.[0-9]\\.[0-9]"
+++ string (REGEX MATCH "[0-9]\\.[0-9]\\.[0-9]"
++ _gcc_version "${_gcc_version_info}")
++ if(NOT _gcc_version)
++- string (REGEX REPLACE ".*\\(GCC\\).* ([34]\\.[0-9]) .*" "\\1.0"
+++ string (REGEX REPLACE ".*\\(GCC\\).* ([0-9]\\.[0-9]) .*" "\\1.0"
++ _gcc_version "${_gcc_version_info}")
++ endif()
++
++--- a/CMake/GenerateExportHeader.cmake 2014-01-22 16:55:41.000000000 +0100
+++++ b/CMake/GenerateExportHeader.cmake.new 2016-07-11 21:28:47.977361853 +0200
++@@ -166,12 +166,12 @@
++ execute_process(COMMAND ${CMAKE_C_COMPILER} --version
++ OUTPUT_VARIABLE _gcc_version_info
++ ERROR_VARIABLE _gcc_version_info)
++- string(REGEX MATCH "[345]\\.[0-9]\\.[0-9]"
+++ string(REGEX MATCH "[0-9]\\.[0-9]\\.[0-9]"
++ _gcc_version "${_gcc_version_info}")
++ # gcc on mac just reports: "gcc (GCC) 3.3 20030304 ..." without the
++ # patch level, handle this here:
++ if(NOT _gcc_version)
++- string(REGEX REPLACE ".*\\(GCC\\).* ([34]\\.[0-9]) .*" "\\1.0"
+++ string(REGEX REPLACE ".*\\(GCC\\).* ([0-9]\\.[0-9]) .*" "\\1.0"
++ _gcc_version "${_gcc_version_info}")
++ endif()
++
++EOF
++ if [[ $? != 0 ]] ; then
++ warn "vtk_gcc6 patch failed."
++ return 1
++ fi
++
++ return 0;
++}
++
+ function apply_vtk_610_patch_2
+ {
+ patch -p0 << \EOF
+@@ -18795,6 +18839,7 @@
+ if [[ ${VTK_VERSION} == 6.1.0 ]] ; then
+ apply_vtk_600_patch
+ apply_vtk_610_patch_2
++ apply_vtk_gcc6_patch
+ if [[ "$OPSYS" == "Linux" ]] ; then
+ apply_vtk_610_patch
+ fi