summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreolianoe2015-10-21 14:28:51 +0200
committereolianoe2015-10-21 14:28:51 +0200
commit9a08e36ffab8a0610040e59ca758e0b8bad408d9 (patch)
tree7c2d03c5ac8c1f61b3e90f1cd81b36c76364fd8e
parent3af071ccd956a956b6be86e13ff5518fe3cac84b (diff)
downloadaur-9a08e36ffab8a0610040e59ca758e0b8bad408d9.tar.gz
Upstream release 2.10.0 and switch to Qt5
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD50
-rw-r--r--no_extract_visit.patch70
-rw-r--r--qt5-qpa.patch10
4 files changed, 95 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4718e8ab1e1a..e07685e27f8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = visit-build
pkgdesc = Interactive parallel visualization and graphical analysis tool (built with build_visit).
- pkgver = 2.9.2
- pkgrel = 2
+ pkgver = 2.10.0
+ pkgrel = 1
url = https://wci.llnl.gov/simulation/computer-codes/visit
arch = i686
arch = x86_64
@@ -12,7 +12,7 @@ pkgbase = visit-build
makedepends = svn
makedepends = java-runtime
makedepends = gcc-fortran
- depends = qtwebkit
+ depends = qt5-webkit
depends = python2-numpy
depends = openmpi
depends = glu
@@ -20,14 +20,17 @@ pkgbase = visit-build
provides = visit
conflicts = visit
conflicts = visit-bin
- source = https://portal.nersc.gov/svn/visit/trunk/releases/2.9.2/build_visit2_9_2
- source = https://portal.nersc.gov/svn/visit/trunk/releases/2.9.2/visit2.9.2.tar.gz
+ options = !emptydirs
+ source = https://portal.nersc.gov/svn/visit/trunk/releases/2.10.0/build_visit2_10_0
+ source = https://portal.nersc.gov/svn/visit/trunk/releases/2.10.0/visit2.10.0.tar.gz
source = visit.sh
source = no_extract_visit.patch
- sha256sums = 4b1d396b41923b3b2c1b2da2524cb424f0166d9898d04f367f52a0426ae7a688
- sha256sums = 97d19e2609fbba655772feb055919b925214ab68c95ff46481572bd7e9c9ea31
+ source = qt5-qpa.patch
+ sha256sums = 63dc4baed14b753abbd2717e958e189f56c99d573d87e034d1304cf2a1d76dc0
+ sha256sums = ed3d514bc90eaf9c79d00b3f75fbe73437c16296a89451db531d0707c6d806bc
sha256sums = d07a11e67ad646579fbc341f30e1eb63ebd38a5fbdd4f3ea36e8f460419028da
- sha256sums = 13f14a8b61cf4b59155c2f1d22fc59e670615343b8b9d78dfbfd9c2e321f6cc7
+ sha256sums = fe8ffacc194689bf5f3165a4cc54b0ef49371b34ef68dd952b5a828a82364108
+ sha256sums = a523dd42c61ccd6743f23d35e63518c4dd33a465fa024e4431f002932464f26b
pkgname = visit-build
diff --git a/PKGBUILD b/PKGBUILD
index b785380b5824..a11d67f3afef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,29 @@
pkgname=visit-build
_pkgname=visit
-pkgver=2.9.2
-_pkgver=2_9_2
-pkgrel=2
+pkgver=2.10.0
+_pkgver=2_10_0
+pkgrel=1
pkgdesc="Interactive parallel visualization and graphical analysis tool (built with build_visit)."
arch=('i686' 'x86_64')
url="https://wci.llnl.gov/simulation/computer-codes/visit"
license=('BSD' 'custom')
makedepends=('qtchooser' 'cmake' 'svn' 'java-runtime' 'gcc-fortran')
-depends=('qtwebkit' 'python2-numpy' 'openmpi' 'glu' 'java-environment')
+depends=('qt5-webkit' 'python2-numpy' 'openmpi' 'glu' 'java-environment')
conflicts=('visit' 'visit-bin')
provides=('visit')
source=("https://portal.nersc.gov/svn/${_pkgname}/trunk/releases/${pkgver}/build_${_pkgname}${_pkgver}"
"https://portal.nersc.gov/svn/${_pkgname}/trunk/releases/${pkgver}/${_pkgname}${pkgver}.tar.gz"
"visit.sh"
- 'no_extract_visit.patch')
-sha256sums=('4b1d396b41923b3b2c1b2da2524cb424f0166d9898d04f367f52a0426ae7a688'
- '97d19e2609fbba655772feb055919b925214ab68c95ff46481572bd7e9c9ea31'
+ 'no_extract_visit.patch'
+ 'qt5-qpa.patch')
+sha256sums=('63dc4baed14b753abbd2717e958e189f56c99d573d87e034d1304cf2a1d76dc0'
+ 'ed3d514bc90eaf9c79d00b3f75fbe73437c16296a89451db531d0707c6d806bc'
'd07a11e67ad646579fbc341f30e1eb63ebd38a5fbdd4f3ea36e8f460419028da'
- '13f14a8b61cf4b59155c2f1d22fc59e670615343b8b9d78dfbfd9c2e321f6cc7')
+ 'fe8ffacc194689bf5f3165a4cc54b0ef49371b34ef68dd952b5a828a82364108'
+ 'a523dd42c61ccd6743f23d35e63518c4dd33a465fa024e4431f002932464f26b')
+
+options=(!emptydirs)
prepare(){
cd "${srcdir}"
@@ -31,11 +35,15 @@ prepare(){
"${srcdir}/build_${_pkgname}${_pkgver}"
# Build directory
- #rm -rf -- "${srcdir}/build-${pkgver}"
- #mkdir -p "${srcdir}/build-${pkgver}"
+ rm -rf -- "${srcdir}/build"
+ mkdir -p "${srcdir}/build"
+
+ # Thirdparty libs
+ rm -rf -- "${srcdir}/thirdparty"
+ mkdir -p "${srcdir}/thirdparty"
# Do not re-extract the visit source code
- patch < no_extract_visit.patch
+ patch "${srcdir}/build_${_pkgname}${_pkgver}" no_extract_visit.patch
# Fix to use python2 in every scripts
sed -i 's/exec\ python/exec\ python2/' \
@@ -45,9 +53,8 @@ prepare(){
-e "s|#![ ]*/bin/env python$|#!/usr/bin/env python2|" \
-i $(find "${srcdir}/${_pkgname}${pkgver}/" -name '*.py')
- # Thirdparty libs
- #rm -rf -- "${srcdir}/thirdparty-${pkgver}"
- #mkdir -p "${srcdir}/thirdparty-${pkgver}"
+ # Fix Qt5 path
+ patch "${srcdir}/${_pkgname}${pkgver}/src/bin/frontendlauncher" qt5-qpa.patch
# Download all files with '--download-only' option
_build_command ${srcdir} --download-only
@@ -66,6 +73,7 @@ build() {
MAKEFLAGS="-j1"
fi
+ # Now build everything
_build_command ${srcdir} "--makeflags ${MAKEFLAGS}"
}
@@ -81,8 +89,8 @@ package(){
make install DESTDIR="${pkgdir}"
# License
- install -Dm644 "${srcdir}/build-${pkgver}/${_pkgname}${pkgver}/src/COPYRIGHT" \
- "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ install -Dm644 "${srcdir}/${_pkgname}${pkgver}/src/COPYRIGHT" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
# Install script to set path
install -Dm755 "${srcdir}/visit.sh" "${pkgdir}/etc/profile.d/visit.sh"
@@ -92,16 +100,14 @@ _build_command(){
dir=${1}
opt=${2}
- # To avoid some incompatibilities with Qt5
- export QT_SELECT=4
-
echo yes | bash build_${_pkgname}${_pkgver} --console \
- --installation-build-dir "${dir}/build-${pkgver}" \
- --thirdparty-path "${dir}/thirdparty-${pkgver}" \
+ --installation-build-dir "${dir}/build" \
+ --thirdparty-path "${dir}/thirdparty" \
--tarball "${dir}/${_pkgname}${pkgver}.tar.gz" \
- --system-cmake --system-qt --system-python \
+ --system-cmake --qt5 --system-qt --system-python \
--parallel-build --parallel \
--cc gcc --cxx g++ --fortran \
+ --cflag "${CFLAGS}" --cxxflag "${CXXFLAGS}" \
--build-mode Release \
--hdf4 \
--hdf5 \
diff --git a/no_extract_visit.patch b/no_extract_visit.patch
index 7de7c3d7c367..a90c7b02b623 100644
--- a/no_extract_visit.patch
+++ b/no_extract_visit.patch
@@ -1,24 +1,46 @@
---- build_visit2_9_2 2015-09-29 18:35:16.929401021 +0200
-+++ build_visit2_9_2.new 2015-09-29 18:36:49.289624506 +0200
-@@ -2433,14 +2433,14 @@
- return -1
- fi
- elif [[ -f ${SRC_FILE%.*} ]] ; then
-- info "Untarring ${SRC_FILE%.*} . . ."
-- $TAR xf ${SRC_FILE%.*}
-+ #info "Untarring ${SRC_FILE%.*} . . ."
-+ #$TAR xf ${SRC_FILE%.*}
- untarred_src=1
-- if [[ $? != 0 ]] ; then
-- warn \
--"Unable to untar ${SRC_FILE%.*}. Corrupted file or out of space on device?"
-- return -1
-- fi
-+ #if [[ $? != 0 ]] ; then
-+ #warn \
-+#"Unable to untar ${SRC_FILE%.*}. Corrupted file or out of space on device?"
-+ #return -1
-+ #fi
- fi
-
- return $untarred_src
+3993,4014c3993,4014
+< if [[ "$DO_SVN" != "yes" || "$USE_VISIT_FILE" == "yes" ]] ; then
+< #
+< # Unzip the file, provided a gzipped file exists.
+< #
+< if [[ -f ${VISIT_FILE} ]] ; then
+< info "Unzipping/untarring ${VISIT_FILE} . . ."
+< uncompress_untar ${VISIT_FILE}
+< if [[ $? != 0 ]] ; then
+< warn \
+< "Unable to untar ${VISIT_FILE}. Corrupted file or out of space on device?"
+< return 1
+< fi
+< elif [[ -f ${VISIT_FILE%.*} ]] ; then
+< info "Unzipping ${VISIT_FILE%.*} . . ."
+< $TAR xf ${VISIT_FILE%.*}
+< if [[ $? != 0 ]] ; then
+< warn \
+< "Unable to untar ${VISIT_FILE%.*}. Corrupted file or out of space on device?"
+< return 1
+< fi
+< fi
+< fi
+---
+> # if [[ "$DO_SVN" != "yes" || "$USE_VISIT_FILE" == "yes" ]] ; then
+> # #
+> # # Unzip the file, provided a gzipped file exists.
+> # #
+> # if [[ -f ${VISIT_FILE} ]] ; then
+> # info "Unzipping/untarring ${VISIT_FILE} . . ."
+> # uncompress_untar ${VISIT_FILE}
+> # if [[ $? != 0 ]] ; then
+> # warn \
+> #"Unable to untar ${VISIT_FILE}. Corrupted file or out of space on device?"
+> # return 1
+> # fi
+> # elif [[ -f ${VISIT_FILE%.*} ]] ; then
+> # info "Unzipping ${VISIT_FILE%.*} . . ."
+> # $TAR xf ${VISIT_FILE%.*}
+> # if [[ $? != 0 ]] ; then
+> # warn \
+> #"Unable to untar ${VISIT_FILE%.*}. Corrupted file or out of space on device?"
+> # return 1
+> # fi
+> # fi
+> # fi
diff --git a/qt5-qpa.patch b/qt5-qpa.patch
new file mode 100644
index 000000000000..a94030319a84
--- /dev/null
+++ b/qt5-qpa.patch
@@ -0,0 +1,10 @@
+--- frontendlauncher 2015-10-21 10:18:28.317260465 +0200
++++ frontendlauncher.new 2015-10-21 11:39:07.079113095 +0200
+@@ -153,6 +153,7 @@
+ exec "$visitpython" $frontendlauncherpy $0 ${1+"$@"}
+ else
+ #echo "System python $frontendlauncherpy $0 ${1+"$@"}"
++ export QT_QPA_PLATFORM_PLUGIN_PATH=/usr/lib/qt/plugins
+ exec python2 $frontendlauncherpy $0 ${1+"$@"}
+ fi
+ $0 = shift @ARGV;