summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Manouchehri2016-01-01 14:21:33 +0000
committerDavid Manouchehri2016-01-01 14:21:33 +0000
commit34211f703cb4f41acd786e51ff9e55ac5f4a25a8 (patch)
tree0ff2b0df2017e7a642262ef754a70cf0453f9b94
downloadaur-34211f703cb4f41acd786e51ff9e55ac5f4a25a8.tar.gz
Package created.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a4fcc493a25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+# Generated by mksrcinfo v8
+# Fri Jan 1 14:21:16 UTC 2016
+pkgbase = visual
+ pkgdesc = A highly visual ARM emulator, designed to make learning ARM Assembly language easier.
+ pkgver = 1.27
+ pkgrel = 1
+ url = http://salmanarif.bitbucket.org/visual/
+ arch = x86_64
+ license = unknown
+ source = http://bit.ly/visuallinux_127_amd64
+ sha512sums = SKIP
+
+pkgname = visual
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43776e849e26
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: David Manouchehri <manouchehri@riseup.net>
+
+pkgname="visual"
+pkgver=1.27
+pkgrel=1
+pkgdesc="A highly visual ARM emulator, designed to make learning ARM Assembly language easier."
+url="http://salmanarif.bitbucket.org/visual/"
+license=('unknown')
+source=("http://bit.ly/visuallinux_127_amd64")
+# http://bit.ly/visuallinux_127_i386
+sha512sums=('SKIP')
+arch=('x86_64') # arch=('i686' 'x86_64')
+# depends=('java-runtime')
+
+package() {
+ cd "${srcdir}/"
+ tar -xvf 'data.tar.xz' -C "${pkgdir}/"
+
+ # The bundled JRE is less than ideal, but it's required at the moment.
+ # sed -i 's,../jre/bin/java,java,' "${pkgdir}/usr/local/bin/visual/VisUAL.sh"
+ # rm -r "${pkgdir}/usr/local/bin/visual/jre/"
+}
+
+# vim:set et sw=2 sts=2 tw=80: \ No newline at end of file