summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBehnam Momeni2015-06-25 17:45:36 +0430
committerBehnam Momeni2015-06-25 17:45:36 +0430
commita15b34b1736b604cc5ebb93e7d8c85e43f749b12 (patch)
tree71119bd3025e09ecc3fb2aa8c64b85fcc344e77c
downloadaur-a15b34b1736b604cc5ebb93e7d8c85e43f749b12.tar.gz
Migrating visual-pdf-diff-git package to AUR4
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD34
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d0cdcc64dce2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = visual-pdf-diff-git
+ pkgdesc = Merges two PDF files into one PDF file and highlights their visual differences.
+ pkgver = v1.0.0
+ pkgrel = 1
+ url = https://github.com/momeni/visual-pdf-diff
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = imagemagick
+ depends = gawk
+ depends = bash
+ depends = coreutils
+ provides = visual-pdf-diff
+ conflicts = visual-pdf-diff
+ source = git+https://github.com/momeni/visual-pdf-diff.git
+ sha256sums = SKIP
+
+pkgname = visual-pdf-diff-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2a90ef04d53e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg/
+src/
+visual-pdf-diff/
+*.pkg.tar.xz
+*~
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a43f73ec7f55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Behnam Momeni <sbmomeni [at the] gmail [dot] com>
+
+pkgname=('visual-pdf-diff-git')
+
+_gitname=visual-pdf-diff
+#The actual value is calculated by pkgver() function
+pkgver=v1.0.0
+pkgrel=1
+
+pkgdesc="Merges two PDF files into one PDF file and highlights their visual differences."
+url="https://github.com/momeni/${_gitname}"
+
+arch=('any')
+license=('GPL3')
+
+depends=('imagemagick' 'gawk' 'bash' 'coreutils')
+conflicts=('visual-pdf-diff')
+provides=('visual-pdf-diff')
+makedepends=('git')
+source=('git+https://github.com/momeni/visual-pdf-diff.git')
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git describe --always | sed 's|-|.|g'
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ install -D -m 755 visualpdfdiff.sh "${pkgdir}/usr/bin/visualpdfdiff.sh"
+ install -D -m 644 README.md "${pkgdir}/usr/share/visual-pdf-diff/README.md"
+}
+