summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracerix2016-06-15 01:10:49 -0400
committeracerix2016-06-15 01:10:49 -0400
commit4cc169de3d379d661ca97bc93f797da78ff585be (patch)
tree2f3bf941d2afeb709a15ad446ea392318836af4a
downloadaur-4cc169de3d379d661ca97bc93f797da78ff585be.tar.gz
init
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD37
-rw-r--r--visual-sfm.desktop8
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c84d82949dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by mksrcinfo v8
+# Wed Jun 15 05:10:40 UTC 2016
+pkgbase = visual-sfm
+ pkgdesc = A Visual Structure from Motion System; create 3d models from photos.
+ pkgver = 0.5
+ pkgrel = 1
+ url = http://ccwu.me/vsfm/
+ arch = x86_64
+ license = custom:visual-sfm
+ depends = gtk2
+ depends = glew
+ depends = devil
+ depends = boost-libs
+ depends = atlas-cpp
+ depends = imagemagick
+ depends = cminpack
+ depends = gcc-fortran
+ depends = metis
+ depends = parmetis
+ depends = freeglut
+ depends = gsl
+ optdepends = opencl-nvidia: nvidia gpu support
+ optdepends = opencl-mesa: amd gpu support (mesa)
+ optdepends = opencl-catalyst: amd gpu support (catalyst)
+ source = http://ccwu.me/vsfm/download/VisualSFM_linux_64bit.zip
+ source = visual-sfm.desktop
+ md5sums = 25fcca5e320a9e97131e87abdf3b7f61
+ md5sums = 52e8eabb314aa7661fd6eb1bee32eaae
+
+pkgname = visual-sfm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9bda9424839d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Dylan Ferris <dylan@psilly.com>
+
+pkgname='visual-sfm'
+pkgver=0.5
+pkgrel=1
+pkgdesc='A Visual Structure from Motion System; create 3d models from photos.'
+arch=('x86_64')
+url='http://ccwu.me/vsfm/'
+depends=('gtk2' 'glew' 'devil' 'boost-libs' 'atlas-cpp' 'imagemagick' 'cminpack' 'gcc-fortran' 'metis' 'parmetis' 'freeglut' 'gsl')
+optdepends=(
+ 'opencl-nvidia: nvidia gpu support'
+ 'opencl-mesa: amd gpu support (mesa)'
+ 'opencl-catalyst: amd gpu support (catalyst)'
+)
+license=('custom:visual-sfm')
+source=(
+ 'http://ccwu.me/vsfm/download/VisualSFM_linux_64bit.zip'
+ 'visual-sfm.desktop'
+)
+md5sums=(
+ '25fcca5e320a9e97131e87abdf3b7f61'
+ '52e8eabb314aa7661fd6eb1bee32eaae'
+)
+
+build() {
+ cd $srcdir/vsfm
+ make
+}
+
+package() {
+ install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
+ cd $srcdir/vsfm
+ install -Dm644 README "$pkgdir/usr/share/licenses/$pkgname/LICENSE.pdf"
+ install -Dm755 bin/VisualSFM "$pkgdir/usr/bin/VisualSFM"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/visual-sfm.desktop b/visual-sfm.desktop
new file mode 100644
index 000000000000..6c005c28d335
--- /dev/null
+++ b/visual-sfm.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=Visual SFM
+Comment=Visual Structure from Motion System
+Exec=/usr/bin/VisualSFM %F
+Terminal=false
+Categories=Graphics;
+