summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-08-23 21:09:20 -0500
committerCarlos Aznarán Laos2022-08-23 21:09:20 -0500
commitacd3556a0b3a3c000f9f47008a8fa20b8ed5c51c (patch)
tree39959848b8d1f81400a135b52e801cbfa6987646
parent69d04333e5366f6a3f54d479413cdd8bf6383220 (diff)
downloadaur-acd3556a0b3a3c000f9f47008a8fa20b8ed5c51c.tar.gz
Bump version to 2.4.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0920cb45531..5892b882fcf5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = visualdl
pkgdesc = Deep Learning Visualization Toolkit
- pkgver = 2.2.1
- pkgrel = 4
+ pkgver = 2.4.0
+ pkgrel = 1
url = https://github.com/PaddlePaddle/visualdl
arch = any
- license = Apache2
- makedepends = python-pre-commit
+ license = Apache
makedepends = shellcheck
makedepends = rustup
makedepends = npm
@@ -18,7 +17,7 @@ pkgbase = visualdl
depends = python-requests
depends = python-matplotlib
depends = python-pandas
- source = https://github.com/PaddlePaddle/visualdl/archive/v2.2.1.tar.gz
- sha512sums = 3c51486ba865e2744142a60677a960f67bfa4116df0c964e1e639b0a06591718a8a1d9ed86d8429c81f8319e3bd365d85e706b809d8814064820ef27288975be
+ source = https://github.com/PaddlePaddle/visualdl/archive/v2.4.0.tar.gz
+ sha512sums = 847657904abe10792e605fee25b5adb859f66227552d3e94e24987176f9c449ce4932a88eb2b434feaacfc14381d8abe569acd3597ea00999e929ac547be74e7
pkgname = visualdl
diff --git a/PKGBUILD b/PKGBUILD
index 40b181139a05..7386fda13fb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
# Contributor: Sam L. Yes <samlukeyes123@gmail.com>
pkgname=visualdl
-pkgver=2.2.1
-pkgrel=4
pkgdesc="Deep Learning Visualization Toolkit"
+pkgver=2.4.0
+pkgrel=1
+arch=(any)
url="https://github.com/PaddlePaddle/${pkgname}"
+license=(Apache)
depends=(python-baidubce flake8 python-flask-babel python-pillow python-protobuf python-requests python-matplotlib python-pandas)
-makedepends=(python-pre-commit shellcheck rustup npm yarn) # python-setuptools
-license=('Apache2')
-arch=('any')
+makedepends=(shellcheck rustup npm yarn) # python-setuptools
source=(${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('3c51486ba865e2744142a60677a960f67bfa4116df0c964e1e639b0a06591718a8a1d9ed86d8429c81f8319e3bd365d85e706b809d8814064820ef27288975be')
+sha512sums=('847657904abe10792e605fee25b5adb859f66227552d3e94e24987176f9c449ce4932a88eb2b434feaacfc14381d8abe569acd3597ea00999e929ac547be74e7')
prepare() {
- sed -i '/pre-commit/d;/shellcheck/d' "VisualDL-${pkgver}/requirements.txt"
+ sed -i '/shellcheck/d' "VisualDL-${pkgver}/requirements.txt"
}
build() {
@@ -24,7 +24,6 @@ build() {
package() {
cd "VisualDL-${pkgver}"
- export PYTHONHASHSEED=0
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}