summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Fišer2017-10-16 16:17:05 +0200
committerJakub Fišer2017-10-16 16:17:05 +0200
commit05b9e7bf4f174f2d7bd6cd8ea306b5275c04045c (patch)
tree5769363242f36702a1cb516f0e891ad3828e8cde
downloadaur-05b9e7bf4f174f2d7bd6cd8ea306b5275c04045c.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD40
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3679b1aa14f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = vit-git
+ pkgdesc = A terminal interface for Taskwarrior with Vim key bindings and colorization support. GIT version.
+ pkgver = r175.d72d6e0
+ pkgrel = 1
+ url = https://github.com/scottkosty/vit
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = perl-curses
+ depends = perl-text-charwidth
+ depends = task
+ source = git+https://github.com/scottkosty/vit.git
+ sha512sums = SKIP
+
+pkgname = vit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecea7f85a093
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Jakub Fišer <kubaCURLYSYMBOLufiseruSMALLPOINTSYMBOlcz>
+# Contributor: Levente Polyak <levente[at]leventepolyak[dot]net>
+# Contributor: Ivan Sichmann Freitas <ivansichfreitas@gmail.com>
+
+pkgname=vit-git
+pkgver=r175.d72d6e0
+pkgrel=1
+pkgdesc="A terminal interface for Taskwarrior with Vim key bindings and colorization support. GIT version."
+arch=('any')
+url="https://github.com/scottkosty/vit"
+license=('GPL3')
+depends=('perl-curses' 'perl-text-charwidth' 'task')
+makedepends=( 'git' )
+source=(git+https://github.com/scottkosty/vit.git)
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${pkgname%-git}
+
+ # allow custom perl location
+ sed -ri "s|(#!/usr/bin/)perl -w|\1env perl|" vit.pl
+}
+
+build() {
+ cd ${pkgname%-git}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname%-git}
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et: