summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeverin Kaderli2019-09-24 18:27:19 +0200
committerSeverin Kaderli2019-09-24 18:27:19 +0200
commit079c0b847d9aea22fa4e8ece994aa0e97ff576e1 (patch)
tree19e7f821ce91bd51507eab57a5569948bb8c4bec
parentceff30d5e7e7f4ed78f25197fb74d8ae54e9f221 (diff)
downloadaur-079c0b847d9aea22fa4e8ece994aa0e97ff576e1.tar.gz
Update PKGBUILD
Signed-off-by: Severin Kaderli <severin@kaderli.dev>
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d5990e802e75..1aedb72562c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vita3k-git
pkgdesc = Experimental PlayStation Vita emulator
- pkgver = r1241.74c50634
+ pkgver = r1255.daff95ff
pkgrel = 1
url = https://vita3k.org/
arch = x86_64
@@ -21,9 +21,9 @@ pkgbase = vita3k-git
source = git+https://github.com/Vita3K/vita-toolchain.git
source = git+https://github.com/jonasmr/microprofile.git
source = git+https://github.com/tcbrindle/sdl2-cmake-scripts.git
- source = git+https://github.com/gabime/spdlog.git#branch=v1.x
+ source = git+https://github.com/gabime/spdlog.git
source = git+https://github.com/nothings/stb.git
- source = git+https://github.com/tronkko/dirent.git#branch=v1.23
+ source = git+https://github.com/tronkko/dirent.git
source = git+https://github.com/B-Con/crypto-algorithms.git
source = git+https://github.com/ocornut/imgui.git
source = git+https://github.com/google/googletest.git
diff --git a/PKGBUILD b/PKGBUILD
index 21791f12bf85..c71e658cca3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: aimileus < $(echo YWltaWxpdXNAcHJvdG9ubWFpbC5jb20K | base64 -d)
_pkgname=vita3k
pkgname=${_pkgname}-git
-pkgver=r1241.74c50634
+pkgver=r1255.daff95ff
pkgrel=1
pkgdesc="Experimental PlayStation Vita emulator"
arch=('x86_64')
@@ -29,9 +29,9 @@ source=(
"git+https://github.com/Vita3K/vita-toolchain.git"
"git+https://github.com/jonasmr/microprofile.git"
"git+https://github.com/tcbrindle/sdl2-cmake-scripts.git"
- "git+https://github.com/gabime/spdlog.git#branch=v1.x"
+ "git+https://github.com/gabime/spdlog.git"
"git+https://github.com/nothings/stb.git"
- "git+https://github.com/tronkko/dirent.git#branch=v1.23"
+ "git+https://github.com/tronkko/dirent.git"
"git+https://github.com/B-Con/crypto-algorithms.git"
"git+https://github.com/ocornut/imgui.git"
"git+https://github.com/google/googletest.git"
@@ -125,20 +125,20 @@ build() {
cd build-linux
cmake .. -DUSE_DISCORD_RICH_PRESENCE=OFF
- make VERBOSE=1 UNICORN_QEMU_FLAGS="--python=/usr/bin/python2"
+ make UNICORN_QEMU_FLAGS="--python=/usr/bin/python2"
}
package() {
cd "${_pkgname}"
- install -d -m 755 "${pkgdir}/opt/"
install -d -m 755 "${pkgdir}/usr/bin/"
+ install -d -m 755 "${pkgdir}/opt/vita3k/"
- # 777 permissions are sadly needed for now for it to work because vita3k
- # creates a log file in the same directory as the binary
- rsync -rtl --perms --chmod=777 "build-linux/bin/" "${pkgdir}/opt/vita3k"
+ cp -r "build-linux/bin/"* "${pkgdir}/opt/vita3k/"
ln -s "/opt/vita3k/Vita3K" "${pkgdir}/usr/bin/vita3k"
+ # This folder needs 777 permissions because vita3k creates a log file
+ chmod 777 "${pkgdir}/opt/vita3k/"
+
install -Dm644 "README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md"
- install -Dm644 "COPYING.txt" "${pkgdir}/usr/share/licenses/${pkgname}/COPYING.txt"
}