summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Nixdorf2015-08-18 12:56:22 +0200
committerJakob Nixdorf2015-08-18 12:56:22 +0200
commite0a4e343bd79049d59d440590897b0f2de475056 (patch)
tree6f87c477a5e4702455b86478efe9cd81b42c592e
downloadaur-e0a4e343bd79049d59d440590897b0f2de475056.tar.gz
Initial import.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--vitables.install12
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d61383790ab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vitables
+ pkgdesc = A graphical tool for browsing and editing files in both PyTables and HDF5 formats.
+ pkgver = 2.1
+ pkgrel = 1
+ url = http://vitables.org/
+ install = vitables.install
+ arch = any
+ license = GPL3
+ makedepends = python2-sphinx
+ depends = python2
+ depends = python2-pytables
+ depends = python2-pyqt4
+ source = http://downloads.sourceforge.net/project/vitables/ViTables-2.1/ViTables-2.1.tar.gz
+ md5sums = 8aea53f86bcdfc28d215b3cfb6c437e9
+
+pkgname = vitables
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3da565dc6488
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+pkgname=vitables
+pkgver=2.1
+pkgrel=1
+pkgdesc="A graphical tool for browsing and editing files in both PyTables and HDF5 formats."
+url="http://vitables.org/"
+depends=( 'python2' 'python2-pytables' 'python2-pyqt4' )
+makedepends=( 'python2-sphinx' )
+license=( 'GPL3' )
+arch=( 'any' )
+install=( "${pkgname}.install" )
+source=( "http://downloads.sourceforge.net/project/vitables/ViTables-${pkgver}/ViTables-${pkgver}.tar.gz" )
+md5sums=( '8aea53f86bcdfc28d215b3cfb6c437e9' )
+
+build() {
+ cd ${srcdir}/ViTables-${pkgver}
+ python2 setup.py build
+}
+
+package() {
+ cd ${srcdir}/ViTables-${pkgver}
+
+ python2 setup.py install --root="${pkgdir}" --optimize=1
+
+ install -D -m 0644 "unixapp/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m 0644 "unixapp/${pkgname}.svg" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"
+}
diff --git a/vitables.install b/vitables.install
new file mode 100644
index 000000000000..62a045c595e1
--- /dev/null
+++ b/vitables.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}