summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDigimezzo2020-06-10 08:26:05 +0200
committerDigimezzo2020-06-10 08:26:05 +0200
commit06f81de7dc5716725e2fb3e756f9c4f2dd03e064 (patch)
treeff2b335c22fdd2bc63a66f6c8962966f166efa78
downloadaur-06f81de7dc5716725e2fb3e756f9c4f2dd03e064.tar.gz
Releases v2.0.3
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD50
-rw-r--r--vitomu.desktop9
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b689d9fb44c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vitomu
+ pkgdesc = Easy to use video to audio converter
+ pkgver = 2.0.3
+ pkgrel = 1
+ url = https://www.digimezzo.com
+ arch = x86_64
+ license = GPL3
+ makedepends = coreutils
+ provides = vitomu
+ conflicts = vitomu
+ replaces = vitomu
+ options = !strip
+ source = Vitomu-2.0.3.AppImage::https://github.com/digimezzo/vitomu/releases/download/v2.0.3/Vitomu-2.0.3.AppImage
+ source = vitomu.desktop
+ sha256sums = d433bc85ff778948d4c743a02db864c437a79876bb929471050d4750049e1160
+ sha256sums = 1330c2e18e4ffce1b7495f130441428a8e04bd04e030bd974993ac9f3fd3eddc
+
+pkgname = vitomu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4178aaa4bb4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Digimezzo <raphael@digimezzo.com>
+_pkgname=Vitomu
+pkgname=vitomu
+pkgver=2.0.3
+pkgrel=1
+pkgdesc="Easy to use video to audio converter"
+arch=('x86_64')
+url="https://www.digimezzo.com"
+license=('GPL3')
+provides=(${pkgname})
+conflicts=(${pkgname})
+replaces=(${pkgname})
+depends=()
+makedepends=('coreutils')
+backup=()
+options=(!strip)
+source=("${_pkgname}-${pkgver}.AppImage::https://github.com/digimezzo/${pkgname}/releases/download/v${pkgver//_/-}/${_pkgname}-${pkgver}.AppImage"
+ "${pkgname}.desktop")
+sha256sums=('d433bc85ff778948d4c743a02db864c437a79876bb929471050d4750049e1160'
+ '1330c2e18e4ffce1b7495f130441428a8e04bd04e030bd974993ac9f3fd3eddc')
+
+prepare() {
+ chmod u+x ${srcdir}/${_pkgname}-${pkgver}.AppImage
+
+ ${srcdir}/${_pkgname}-${pkgver}.AppImage --appimage-extract
+}
+
+package() {
+ find ${srcdir}/squashfs-root/locales/ -type d -exec chmod 755 {} +
+ find ${srcdir}/squashfs-root/resources/ -type d -exec chmod 755 {} +
+
+ install -d ${pkgdir}/opt/${pkgname}
+ cp -r ${srcdir}/squashfs-root/* ${pkgdir}/opt/${pkgname}
+
+ # remove broken or unused files and directories
+ rm -r ${pkgdir}/opt/${pkgname}/usr/
+ rm ${pkgdir}/opt/${pkgname}/AppRun
+ rm ${pkgdir}/opt/${pkgname}/${pkgname}.desktop
+ rm ${pkgdir}/opt/${pkgname}/${pkgname}.png
+
+ find ${srcdir}/squashfs-root/usr/share/icons/ -type d -exec chmod 755 {} +
+
+ install -d ${pkgdir}/usr/share/icons
+ cp -r ${srcdir}/squashfs-root/usr/share/icons/hicolor ${pkgdir}/usr/share/icons/hicolor
+
+ install -d ${pkgdir}/usr/bin
+ ln -s ../../opt/${pkgname}/${pkgname} ${pkgdir}/usr/bin/${pkgname}
+
+ install -Dm644 ${srcdir}/${pkgname}.desktop ${pkgdir}/usr/share/applications/${pkgname}.desktop
+}
diff --git a/vitomu.desktop b/vitomu.desktop
new file mode 100644
index 000000000000..7277badb0b46
--- /dev/null
+++ b/vitomu.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Vitomu
+Exec=vitomu
+Terminal=false
+Type=Application
+Icon=vitomu
+StartupWMClass=Vitomu
+Comment=Easy to use video to audio converter
+Categories=Utility; \ No newline at end of file