summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMako882015-06-11 09:57:34 -0500
committerMako882015-06-11 09:57:34 -0500
commit9dd788363fcc14a8df1af64b9092b535875bfe23 (patch)
treea022874999b4c82c671d91dbe6aa45a0b9f1c6f7
downloadaur-9dd788363fcc14a8df1af64b9092b535875bfe23.tar.gz
Initial Commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD21
-rw-r--r--update-icon-cache.install14
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87ddea59fcc6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vivacious-colors
+ pkgdesc = A vivid and modern GTK icon theme. Featuring a completely NEW set of application icons (Re-designed by RAVEfinity based on Plasma-Next, Flattr and Emerald).
+ pkgver = 1.1a
+ pkgrel = 1
+ url = http://www.ravefinity.com/p/vivacious-colors-gtk-icon-theme.html
+ install = update-icon-cache.install
+ arch = any
+ groups = x11
+ license = custom:cc-by-sa-3.0
+ license = GPL2
+ options = !strip
+ options = !zipman
+ options = libtool
+ options = staticlibs
+ source = vivacious-colors-1.1a.tar.gz::https://googledrive.com/host/0B7iDWdwgu9QAemEzQVo5aHJneU0
+ md5sums = d9b76c5f1f2b1816ee54abc9791c4af0
+
+pkgname = vivacious-colors
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d87d3d0a75a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: ThePilot <afuturepilotis at gmail dot com>
+pkgname=vivacious-colors
+pkgver=1.1a
+pkgrel=1
+pkgdesc="A vivid and modern GTK icon theme. Featuring a completely NEW set of application icons (Re-designed by RAVEfinity based on Plasma-Next, Flattr and Emerald)."
+arch=('any')
+url="http://www.ravefinity.com/p/vivacious-colors-gtk-icon-theme.html"
+license=('custom:cc-by-sa-3.0' 'GPL2')
+groups=('x11')
+options=('!strip' '!zipman' 'libtool' 'staticlibs')
+install=update-icon-cache.install
+source=($pkgname-$pkgver.tar.gz::https://googledrive.com/host/0B7iDWdwgu9QAemEzQVo5aHJneU0)
+md5sums=('d9b76c5f1f2b1816ee54abc9791c4af0')
+
+package() {
+ mkdir -p $pkgdir/usr/share/icons/
+ cp -r $srcdir/* $pkgdir/usr/share/icons/
+ mkdir -p $pkgdir/usr/share/licenses/vivacious-colors/
+ mv "$pkgdir/usr/share/icons/Copyrights&Licenses.txt" "$pkgdir/usr/share/licenses/vivacious-colors/"
+ rm "$pkgdir/usr/share/icons/README-Manual.txt" "$pkgdir/usr/share/icons/$pkgname-$pkgver.tar.gz"
+}
diff --git a/update-icon-cache.install b/update-icon-cache.install
new file mode 100644
index 000000000000..691b68835bf4
--- /dev/null
+++ b/update-icon-cache.install
@@ -0,0 +1,14 @@
+post_install() {
+ for dir in usr/share/icons/Vivacious*; do
+ gtk-update-icon-cache -ftq $dir
+ done
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+