summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2020-03-04 19:37:41 +0100
committerXiretza2020-03-04 19:37:41 +0100
commitd81dd442d57935bff56c7830b8e31694d249a1ea (patch)
tree80eafdc2a10bb1cd21fe2a59f0f3941472b14433
parent44ac0213eaf5aa13a064fdfc2dd1fc1c5f0ae42d (diff)
downloadaur-d81dd442d57935bff56c7830b8e31694d249a1ea.tar.gz
Workaround makepkg file extraction bug
ref. https://git.archlinux.org/pacman.git/commit/?id=349c22d043290ccd0cce9f30981f5415e295442a
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36d2b45d367a..4b0d8715ebb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vivado
pkgdesc = FPGA/CPLD design suite for Xilinx devices
pkgver = 2019.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.xilinx.com/products/design-tools/vivado.html
arch = x86_64
license = custom
@@ -13,6 +13,7 @@ pkgbase = vivado
depends = digilent.adept.runtime
depends = digilent.adept.utilities
depends = xterm
+ noextract = Xilinx_Vivado_2019.2_1106_2127.tar.gz
options = !strip
source = file:///Xilinx_Vivado_2019.2_1106_2127.tar.gz
source = spoof_homedir.c
diff --git a/PKGBUILD b/PKGBUILD
index 3eccfeb6c5db..d3d9ad98a923 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,7 @@
pkgname=vivado
pkgver=2019.2
_more_ver=1106_2127
-pkgrel=1
+pkgrel=2
pkgdesc="FPGA/CPLD design suite for Xilinx devices"
url="https://www.xilinx.com/products/design-tools/vivado.html"
arch=('x86_64')
@@ -48,6 +48,8 @@ source=("file:///Xilinx_Vivado_${pkgver}_${_more_ver}.tar.gz"
'Xilinx-SDK.desktop'
'Xilinx-DocNav.desktop')
+noextract=("Xilinx_Vivado_${pkgver}_${_more_ver}.tar.gz")
+
# checksum from https://www.xilinx.com/support/download.html
md5sums=('e2b2762964ef5f014591b13d77d823ab'
'69d14ad64f6ec44e041eaa8ffcb6f87c'
@@ -59,6 +61,10 @@ options=('!strip')
PKGEXT=".pkg.tar"
prepare() {
+ # https://git.archlinux.org/pacman.git/commit/?id=349c22d043290ccd0cce9f30981f5415e295442a
+ echo "Manually extracting archive..."
+ bsdtar -xf "Xilinx_Vivado_${pkgver}_${_more_ver}.tar.gz"
+
mkdir -p "$srcdir/installer_temp"
sed -i "s/%VERSION%/$pkgver/g" *.desktop