summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFeakster2020-11-08 08:31:24 +0000
committerFeakster2020-11-08 08:31:24 +0000
commit60b2b354489a12fe142b0a55c1c801e044d9bad8 (patch)
tree4e4ac7334cc27306d5f4d5267727f33114276b87
downloadaur-60b2b354489a12fe142b0a55c1c801e044d9bad8.tar.gz
Initial commit
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD60
2 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a31f172e3af7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = vivaldi-arm-bin
+ pkgdesc = An advanced browser made with the power user in mind.
+ pkgver = 3.1.1929.34
+ pkgrel = 1
+ url = https://vivaldi.com
+ arch = aarch64
+ license = custom
+ makedepends = w3m
+ depends = gtk3
+ depends = libcups
+ depends = nss
+ depends = alsa-lib
+ depends = libxss
+ depends = ttf-font
+ depends = desktop-file-utils
+ depends = shared-mime-info
+ depends = hicolor-icon-theme
+ optdepends = vivaldi-ffmpeg-codecs: playback of proprietary video/audio
+ optdepends = pepper-flash: flash support
+ optdepends = google-chrome: Widevine DRM Plugin
+ optdepends = vivaldi-widevine: Widevine DRM Plugin
+ optdepends = libnotify: native notifications
+ provides = www-browser
+ provides = vivaldi
+ options = !strip
+ options = !emptydirs
+ source = https://downloads.vivaldi.com/stable/vivaldi-stable_3.1.1929.34-1_arm64.deb
+ sha512sums = 7b8d3c5f373d05e70fbfe29750f6a7c684450beead9ef54b33758f8847f4bb3f736f323becdbf90fc24917caefb9087f6ece1b1ef7c013fc0480f1224eb05269
+
+pkgname = vivaldi-arm-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4b3fde6bcc0e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: Matthew Zilvar <mattzilvar@gmail.com>
+# Contributor: Térence Clastres <t dot clastres at gmail dot com>
+# Modified PKGBUILD from https://aur.archlinux.org/packages/vivaldi/
+
+pkgname=vivaldi-arm-bin
+_pkgname=vivaldi
+pkgver=3.1.1929.34
+_pkgver=3.1.1929.34-1
+pkgrel=1
+pkgdesc='An advanced browser made with the power user in mind.'
+url="https://vivaldi.com"
+options=('!strip' '!emptydirs')
+license=('custom')
+arch=('aarch64')
+provides=('vivaldi-stable')
+depends=('gtk3' 'libcups' 'nss' 'alsa-lib' 'libxss' 'ttf-font' 'desktop-file-utils' 'shared-mime-info' 'hicolor-icon-theme')
+makedepends=('w3m')
+optdepends=(
+ 'vivaldi-ffmpeg-codecs: playback of proprietary video/audio'
+ 'pepper-flash: flash support'
+ 'google-chrome: Widevine DRM Plugin'
+ 'vivaldi-widevine: Widevine DRM Plugin'
+ 'libnotify: native notifications'
+)
+provides=('www-browser' 'vivaldi')
+source=("https://downloads.vivaldi.com/stable/vivaldi-stable_${_pkgver}_arm64.deb")
+sha512sums=('7b8d3c5f373d05e70fbfe29750f6a7c684450beead9ef54b33758f8847f4bb3f736f323becdbf90fc24917caefb9087f6ece1b1ef7c013fc0480f1224eb05269')
+
+prepare() {
+ tar -xf data.tar.xz
+}
+
+package() {
+ cp --parents -a {opt,usr/bin,usr/share} "$pkgdir"
+
+ # suid sandbox
+ chmod 4755 "$pkgdir/opt/$_pkgname/vivaldi-sandbox"
+
+ # make /usr/bin/vivaldi-stable available
+ binf="$pkgdir/usr/bin/vivaldi-stable"
+ if [[ ! -e "$binf" ]] && [[ ! -f "$binf" ]] && [[ ! -L "$binf" ]]; then
+ install -dm755 "$pkgdir/usr/bin"
+ ln -s /opt/vivaldi/vivaldi "$binf"
+ fi
+
+ # install icons
+ for res in 16 22 24 32 48 64 128 256; do
+ install -Dm644 "$pkgdir/opt/$_pkgname/product_logo_${res}.png" \
+ "$pkgdir/usr/share/icons/hicolor/${res}x${res}/apps/$_pkgname.png"
+ done
+
+ # license
+ install -dm755 "$pkgdir/usr/share/licenses/$_pkgname"
+ strings "$pkgdir/opt/vivaldi/locales/en-US.pak" \
+ | tr '\n' ' ' \
+ | sed -rne 's/.*(<html lang.*>.*html>).*/\1/p' \
+ | w3m -I 'utf-8' -T 'text/html' \
+ > "$pkgdir/usr/share/licenses/$_pkgname/eula.txt"
+}