summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFeakster2021-02-18 14:42:33 +0000
committerFeakster2021-02-18 14:42:33 +0000
commite4da6135d603100323c59a64d14551d091fff281 (patch)
tree4222dd0234494d3cadd045513adf6a23c674c352
parentcd22cbd62412ae5271dbf0ed7a25f17b07dcd1f2 (diff)
downloadaur-e4da6135d603100323c59a64d14551d091fff281.tar.gz
Cosmetic changes
- Altered some comments in the PKGBUILD. - Restructured the .install file to make it a little more robust to people manually digging around and removing files.
-rw-r--r--PKGBUILD3
-rw-r--r--update-ffmpeg.install16
2 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7576d4a133a0..dbc797993b58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,6 @@
# Contributor: Felix Golatofski <contact at xdfr dot de>
# Contributor: Matthew Zilvar <mattzilvar at gmail dot com>
# Contributor: Térence Clastres <t dot clastres at gmail dot com>
-# Modified PKGBUILD from https://aur.archlinux.org/packages/vivaldi/
### Info ###
pkgname=vivaldi-arm-bin
@@ -43,7 +42,7 @@ package() {
## SUID Sandbox ##
chmod 4755 "$pkgdir"/opt/$_pkgname/${_pkgname}-sandbox
- ## Install Icons ##
+ ## Icons ##
for res in 16 22 24 32 48 64 128 256; do
install -dm0755 "$pkgdir"/usr/share/icons/hicolor/${res}x${res}/apps
ln -fs \
diff --git a/update-ffmpeg.install b/update-ffmpeg.install
index 5cad48207065..b7f32091813d 100644
--- a/update-ffmpeg.install
+++ b/update-ffmpeg.install
@@ -8,24 +8,26 @@ _nc='\033[0m' # No colour.
### Post Install ###
post_install() {
## Install ffmpeg ##
- echo -e "${_yellow}Installing proprietary media codecs ...${_nc}"
- cd /opt/$_pkgname
- ./update-ffmpeg
+ if [ -f /opt/$_pkgname/update-ffmpeg ]; then
+ echo -e "${_yellow}Installing proprietary media codecs ...${_nc}"
+ /opt/$_pkgname/update-ffmpeg
+ fi
}
### Post Upgrade ###
post_upgrade() {
## Update ffmpeg ##
- echo -e "${_yellow}Updating proprietary media codecs ...${_nc}"
- cd /opt/$_pkgname
- ./update-ffmpeg
+ if [ -f /opt/$_pkgname/update-ffmpeg ]; then
+ echo -e "${_yellow}Updating proprietary media codecs ...${_nc}"
+ /opt/$_pkgname/update-ffmpeg
+ fi
}
### Post Remove ###
post_remove() {
## Remove ffmpeg ##
- echo -e "${_yellow}Removing proprietary media codecs ...${_nc}"
if [ -d /var/opt/$_pkgname ]; then
+ echo -e "${_yellow}Removing proprietary media codecs ...${_nc}"
rm -rf /var/opt/$_pkgname
fi
}