summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClastres Térence2018-01-01 17:00:51 +0100
committerClastres Térence2018-01-01 17:00:51 +0100
commitf2d9d2b4a975f93574b7e71cdc18834f30ddec77 (patch)
tree9747025be1432f26fee8146405a8d92f6c3ee207
downloadaur-f2d9d2b4a975f93574b7e71cdc18834f30ddec77.tar.gz
Initial commit
-rw-r--r--.INSTALL39
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD55
-rw-r--r--README.md4
4 files changed, 130 insertions, 0 deletions
diff --git a/.INSTALL b/.INSTALL
new file mode 100644
index 000000000000..f60628dabc75
--- /dev/null
+++ b/.INSTALL
@@ -0,0 +1,39 @@
+available()
+{
+ command -v $1 >/dev/null 2>&1
+}
+
+integration() {
+
+ # Setup Menus
+ if available update-desktop-database
+ then
+ update-desktop-database -q /usr/share/applications
+ fi
+
+ # Setup MIME types
+ if available update-mime-database
+ then
+ update-mime-database /usr/share/mime >/dev/null
+ fi
+
+ # Setup Icons
+ touch -c /usr/share/icons/hicolor
+ if available gtk-update-icon-cache
+ then
+ gtk-update-icon-cache -tq /usr/share/icons/hicolor
+ fi
+
+}
+
+post_install() {
+ integration
+}
+
+post_upgrade() {
+ integration
+}
+
+post_remove() {
+ integration
+}
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..80259224dded
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = vivaldi-rpi
+ pkgdesc = An advanced browser made with the power user in mind for Raspberry Pi
+ pkgver = 1.13.1008.40
+ pkgrel = 1
+ url = https://vivaldi.com
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = custom
+ makedepends = w3m
+ depends = gtk3
+ depends = libcups
+ depends = nss
+ depends = gconf
+ depends = alsa-lib
+ depends = libxss
+ depends = ttf-font
+ depends = desktop-file-utils
+ depends = shared-mime-info
+ depends = hicolor-icon-theme
+ optdepends = vivaldi-ffmpeg-codecs: playback of proprietary video/audio
+ optdepends = pepper-flash: flash support
+ optdepends = google-chrome: Widevine DRM Plugin
+ optdepends = vivaldi-widevine: Widevine DRM Plugin
+ optdepends = libnotify: native notifications
+ options = !strip
+ options = !zipman
+ source = https://downloads.vivaldi.com/stable/vivaldi-stable_1.13.1008.40-1_armhf.deb
+ sha512sums = 7b636a8d4f9be825c126863e6761e2e0a1c4a07147984872f46678f1014b70c712071ba7ce15e65d0253d37a70c08e74a2a9fefa0c1f6c356445cb9e2dbcc84a
+
+pkgname = vivaldi-rpi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fea684c8d35d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Térence Clastres <t dot clastres at gmail dot com>
+# Modified PKGBUILD from https://aur.archlinux.org/packages/vivaldi/
+
+pkgname=vivaldi-rpi
+pkgver=1.13.1008.40
+pkgrel=1
+pkgdesc='An advanced browser made with the power user in mind for Raspberry Pi'
+arch=('armv6h' 'armv7h' 'aarch64')
+url="https://vivaldi.com"
+options=(!strip !zipman)
+license=('custom')
+depends=('gtk3' 'libcups' 'nss' 'gconf' 'alsa-lib' 'libxss' 'ttf-font' 'desktop-file-utils' 'shared-mime-info' 'hicolor-icon-theme')
+makedepends=('w3m')
+optdepends=(
+ 'vivaldi-ffmpeg-codecs: playback of proprietary video/audio'
+ 'pepper-flash: flash support'
+ 'google-chrome: Widevine DRM Plugin'
+ 'vivaldi-widevine: Widevine DRM Plugin'
+ 'libnotify: native notifications'
+)
+source=("https://downloads.vivaldi.com/stable/vivaldi-stable_${pkgver}-1_armhf.deb")
+sha512sums=('7b636a8d4f9be825c126863e6761e2e0a1c4a07147984872f46678f1014b70c712071ba7ce15e65d0253d37a70c08e74a2a9fefa0c1f6c356445cb9e2dbcc84a')
+
+prepare() {
+ tar -xf data.tar.xz
+}
+
+package() {
+ cp -a {opt,usr} "$pkgdir"
+
+ # suid sandbox
+ chmod 4755 "$pkgdir/opt/vivaldi/vivaldi-sandbox"
+
+ # make /usr/bin/vivaldi-stable available
+ binf="$pkgdir/usr/bin/vivaldi-stable"
+ if [[ ! -e "$binf" ]] && [[ ! -f "$binf" ]] && [[ ! -L "$binf" ]]; then
+ install -dm755 "$pkgdir/usr/bin"
+ ln -s /opt/vivaldi/vivaldi "$binf"
+ fi
+
+ # install icons
+ for res in 16 22 24 32 48 64 128 256; do
+ install -Dm644 "$pkgdir/opt/vivaldi/product_logo_${res}.png" \
+ "$pkgdir/usr/share/icons/hicolor/${res}x${res}/apps/vivaldi.png"
+ done
+
+ # license
+ install -dm755 "$pkgdir/usr/share/licenses/$pkgname"
+ strings "$pkgdir/opt/vivaldi/locales/en-US.pak" \
+ | tr '\n' ' ' \
+ | sed -rne 's/.*(<html lang.*>.*html>).*/\1/p' \
+ | w3m -I 'utf-8' -T 'text/html' \
+ > "$pkgdir/usr/share/licenses/$pkgname/eula.txt"
+}
+
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..5fdd7cfd2b66
--- /dev/null
+++ b/README.md
@@ -0,0 +1,4 @@
+vivaldi
+========================================
+
+url = https://vivaldi.com