summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMusikolo2021-03-20 12:48:55 -0500
committerMusikolo2021-03-20 12:48:55 -0500
commitceef19fd5ea94d5bcdcefb4051228b6492c3a138 (patch)
tree5f1b86276dc6981ac8bdd84e5f87c794e6bafe15
parenta2b7b3d25600a9ebf81eb178994fe38ae94ed0df (diff)
downloadaur-ceef19fd5ea94d5bcdcefb4051228b6492c3a138.tar.gz
Chrome version 89.0.4389.72; Plugin version 4.10.2209.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--get_cdm_version.c25
3 files changed, 9 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 401f1b924218..0b18559c7cb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu May 21 03:21:05 UTC 2020
+# Sat Mar 20 17:45:38 UTC 2021
pkgbase = vivaldi-widevine
pkgdesc = A browser plugin designed for the viewing of premium video content, standalone for vivaldi
- pkgver = 4.10.1679.0
+ pkgver = 4.10.2209.0
pkgrel = 1
epoch = 1
url = https://www.widevine.com/
@@ -15,12 +15,8 @@ pkgbase = vivaldi-widevine
depends = nss
conflicts = google-chrome
options = !strip
- source = chrome-eula_text.html::https://www.google.com/intl/en/chrome/privacy/eula_text.html
- source = https://dl.google.com/linux/deb/pool/main/g/google-chrome-stable/google-chrome-stable_83.0.4103.61-1_amd64.deb
- source = get_cdm_version.c
- sha256sums = SKIP
- sha256sums = adba3364137bfd377a590ba7256052f59faf34be6ff36e3d3d4ac467a60a51f2
- sha256sums = 3fda44a5b8b222434530f27923568de1fda1eb0caa8621b56a8b2a6a2a2e3d5d
+ source = https://dl.google.com/linux/deb/pool/main/g/google-chrome-stable/google-chrome-stable_89.0.4389.72-1_amd64.deb
+ sha256sums = 8b3ee655bf8c8114f4a6494c2161938582ad8cbe683251760ebe0363f2eb4dc0
pkgname = vivaldi-widevine
diff --git a/PKGBUILD b/PKGBUILD
index 483c6524bb02..346debce530b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,18 @@
pkgname=vivaldi-widevine
pkgdesc="A browser plugin designed for the viewing of premium video content, standalone for vivaldi"
-pkgver=4.10.1679.0
-_chrome_ver=83.0.4103.61
+pkgver=4.10.2209.0
+_chrome_ver=89.0.4389.72
pkgrel=1
epoch=1
arch=('x86_64')
url='https://www.widevine.com/'
-source=("chrome-eula_text.html::https://www.google.com/intl/en/chrome/privacy/eula_text.html"
- "https://dl.google.com/linux/deb/pool/main/g/google-chrome-stable/google-chrome-stable_${_chrome_ver}-1_amd64.deb"
- get_cdm_version.c)
+source=("https://dl.google.com/linux/deb/pool/main/g/google-chrome-stable/google-chrome-stable_${_chrome_ver}-1_amd64.deb")
options=("!strip")
license=('custom')
depends=('gcc-libs' 'glib2' 'glibc' 'nspr' 'nss')
conflicts=('google-chrome')
-sha256sums=('SKIP'
- 'adba3364137bfd377a590ba7256052f59faf34be6ff36e3d3d4ac467a60a51f2'
- '3fda44a5b8b222434530f27923568de1fda1eb0caa8621b56a8b2a6a2a2e3d5d')
+sha256sums=('8b3ee655bf8c8114f4a6494c2161938582ad8cbe683251760ebe0363f2eb4dc0')
prepare() {
bsdtar -x --strip-components 4 -f data.tar.xz opt/google/chrome/WidevineCdm
@@ -32,5 +28,5 @@ pkgver() {
package() {
install -dm755 "$pkgdir/opt/google/chrome/"
cp -a WidevineCdm "$pkgdir/opt/google/chrome/"
- install -Dm644 chrome-eula_text.html -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 WidevineCdm/LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
}
diff --git a/get_cdm_version.c b/get_cdm_version.c
deleted file mode 100644
index ac77bd7cf05a..000000000000
--- a/get_cdm_version.c
+++ /dev/null
@@ -1,25 +0,0 @@
-#include <stdio.h>
-#include <stdlib.h>
-#include <dlfcn.h>
-
-int main(int argc, char *argv[]) {
- void *handle;
- const char *(*get_cdm_version)();
-
- handle = dlopen("./libwidevinecdm.so", RTLD_LAZY);
- if (!handle) {
- fprintf(stderr, "%s\n", dlerror());
- exit(EXIT_FAILURE);
- }
-
- get_cdm_version = dlsym(handle, "GetCdmVersion");
- if (!get_cdm_version) {
- fprintf(stderr, "%s\n", dlerror());
- exit(EXIT_FAILURE);
- }
-
- printf("%s\n", get_cdm_version());
- dlclose(handle);
- exit(EXIT_SUCCESS);
-}
-