summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-08-30 21:17:20 -0500
committerLuis Martinez2021-08-30 21:17:20 -0500
commit0d8771a368e18c4efa485324b3278c128a98b333 (patch)
tree1c1cb19c3b52622b92fb9c35ff2b2123dc548e26
parentdfe38aa81af61d2742f31c5db3514b8a93aa8b10 (diff)
downloadaur-0d8771a368e18c4efa485324b3278c128a98b333.tar.gz
add GPG keys
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD25
2 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6834e807ecdd..6d4b4680192a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vivarium-git
pkgdesc = A dynamic tiling Wayland compositor inspired by xmonad
- pkgver = 0.0.3.r15.g460fd72
- pkgrel = 2
+ pkgver = 0.0.4.r3.gd7074de
+ pkgrel = 1
url = https://github.com/inclement/vivarium
install = vivarium-git.install
arch = x86_64
@@ -16,8 +16,9 @@ pkgbase = vivarium-git
optdepends = waybar: Bar program for Wayland; the only tested one
provides = vivarium
conflicts = vivarium
- source = git+https://github.com/inclement/vivarium
- validpgpkeys = 4AEE18F83AFDEB23
+ backup = etc/vivarium/config.toml
+ source = git+https://github.com/inclement/vivarium?signed
+ validpgpkeys = 5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23
md5sums = SKIP
pkgname = vivarium-git
diff --git a/PKGBUILD b/PKGBUILD
index 49c32af240de..3d47e64d1d94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,34 @@
-# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=vivarium-git
-pkgver=0.0.3.r15.g460fd72
-pkgrel=2
+pkgver=0.0.4.r3.gd7074de
+pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor inspired by xmonad"
arch=('x86_64')
url="https://github.com/inclement/vivarium"
license=('GPL3')
depends=('wlroots>=0.14.0' 'wlroots<0.15.0' 'xcb-util-renderutil')
makedepends=('git' 'meson' 'wayland-protocols')
-optdepends=('xorg-xwayland: X.org support under Wayland'
- 'waybar: Bar program for Wayland; the only tested one')
+optdepends=(
+ 'xorg-xwayland: X.org support under Wayland'
+ 'waybar: Bar program for Wayland; the only tested one')
provides=('vivarium')
conflicts=('vivarium')
+backup=('etc/vivarium/config.toml')
install="$pkgname.install"
-source=("git+$url")
+source=("git+$url?signed")
md5sums=('SKIP')
-validpgpkeys=('4AEE18F83AFDEB23')
+validpgpkeys=('5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23')
pkgver() {
- cd vivarium
- git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+ git -C vivarium describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
}
build() {
- meson --prefix=/usr --buildtype=release -Ddevelop=false -Dwerror=false vivarium build
- meson compile -C build
+ meson --prefix=/usr --buildtype=release -Ddevelop=false -Dwerror=false vivarium build
+ meson compile -C build
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ DESTDIR="$pkgdir" meson install -C build
}