summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-10-16 15:34:52 -0500
committerLuis Martinez2022-10-16 15:34:52 -0500
commita552680895caf6c7bacbcd6c6b53c98570d9f5ce (patch)
treecb33a12270d9fb6cdd4b6c815e0c1dd0ecbe3da6
parent0d8771a368e18c4efa485324b3278c128a98b333 (diff)
downloadaur-a552680895caf6c7bacbcd6c6b53c98570d9f5ce.tar.gz
fix wlroots dep
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD28
2 files changed, 20 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d4b4680192a..f63654b2b475 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vivarium-git
pkgdesc = A dynamic tiling Wayland compositor inspired by xmonad
- pkgver = 0.0.4.r3.gd7074de
+ pkgver = 0.0.4.r24.g40b1038
pkgrel = 1
url = https://github.com/inclement/vivarium
install = vivarium-git.install
@@ -9,15 +9,15 @@ pkgbase = vivarium-git
makedepends = git
makedepends = meson
makedepends = wayland-protocols
- depends = wlroots>=0.14.0
- depends = wlroots<0.15.0
+ makedepends = cpptoml
+ depends = wlroots
depends = xcb-util-renderutil
optdepends = xorg-xwayland: X.org support under Wayland
optdepends = waybar: Bar program for Wayland; the only tested one
provides = vivarium
conflicts = vivarium
backup = etc/vivarium/config.toml
- source = git+https://github.com/inclement/vivarium?signed
+ source = vivarium::git+https://github.com/inclement/vivarium?signed
validpgpkeys = 5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3d47e64d1d94..c7e3d8b9cf80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,38 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=vivarium-git
-pkgver=0.0.4.r3.gd7074de
+_pkg="${pkgname%-git}"
+pkgver=0.0.4.r24.g40b1038
pkgrel=1
pkgdesc="A dynamic tiling Wayland compositor inspired by xmonad"
arch=('x86_64')
url="https://github.com/inclement/vivarium"
license=('GPL3')
-depends=('wlroots>=0.14.0' 'wlroots<0.15.0' 'xcb-util-renderutil')
-makedepends=('git' 'meson' 'wayland-protocols')
-optdepends=(
- 'xorg-xwayland: X.org support under Wayland'
- 'waybar: Bar program for Wayland; the only tested one')
-provides=('vivarium')
-conflicts=('vivarium')
-backup=('etc/vivarium/config.toml')
+depends=('wlroots' 'xcb-util-renderutil')
+makedepends=('git' 'meson' 'wayland-protocols' 'cpptoml')
+optdepends=('xorg-xwayland: X.org support under Wayland'
+ 'waybar: Bar program for Wayland; the only tested one')
+provides=("$_pkg")
+conflicts=("$_pkg")
+backup=("etc/$_pkg/config.toml")
install="$pkgname.install"
-source=("git+$url?signed")
+source=("$_pkg::git+$url?signed")
md5sums=('SKIP')
validpgpkeys=('5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23')
pkgver() {
- git -C vivarium describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+ git -C "$_pkg" describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
}
build() {
- meson --prefix=/usr --buildtype=release -Ddevelop=false -Dwerror=false vivarium build
+ meson --prefix=/usr --buildtype=release -Ddevelop=false -Dwerror=false "$_pkg" build
meson compile -C build
}
+# check() {
+# meson test -C build
+# }
+
package() {
DESTDIR="$pkgdir" meson install -C build
}