summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-03-16 15:24:19 -0500
committerLuis Martinez2021-03-16 15:24:19 -0500
commitca66f233308bfb8ba72f1d3551f7256f05bce6bc (patch)
tree831b769e47976d588e4b7308e69d85fdb3c9bd9a
downloadaur-ca66f233308bfb8ba72f1d3551f7256f05bce6bc.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a43e427cca3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = vivarium-git
+ pkgdesc = A dynamic tiling wlroots compositor inspired by xmonad
+ pkgver = 0.0.1.r2.g28212ea
+ pkgrel = 1
+ url = https://github.com/inclement/vivarium
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = wayland-protocols
+ depends = wlroots
+ depends = xcb-util-renderutil
+ optdepends = xorg-xwayland: X.org support under Wayland
+ provides = vivarium
+ conflicts = vivarium
+ source = git+https://github.com/inclement/vivarium
+ md5sums = SKIP
+
+pkgname = vivarium-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..06e32a04b1d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: lmartinez-mirror
+pkgname=vivarium-git
+pkgver=0.0.1.r2.g28212ea
+pkgrel=1
+pkgdesc="A dynamic tiling Wayland compositor inspired by xmonad"
+arch=('x86_64')
+url="https://github.com/inclement/vivarium"
+license=('GPL3')
+depends=('wlroots' 'xcb-util-renderutil')
+makedepends=('git' 'meson' 'wayland-protocols')
+optdepends=('xorg-xwayland: X.org support under Wayland')
+provides=('vivarium')
+conflicts=('vivarium')
+source=("git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd vivarium
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+}
+
+build() {
+ meson --prefix=/usr --buildtype=release -Ddevelop=false -Dwerror=false vivarium build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}