summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorperigoso2020-09-14 13:06:27 +0100
committerperigoso2020-09-14 13:06:27 +0100
commit23554f9b5727f34bc9581144bfbcb8e9217b71ba (patch)
tree4beb7878fa8b429a192d1245eef45fe9760ae8aa
downloadaur-23554f9b5727f34bc9581144bfbcb8e9217b71ba.tar.gz
release 1.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cccd8b5c464f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vizex
+ pkgdesc = vizex is the terminal program for the UNIX/Linux systems which helps the user to visualize the disk space usage for every partition and media on the user's machine.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/bexxmodd/vizex
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-click
+ depends = python-colored
+ depends = python-psutil
+ source = https://github.com/bexxmodd/vizex/archive/1.0.tar.gz
+ sha256sums = 77cf21f4d7a78b18cf6f804c7e371b42d599b4d9c7ae7b9a1784db74a9320889
+
+pkgname = vizex
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f3d6d1c2954
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Rafael Silva <silvagracarafael@gmail.com>
+
+pkgname=vizex
+pkgver=1.0
+pkgrel=1
+pkgdesc="vizex is the terminal program for the UNIX/Linux systems which helps the user to visualize the disk space usage for every partition and media on the user's machine."
+arch=('any')
+url="https://github.com/bexxmodd/vizex"
+depends=('python' 'python-click' 'python-colored' 'python-psutil')
+makedepends=('python-setuptools')
+license=('MIT')
+source=(https://github.com/bexxmodd/${pkgname}/archive/${pkgver}.tar.gz)
+sha256sums=('77cf21f4d7a78b18cf6f804c7e371b42d599b4d9c7ae7b9a1784db74a9320889')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/license.txt
+}