summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormorganamilo2018-09-13 03:23:41 +0100
committermorganamilo2018-09-13 03:23:41 +0100
commit78586cb96716302369604b5c66d00704ff3ffd31 (patch)
treec216c27a87ab3287539cc27a97a351001cb18c0b
downloadaur-78586cb96716302369604b5c66d00704ff3ffd31.tar.gz
Initial commit
-rw-r--r--.SRCINFO44
-rw-r--r--PKGBUILD56
-rw-r--r--setup_vk91
-rw-r--r--setup_vk9-321
-rw-r--r--setup_vk9-i686.verb14
-rw-r--r--setup_vk9-x86_64.verb14
6 files changed, 130 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b61cb90db0bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+pkgbase = vk9-bin
+ pkgdesc = Direct3D 9 compatibility layer using Vulkan
+ pkgver = 0.27.0
+ pkgrel = 1
+ url = https://github.com/doitsujin/vk9
+ arch = x86_64
+ arch = i686
+ license = custom:zlib/libpng
+ options = !strip
+ source = setup_vk9-x86_64.verb
+ source = setup_vk9-i686.verb
+ source = setup_vk9
+ source = setup_vk9-32
+ md5sums = 6600eabb853962260068f86d9a70aed1
+ md5sums = aaf4cb6c959a9dfcab2ec8ec8f802909
+ md5sums = 42de90e0a79a9eef2410799044521f39
+ md5sums = c4d6aafd335443ddc5d0cc5495511db3
+ source_x86_64 = vk9-bin-0.27.0-x86_64.zip::https://github.com/disks86/VK9/releases/download/0.27.0/0.27.0-bin-x86_64-Release.zip
+ md5sums_x86_64 = 22afc73d4e7d1b3c7d67b1e470a6c5c3
+ source_i686 = vk9-bin-0.27.0-x86_64.zip::https://github.com/disks86/VK9/releases/download/0.27.0/0.27.0-bin-x86-Release.zip
+ md5sums_i686 = 22afc73d4e7d1b3c7d67b1e470a6c5c3
+
+pkgname = vk9-bin
+ arch = x86_64
+ arch = i686
+ depends = vk9-data
+ depends = vulkan-icd-loader
+ depends = wine
+ depends = winetricks
+ provides = vk9
+ conflicts = vk9
+
+pkgname = lib32-vk9-bin
+ arch = x86_64
+ depends = vk9-data
+ provides = lib32-vk9
+ conflicts = lib32-vk9
+
+pkgname = vk9-data-bin
+ arch = any
+ provides = vk9-data
+ conflicts = vk9-data
+ backup = etc/VK9.conf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9f07a194a887
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Anna <morganamilo@gmail.com>
+
+pkgnamebase=vk9-bin
+pkgname=(vk9-bin lib32-vk9-bin vk9-data-bin)
+pkgver=0.27.0
+pkgrel=1
+pkgdesc='Direct3D 9 compatibility layer using Vulkan'
+arch=('x86_64' 'i686')
+url='https://github.com/doitsujin/vk9'
+license=('custom:zlib/libpng')
+options=(!strip)
+source=(setup_vk9-{x86_64,i686}.verb setup_vk9{,-32})
+source_x86_64=("$pkgname-$pkgver-$CARCH.zip::https://github.com/disks86/VK9/releases/download/$pkgver/$pkgver-bin-x86_64-Release.zip")
+source_i686=("$pkgname-$pkgver-$CARCH.zip::https://github.com/disks86/VK9/releases/download/$pkgver/$pkgver-bin-x86-Release.zip")
+md5sums=('6600eabb853962260068f86d9a70aed1'
+ 'aaf4cb6c959a9dfcab2ec8ec8f802909'
+ '42de90e0a79a9eef2410799044521f39'
+ 'c4d6aafd335443ddc5d0cc5495511db3')
+md5sums_x86_64=('22afc73d4e7d1b3c7d67b1e470a6c5c3')
+md5sums_i686=('22afc73d4e7d1b3c7d67b1e470a6c5c3')
+
+package_vk9-bin() {
+ arch=('x86_64' 'i686')
+ depends=('vk9-data' 'vulkan-icd-loader' 'wine' 'winetricks')
+ provides=('vk9')
+ conflicts=('vk9')
+
+ install -Dm644 "d3d9.dll" "$pkgdir/usr/lib/d3d9.dll"
+ install -Dm755 "setup_vk9" "$pkgdir/usr/bin/setup_vk9"
+ install -Dm644 "setup_vk9-$CARCH.verb" "$pkgdir/usr/share/vk9/setup_vk9.verb"
+}
+
+
+package_lib32-vk9-bin() {
+ arch=('x86_64')
+ depends=('vk9-data')
+ provides=('lib32-vk9')
+ conflicts=('lib32-vk9')
+
+ install -Dm644 "d3d9.dll" "$pkgdir/usr/lib32/d3d9.dll"
+ install -Dm755 "setup_vk9-32" "$pkgdir/usr/bin/setup_vk9-32"
+ install -Dm644 "setup_vk9-i686.verb" "$pkgdir/usr/share/lib32-vk9/setup_vk9.verb"
+}
+
+package_vk9-data-bin() {
+ arch=('any')
+ provides=('vk9-data')
+ conflicts=('vk9-data')
+ backup=('etc/VK9.conf')
+
+ install -Dm644 "VK9.conf" "$pkgdir/etc/VK9.conf"
+
+ for f in VertexBuffer*; do
+ install -Dm644 "$f" "$pkgdir/usr/share/vk9/$f"
+ done
+}
diff --git a/setup_vk9 b/setup_vk9
new file mode 100644
index 000000000000..297b95f75ca8
--- /dev/null
+++ b/setup_vk9
@@ -0,0 +1 @@
+winetricks --force /usr/share/vk9/setup_vk9.verb
diff --git a/setup_vk9-32 b/setup_vk9-32
new file mode 100644
index 000000000000..811f829ac4ca
--- /dev/null
+++ b/setup_vk9-32
@@ -0,0 +1 @@
+winetricks --force /usr/share/lib32-vk9/setup_vk9.verb
diff --git a/setup_vk9-i686.verb b/setup_vk9-i686.verb
new file mode 100644
index 000000000000..4d5e572ba9f3
--- /dev/null
+++ b/setup_vk9-i686.verb
@@ -0,0 +1,14 @@
+w_metadata setup_vk9 dlls \
+ title="VK9" \
+ publisher="Christopher Schaefer" \
+ year="2018" \
+ media="manual_download" \
+ file1="d3d9.dll" \
+ installed_file1="$W_SYSTEM32_DLLS_WIN\\d3d9.dll" \
+ homepage="https://github.com/disks86/VK9" \
+ unattended="yes"
+
+load_setup_vk9() {
+ w_try ln -fs "/usr/lib/$file1" "$W_SYSTEM32_DLLS/$file1"
+ w_override_dlls native d3d9
+}
diff --git a/setup_vk9-x86_64.verb b/setup_vk9-x86_64.verb
new file mode 100644
index 000000000000..23141095d5df
--- /dev/null
+++ b/setup_vk9-x86_64.verb
@@ -0,0 +1,14 @@
+w_metadata setup_vk9 dlls \
+ title="VK9" \
+ publisher="Christopher Schaefer" \
+ year="2018" \
+ media="manual_download" \
+ file1="d3d9.dll" \
+ installed_file1="$W_SYSTEM64_DLLS_WIN64\\d3d9.dll" \
+ homepage="https://github.com/disks86/VK9" \
+ unattended="yes"
+
+load_setup_vk9() {
+ w_try ln -fs "/usr/lib/$file1" "$W_SYSTEM64_DLLS/$file1"
+ w_override_dlls native d3d9
+}