summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2024-01-27 04:05:07 +0200
committerStelios Tsampas2024-01-27 04:05:07 +0200
commit6ba2342fefa2fd05cdbbdf3ff9f189c3afe3ea92 (patch)
tree55d9a1a7836a9e3433fac6b98046c34cc9bf2697
parenteee17e200466021df827d4ec4a89cba1dcb9bcfc (diff)
downloadaur-6ba2342fefa2fd05cdbbdf3ff9f189c3afe3ea92.tar.gz
[vkd3d-proton-mingw] Revert to no-avx
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d7ac75e5935..b74b93e39d91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vkd3d-proton-mingw
pkgdesc = Fork of VKD3D. Development branches for Protons Direct3D 12 implementation
pkgver = 2.11.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/HansKristian-Work/vkd3d-proton
arch = x86_64
license = LGPL-2.1
diff --git a/PKGBUILD b/PKGBUILD
index f32880a5258a..20a972daab2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=vkd3d-proton-mingw
pkgver=2.11.1
-pkgrel=2
+pkgrel=3
pkgdesc='Fork of VKD3D. Development branches for Protons Direct3D 12 implementation'
arch=('x86_64')
url="https://github.com/HansKristian-Work/vkd3d-proton"
@@ -34,9 +34,9 @@ prepare() {
# If you want the "best" possible optimizations for your system you can use
# `-march=native` and remove the `-mtune=core-avx2` option.
-# local -a split=($CFLAGS)
-# local -A flags
-# for opt in "${split[@]}"; do flags["${opt%%=*}"]="${opt##*=}"; done
+ local -a split=($CFLAGS)
+ local -A flags
+ for opt in "${split[@]}"; do flags["${opt%%=*}"]="${opt##*=}"; done
local march="${flags["-march"]:-nocona}"
local mtune="${flags["-mtune"]:-core-avx2}"
@@ -61,8 +61,8 @@ prepare() {
# Relevant Wine issues
# https://bugs.winehq.org/show_bug.cgi?id=45289
# https://bugs.winehq.org/show_bug.cgi?id=43516
- CFLAGS+=" -mno-avx2"
- CXXFLAGS+=" -mno-avx2"
+ CFLAGS+=" -mno-avx2 -mno-avx"
+ CXXFLAGS+=" -mno-avx2 -mno-avx"
local cross_ldflags="$LDFLAGS"