summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2023-11-24 21:27:12 +0200
committerStelios Tsampas2023-11-24 21:27:12 +0200
commitd87e84c64282436e2f5957c68cc1764a7aeaa268 (patch)
treecc424bd9c9eb0da818a4f7bc44eb1c70cce40513
parent8091d013febfd1f2fc22f8041b947bda251173db (diff)
downloadaur-d87e84c64282436e2f5957c68cc1764a7aeaa268.tar.gz
[vkd3d-proton-mingw] Version 2.11
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD4
-rw-r--r--PKGBUILD.personal9
-rw-r--r--vkd3d-proton-extraopts.patch40
4 files changed, 32 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9aff7a09ca5..2fe457d76200 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vkd3d-proton-mingw
pkgdesc = Fork of VKD3D. Development branches for Protons Direct3D 12 implementation
- pkgver = 2.10
+ pkgver = 2.11
pkgrel = 1
url = https://github.com/HansKristian-Work/vkd3d-proton
arch = x86_64
@@ -13,17 +13,17 @@ pkgbase = vkd3d-proton-mingw
makedepends = mingw-w64-tools
provides = vkd3d-proton
provides = d3d12.dll
- provides = vkd3d-proton=2.10
+ provides = vkd3d-proton=2.11
conflicts = vkd3d-proton
conflicts = d3d12.dll
options = !lto
options = !staticlibs
- source = git+https://github.com/HansKristian-Work/vkd3d-proton.git#tag=v2.10
+ source = git+https://github.com/HansKristian-Work/vkd3d-proton.git#tag=v2.11
source = setup_vkd3d_proton
source = vkd3d-proton-extraopts.patch
sha256sums = SKIP
sha256sums = 67815eed9d47bbf610e23c6a1e4954c11371886c2ca73555dd9f1d6fbebb1323
- sha256sums = 8fc019d1dca8c52b6af96c40ff06a6c215aad3e713ae17be72c7422f1ba45634
+ sha256sums = bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362
pkgname = vkd3d-proton-mingw
depends = vulkan-icd-loader
diff --git a/PKGBUILD b/PKGBUILD
index ab8542f412df..cc716b6e40d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: loathingkernel <loathingkernel @at gmail .dot com>
pkgname=vkd3d-proton-mingw
-pkgver=2.10
+pkgver=2.11
pkgrel=1
pkgdesc='Fork of VKD3D. Development branches for Protons Direct3D 12 implementation'
arch=('x86_64')
@@ -106,4 +106,4 @@ package() {
sha256sums=('SKIP'
'67815eed9d47bbf610e23c6a1e4954c11371886c2ca73555dd9f1d6fbebb1323'
- '8fc019d1dca8c52b6af96c40ff06a6c215aad3e713ae17be72c7422f1ba45634')
+ 'bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362')
diff --git a/PKGBUILD.personal b/PKGBUILD.personal
index 6ebc8bce6881..249b68ca76b7 100644
--- a/PKGBUILD.personal
+++ b/PKGBUILD.personal
@@ -1,7 +1,7 @@
# Maintainer: loathingkernel <loathingkernel @at gmail .dot com>
pkgname=vkd3d-proton-mingw
-pkgver=2.10
+pkgver=2.11
pkgrel=1
pkgdesc='Fork of VKD3D. Development branches for Protons Direct3D 12 implementation'
arch=('x86_64')
@@ -16,6 +16,9 @@ source=(
"setup_vkd3d_proton"
"vkd3d-proton-extraopts.patch"
)
+#Optional patches
+source+=(
+)
prepare() {
cd vkd3d-proton
@@ -106,4 +109,6 @@ package() {
sha256sums=('SKIP'
'67815eed9d47bbf610e23c6a1e4954c11371886c2ca73555dd9f1d6fbebb1323'
- '8fc019d1dca8c52b6af96c40ff06a6c215aad3e713ae17be72c7422f1ba45634')
+ 'bcc15521e4c7f966a0192a1dabb7fb4935b33db39344ab5b861f9d81486f1362')
+sha256sums+=(
+)
diff --git a/vkd3d-proton-extraopts.patch b/vkd3d-proton-extraopts.patch
index 4e1e7430eac6..49a77f486f42 100644
--- a/vkd3d-proton-extraopts.patch
+++ b/vkd3d-proton-extraopts.patch
@@ -1,36 +1,34 @@
diff --git a/build-win32.txt b/build-win32.txt
-index c1f017a0..8fd09003 100644
+index a1406832..748f5c1e 100644
--- a/build-win32.txt
+++ b/build-win32.txt
-@@ -6,10 +6,10 @@ strip = 'i686-w64-mingw32-strip'
- widl = 'i686-w64-mingw32-widl'
+@@ -4,6 +4,12 @@ cpp = 'i686-w64-mingw32-g++'
+ ar = 'i686-w64-mingw32-ar'
+ strip = 'i686-w64-mingw32-strip'
++[built-in options]
++c_args=[@CARGS@]
++cpp_args=[@CXXARGS@]
++c_link_args = [@LDARGS@]
++cpp_link_args = [@LDARGS@]
++
[properties]
--c_args=['-msse', '-msse2']
--cpp_args=['-msse', '-msse2']
--c_link_args = ['-static', '-static-libgcc']
--cpp_link_args = ['-static', '-static-libgcc', '-static-libstdc++']
-+c_args=['-msse', '-msse2', @CARGS@]
-+cpp_args=['-msse', '-msse2', @CXXARGS@]
-+c_link_args = ['-static', '-static-libgcc', @LDARGS@]
-+cpp_link_args = ['-static', '-static-libgcc', '-static-libstdc++', @LDARGS@]
needs_exe_wrapper = true
- [host_machine]
diff --git a/build-win64.txt b/build-win64.txt
-index 8a241178..e3f619eb 100644
+index 1aee4626..7d2e84f4 100644
--- a/build-win64.txt
+++ b/build-win64.txt
-@@ -6,8 +6,10 @@ strip = 'x86_64-w64-mingw32-strip'
- widl = 'x86_64-w64-mingw32-widl'
+@@ -4,6 +4,12 @@ cpp = 'x86_64-w64-mingw32-g++'
+ ar = 'x86_64-w64-mingw32-ar'
+ strip = 'x86_64-w64-mingw32-strip'
- [properties]
--c_link_args = ['-static', '-static-libgcc']
--cpp_link_args = ['-static', '-static-libgcc', '-static-libstdc++']
++[built-in options]
+c_args=[@CARGS@]
+cpp_args=[@CXXARGS@]
-+c_link_args = ['-static', '-static-libgcc', @LDARGS@]
-+cpp_link_args = ['-static', '-static-libgcc', '-static-libstdc++', @LDARGS@]
++c_link_args = [@LDARGS@]
++cpp_link_args = [@LDARGS@]
++
+ [properties]
needs_exe_wrapper = true
- [host_machine]