summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2023-05-02 16:36:58 +0300
committerStelios Tsampas2023-05-02 16:36:58 +0300
commit518976dec81efe0b08c60a24fdcc01a2a470bf62 (patch)
treeefac2518c16302ec3dce358b5ca76665566b288a
parent939dbc3e50a7eb12c52ec56ba4553f8a14d1b04b (diff)
downloadaur-518976dec81efe0b08c60a24fdcc01a2a470bf62.tar.gz
[vkd3d-proton-mingw-git] Move depends() to package()
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD33
-rw-r--r--PKGBUILD.testing33
3 files changed, 38 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index afac68ad1712..81f6537f8d4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,9 +11,6 @@ pkgbase = vkd3d-proton-mingw-git
makedepends = git
makedepends = mingw-w64-gcc
makedepends = mingw-w64-tools
- depends = vulkan-icd-loader
- depends = lib32-vulkan-icd-loader
- depends = bash
provides = vkd3d-proton
provides = d3d12.dll
provides = vkd3d-proton=2.8.r180.g7b561f37
@@ -35,3 +32,7 @@ pkgbase = vkd3d-proton-mingw-git
sha256sums = 8fc019d1dca8c52b6af96c40ff06a6c215aad3e713ae17be72c7422f1ba45634
pkgname = vkd3d-proton-mingw-git
+ depends = vulkan-icd-loader
+ depends = lib32-vulkan-icd-loader
+ depends = wine
+ depends = bash
diff --git a/PKGBUILD b/PKGBUILD
index 31411cb31ab6..9a40931dc639 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,6 @@ pkgdesc='Fork of VKD3D. Development branches for Protons Direct3D 12 implementat
arch=('x86_64')
url="https://github.com/HansKristian-Work/vkd3d-proton"
license=('LGPL-2.1')
-depends=('vulkan-icd-loader' 'lib32-vulkan-icd-loader' 'bash')
makedepends=('ninja' 'meson>=0.43' 'glslang' 'git' 'mingw-w64-gcc' 'mingw-w64-tools')
provides=('vkd3d-proton' 'd3d12.dll' "vkd3d-proton=$pkgver")
conflicts=('vkd3d-proton' 'd3d12.dll')
@@ -44,17 +43,14 @@ prepare() {
# This overrides FLAGS from makepkg.conf, if you comment these you are on your own
# If you want the "best" possible optimizations for your system you can use
# `-march=native` and remove the `-mtune=core-avx2` option.
- # `-O2` is adjusted to `-O3` since AVX is disabled
export CFLAGS="-O2 -march=nocona -mtune=core-avx2 -pipe"
export CXXFLAGS="-O2 -march=nocona -mtune=core-avx2 -pipe"
export LDFLAGS="-Wl,-O1,--sort-common,--as-needed"
- # Uncomment to enable extra optimizations
- # Patch crossfiles with extra optimizations from makepkg.conf
- patch -p1 -i "$srcdir"/vkd3d-proton-extraopts.patch
- local cross_cflags="$CFLAGS"
- local cross_cxxflags="$CXXFLAGS"
- local cross_ldflags="$LDFLAGS"
+ # These flags are taken from Proton
+ CFLAGS+=" -mfpmath=sse -fwrapv -fno-strict-aliasing"
+ CXXFLAGS+=" -mfpmath=sse -fwrapv -fno-strict-aliasing -std=c++17"
+ LDFLAGS+=" -Wl,--file-alignment,4096"
# If using -march=native and the CPU supports AVX, launching a d3d9
# game can cause an Unhandled exception. The cause seems to be the
@@ -68,21 +64,24 @@ prepare() {
# Relevant Wine issues
# https://bugs.winehq.org/show_bug.cgi?id=45289
# https://bugs.winehq.org/show_bug.cgi?id=43516
- cross_cflags+=" -mno-avx2"
- cross_cxxflags+=" -mno-avx2"
+ CFLAGS+=" -mno-avx2"
+ CXXFLAGS+=" -mno-avx2"
+
+ # Uncomment to enable extra optimizations
+ # Patch crossfiles with extra optimizations from makepkg.conf
+ patch -p1 -i "$srcdir"/vkd3d-proton-extraopts.patch
- # These flags are taken from Proton, I don't know if there are issues with Arch wine.
- cross_cflags+=" -mfpmath=sse -fwrapv -fno-strict-aliasing -gdwarf-2 -gstrict-dwarf"
- cross_cxxflags+=" -mfpmath=sse -fwrapv -fno-strict-aliasing -gdwarf-2 -gstrict-dwarf -std=c++17"
- cross_ldflags+=" -Wl,--file-alignment,4096"
+ local cross_ldflags="$LDFLAGS"
+ local cross_cflags="$CFLAGS -mcmodel=small"
+ local cross_cxxflags="$CXXFLAGS -mcmodel=small"
sed -i build-win64.txt \
-e "s|@CARGS@|\'${cross_cflags// /\',\'}\'|g" \
-e "s|@CXXARGS@|\'${cross_cxxflags// /\',\'}\'|g" \
-e "s|@LDARGS@|\'${cross_ldflags// /\',\'}\'|g"
- cross_cflags+=" -mstackrealign -mno-avx"
- cross_cxxflags+=" -mstackrealign -mno-avx"
+ local cross_cflags="$CFLAGS -mstackrealign -mno-avx"
+ local cross_cxxflags="$CXXFLAGS -mstackrealign -mno-avx"
sed -i build-win32.txt \
-e "s|@CARGS@|\'${cross_cflags// /\',\'}\'|g" \
-e "s|@CXXARGS@|\'${cross_cxxflags// /\',\'}\'|g" \
@@ -110,6 +109,8 @@ build() {
}
package() {
+ depends=('vulkan-icd-loader' 'lib32-vulkan-icd-loader' 'wine' 'bash')
+
DESTDIR="$pkgdir" ninja -C "build/x86" install
DESTDIR="$pkgdir" ninja -C "build/x64" install
install -Dm 755 -t "$pkgdir/usr/share/vkd3d-proton" vkd3d-proton/setup_vkd3d_proton.sh
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index 89de5fb6f39d..005645cf01a0 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -7,7 +7,6 @@ pkgdesc='Fork of VKD3D. Development branches for Protons Direct3D 12 implementat
arch=('x86_64')
url="https://github.com/HansKristian-Work/vkd3d-proton"
license=('LGPL-2.1')
-depends=('vulkan-icd-loader' 'lib32-vulkan-icd-loader' 'bash')
makedepends=('ninja' 'meson>=0.43' 'glslang' 'git' 'mingw-w64-gcc' 'mingw-w64-tools')
provides=('vkd3d-proton' 'd3d12.dll' "vkd3d-proton=$pkgver")
conflicts=('vkd3d-proton' 'd3d12.dll')
@@ -44,17 +43,14 @@ prepare() {
# This overrides FLAGS from makepkg.conf, if you comment these you are on your own
# If you want the "best" possible optimizations for your system you can use
# `-march=native` and remove the `-mtune=core-avx2` option.
- # `-O2` is adjusted to `-O3` since AVX is disabled
export CFLAGS="-O2 -march=haswell -mtune=haswell -pipe -fno-semantic-interposition"
export CXXFLAGS="-O2 -march=haswell -mtune=haswell -pipe -fno-semantic-interposition"
export LDFLAGS="-Wl,-O1,--sort-common,--as-needed"
- # Uncomment to enable extra optimizations
- # Patch crossfiles with extra optimizations from makepkg.conf
- patch -p1 -i "$srcdir"/vkd3d-proton-extraopts.patch
- local cross_cflags="$CFLAGS"
- local cross_cxxflags="$CXXFLAGS"
- local cross_ldflags="$LDFLAGS"
+ # These flags are taken from Proton
+ CFLAGS+=" -mfpmath=sse -fwrapv -fno-strict-aliasing"
+ CXXFLAGS+=" -mfpmath=sse -fwrapv -fno-strict-aliasing -std=c++17"
+ LDFLAGS+=" -Wl,--file-alignment,4096"
# If using -march=native and the CPU supports AVX, launching a d3d9
# game can cause an Unhandled exception. The cause seems to be the
@@ -68,21 +64,24 @@ prepare() {
# Relevant Wine issues
# https://bugs.winehq.org/show_bug.cgi?id=45289
# https://bugs.winehq.org/show_bug.cgi?id=43516
- cross_cflags+=" -mno-avx2"
- cross_cxxflags+=" -mno-avx2"
+ CFLAGS+=" -mno-avx2"
+ CXXFLAGS+=" -mno-avx2"
+
+ # Uncomment to enable extra optimizations
+ # Patch crossfiles with extra optimizations from makepkg.conf
+ patch -p1 -i "$srcdir"/vkd3d-proton-extraopts.patch
- # These flags are taken from Proton, I don't know if there are issues with Arch wine.
- cross_cflags+=" -mfpmath=sse -fwrapv -fno-strict-aliasing -gdwarf-2 -gstrict-dwarf"
- cross_cxxflags+=" -mfpmath=sse -fwrapv -fno-strict-aliasing -gdwarf-2 -gstrict-dwarf -std=c++17"
- cross_ldflags+=" -Wl,--file-alignment,4096"
+ local cross_ldflags="$LDFLAGS"
+ local cross_cflags="$CFLAGS -mcmodel=small"
+ local cross_cxxflags="$CXXFLAGS -mcmodel=small"
sed -i build-win64.txt \
-e "s|@CARGS@|\'${cross_cflags// /\',\'}\'|g" \
-e "s|@CXXARGS@|\'${cross_cxxflags// /\',\'}\'|g" \
-e "s|@LDARGS@|\'${cross_ldflags// /\',\'}\'|g"
- cross_cflags+=" -mstackrealign -mno-avx"
- cross_cxxflags+=" -mstackrealign -mno-avx"
+ local cross_cflags="$CFLAGS -mstackrealign -mno-avx"
+ local cross_cxxflags="$CXXFLAGS -mstackrealign -mno-avx"
sed -i build-win32.txt \
-e "s|@CARGS@|\'${cross_cflags// /\',\'}\'|g" \
-e "s|@CXXARGS@|\'${cross_cxxflags// /\',\'}\'|g" \
@@ -110,6 +109,8 @@ build() {
}
package() {
+ depends=('vulkan-icd-loader' 'lib32-vulkan-icd-loader' 'wine' 'bash')
+
DESTDIR="$pkgdir" ninja -C "build/x86" install
DESTDIR="$pkgdir" ninja -C "build/x64" install
install -Dm 755 -t "$pkgdir/usr/share/vkd3d-proton" vkd3d-proton/setup_vkd3d_proton.sh