summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2022-10-27 20:01:13 +0300
committerStelios Tsampas2022-10-27 20:01:13 +0300
commit565fdc419abd3dcc8e334e1460f3b100c4e126cc (patch)
tree8148d2419d14f561ebd4e4be10eab6d9b5b237f2
parenta46d9a92dac22d0e8030cdf330b356512ad7f3bf (diff)
downloadaur-565fdc419abd3dcc8e334e1460f3b100c4e126cc.tar.gz
fix git submodules
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c489720f653..79576f11fdd3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vkd3d-proton-mingw-git
pkgdesc = Fork of VKD3D. Development branches for Protons Direct3D 12 implementation
- pkgver = 2.6.r0.g3e5aab6f
+ pkgver = 2.7.r0.g4df36617
pkgrel = 1
url = https://github.com/HansKristian-Work/vkd3d-proton
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = vkd3d-proton-mingw-git
depends = bash
provides = vkd3d-proton
provides = d3d12.dll
- provides = vkd3d-proton=2.6.r0.g3e5aab6f
+ provides = vkd3d-proton=2.7.r0.g4df36617
conflicts = vkd3d-proton
conflicts = d3d12.dll
options = !lto
diff --git a/PKGBUILD b/PKGBUILD
index 2082556273dd..54624a1f1eb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: loathingkernel <loathingkernel @at gmail .dot com>
pkgname=vkd3d-proton-mingw-git
-pkgver=2.6.r0.g3e5aab6f
+pkgver=2.7.r0.g4df36617
pkgrel=1
pkgdesc='Fork of VKD3D. Development branches for Protons Direct3D 12 implementation'
arch=('x86_64')
@@ -31,13 +31,13 @@ prepare() {
for submodule in subprojects/{dxil-spirv,Vulkan-Headers,SPIRV-Headers}; do
git submodule init "${submodule}"
- git config submodule."${submodule}".url "$srcdir"/"${submodule#*/}"
- git submodule update "${submodule}"
+ git submodule set-url "${submodule}" "$srcdir"/"${submodule#*/}"
+ git -c protocol.file.allow=always submodule update "${submodule}"
done
pushd subprojects/dxil-spirv
git submodule init third_party/spirv-headers
- git config submodule.third_party/spirv-headers.url "$srcdir"/SPIRV-Headers
- git submodule update third_party/spirv-headers
+ git submodule set-url third_party/spirv-headers "$srcdir"/SPIRV-Headers
+ git -c protocol.file.allow=always submodule update third_party/spirv-headers
popd
# By default export FLAGS used by proton and ignore makepkg
@@ -45,8 +45,8 @@ prepare() {
# If you want the "best" possible optimizations for your system you can use
# `-march=native` and remove the `-mtune=core-avx2` option.
# `-O2` is adjusted to `-O3` since AVX is disabled
- export CFLAGS="-O3 -march=nocona -mtune=core-avx2 -pipe"
- export CXXFLAGS="-O3 -march=nocona -mtune=core-avx2 -pipe"
+ export CFLAGS="-O2 -march=nocona -mtune=core-avx2 -pipe"
+ export CXXFLAGS="-O2 -march=nocona -mtune=core-avx2 -pipe"
export LDFLAGS="-Wl,-O1,--sort-common,--as-needed"
# Uncomment to enable extra optimizations