summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2022-07-16 21:07:37 +0300
committerStelios Tsampas2022-07-16 21:07:37 +0300
commita46d9a92dac22d0e8030cdf330b356512ad7f3bf (patch)
tree1bf7522e091d384a3d5450dbeaf29c1f8d8e57b3
parentd3fef9a49a7b3774426da20f52f3aa9c6e5a6eb1 (diff)
downloadaur-a46d9a92dac22d0e8030cdf330b356512ad7f3bf.tar.gz
Don't force symlinking
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
-rw-r--r--setup_vkd3d_proton2
3 files changed, 5 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07eb729e20a1..0c489720f653 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -31,7 +31,7 @@ pkgbase = vkd3d-proton-mingw-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 459d0de87abd6ea44ac71b4d7a005b6cfc9b2a75613ecda161223e95a22414d8
+ sha256sums = 67815eed9d47bbf610e23c6a1e4954c11371886c2ca73555dd9f1d6fbebb1323
sha256sums = 8fc019d1dca8c52b6af96c40ff06a6c215aad3e713ae17be72c7422f1ba45634
pkgname = vkd3d-proton-mingw-git
diff --git a/PKGBUILD b/PKGBUILD
index a2dbacd4e437..2082556273dd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -40,19 +40,6 @@ prepare() {
git submodule update third_party/spirv-headers
popd
- # Filter known bad flags before applying optimizations
- # Filter fstack-protector{ ,-all,-strong} flag for MingW.
- # https://github.com/Joshua-Ashton/d9vk/issues/476
- CFLAGS="${CFLAGS// -fstack-protector*([\-all|\-strong])/}"
- CXXFLAGS="${CXXFLAGS// -fstack-protector*([\-all|\-strong])/}"
- # Doesn't compile with these flags in MingW so remove them.
- # They are also filtered in Wine PKGBUILDs so remove them
- # for winelib versions too.
- CFLAGS="${CFLAGS/ -fno-plt/}"
- CXXFLAGS="${CXXFLAGS/ -fno-plt/}"
- LDFLAGS="${LDFLAGS/,-z,now/}"
- LDFLAGS="${LDFLAGS/,-z,relro/}"
-
# By default export FLAGS used by proton and ignore makepkg
# This overrides FLAGS from makepkg.conf, if you comment these you are on your own
# If you want the "best" possible optimizations for your system you can use
@@ -126,7 +113,8 @@ package() {
DESTDIR="$pkgdir" ninja -C "build/x86" install
DESTDIR="$pkgdir" ninja -C "build/x64" install
install -Dm 755 -t "$pkgdir/usr/share/vkd3d-proton" vkd3d-proton/setup_vkd3d_proton.sh
- install -Dm 644 -t "$pkgdir/usr/share/$pkgname" vkd3d-proton/LICENSE
+ install -Dm 644 -t "$pkgdir/usr/share/doc/$pkgname" vkd3d-proton/README.md
+ install -Dm 644 -t "$pkgdir/usr/share/licenses/$pkgname" vkd3d-proton/LICENSE
install -Dm 755 -t "$pkgdir/usr/bin" setup_vkd3d_proton
}
@@ -134,5 +122,5 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '459d0de87abd6ea44ac71b4d7a005b6cfc9b2a75613ecda161223e95a22414d8'
+ '67815eed9d47bbf610e23c6a1e4954c11371886c2ca73555dd9f1d6fbebb1323'
'8fc019d1dca8c52b6af96c40ff06a6c215aad3e713ae17be72c7422f1ba45634')
diff --git a/setup_vkd3d_proton b/setup_vkd3d_proton
index b13e0fc4da81..b30e67ea9751 100644
--- a/setup_vkd3d_proton
+++ b/setup_vkd3d_proton
@@ -1,2 +1,2 @@
#!/bin/sh
-/usr/share/vkd3d-proton/setup_vkd3d_proton.sh $1 --symlink
+/usr/share/vkd3d-proton/setup_vkd3d_proton.sh $@